Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Proposals » OSGi Enterprise Tools » export product to linux - segmentation fault(OSGi application exported to linux causes segmentation fault)
export product to linux - segmentation fault [message #803579] Tue, 21 February 2012 14:32
Kris Reid is currently offline Kris ReidFriend
Messages: 5
Registered: February 2012
Junior Member

I've got an OSGi that has a number of bundles where one of the bundles starts a Jetty web server.

The application runs perfect on my Windows laptop. I have created a new Product. File->New->Product.

When exporting this I select "Export for multiple platforms"
I select
Win32 (win32/x86)
linux (gtk/x86)

This then exports two two folders. The windows version contains a eclipse.exe that executes perfectly.
The linux version looks the same except the eclipse.exe is just called eclipse

I upload this to my remote server. The only thing I change is make the "eclipse" file executable. Then attempt to run it.
The only error I receive is Segmentation Fault. I am not running as root, just a standard user and am running from the user's home directory.

I am not sure what to look at next or even where to start.
The remote server is a hosted server running CentOS and has no graphical user interface

Any suggestions of what to look at or ideas of what is going on would be greatly appreciated



Previous Topic:Add Server Admin panel in own RCP Application
Next Topic:Exporting a bundle with dependencies with another bundles
Goto Forum:

Current Time: Tue Dec 01 16:31:37 GMT 2015

Powered by FUDForum. Page generated in 0.37034 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software