Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster » Difference between 3.6 and 3.7?
Difference between 3.6 and 3.7? [message #802222] Sun, 19 February 2012 16:26 Go to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 294
Registered: July 2009
Senior Member

Hi,

I had a solid build based on Buckminster 3.6. After installing Buckminster 3.7 the build is failing.

ERROR [0019] : java.io.FileNotFoundException: /home/targets/rdp8/plugins/com.ibm.etools.iseries.rse.ui_8.0.0.v20101014_1730/.project

The plugin is part of my target environment:

<target includeMode="feature" name="TDOMS Base Target">
<locations>
<location path="/home/targets/rdp8" type="Directory"/>
<location path="/home/targets/eclipse36" type="Directory"/>
</locations>
</target>


There is no .project at this location because it is not a source bundle.

any suggestion on how I can fix this?

Thanks in advance,

Wim
Re: Difference between 3.6 and 3.7? [message #802228 is a reply to message #802222] Sun, 19 February 2012 16:37 Go to previous messageGo to next message
Wim Jongman is currently offline Wim JongmanFriend
Messages: 294
Registered: July 2009
Senior Member

Here is some additional stuff about this bundle

com.ibm.etools.iseries.rse.ui:osgi.bundle/7.5.0: Using resolver Local resolver
com.ibm.etools.iseries.rse.ui:osgi.bundle/7.5.0: Trying provider local(materialized)
No materialization found for com.ibm.etools.iseries.rse.ui:osgi.bundle/7.5.0
com.ibm.etools.iseries.rse.ui:osgi.bundle/7.5.0: Trying provider local(workspace)
No open workspace project found that corresponds to com.ibm.etools.iseries.rse.ui:osgi.bundle/7.5.0
com.ibm.etools.iseries.rse.ui:osgi.bundle/7.5.0: Trying provider local(target)
com.ibm.etools.iseries.rse.ui:osgi.bundle/7.5.0: Found match 8.0.0.v20101014_1730


Re: Difference between 3.6 and 3.7? [message #871192 is a reply to message #802228] Fri, 11 May 2012 11:32 Go to previous messageGo to next message
Bob Reynders is currently offline Bob ReyndersFriend
Messages: 1
Registered: May 2012
Junior Member
Have you solved this problem?

We are having exactly the same problems with a bundle that resides in our target platform and I can't find anything on this problem other than this post.

ERROR   [0099] : java.io.FileNotFoundException: <snip>\.metadata\.plugins\org.eclipse.pde.core\.bundle_pool\plugins\de.mpicbg.tds.knime.scripting_1.1.0.201112121427\.project
Re: Difference between 3.6 and 3.7? [message #1446853 is a reply to message #871192] Fri, 17 October 2014 11:59 Go to previous message
Manuel Beckmann is currently offline Manuel BeckmannFriend
Messages: 1
Registered: October 2014
Junior Member
The thread is very old but we were confronted with the same problem a few days ago.

The problem was a result of a malformed build.properties file in the according bundle. The entry bin.includes did contain the build.properties-file itself. In addition to that the bundle was unpacked by installation.

I think Buckminster interprets the unpacked bundle including a build.properties-file as source bundle and therefore misses a .project-file.

Removing the unnecessary build.properties-file from binary build solved the problem for us.
Previous Topic:[Resolved] - Headless import issues upgrading from 3.5 to 4.4
Next Topic:Every buckminster action fails with NPE
Goto Forum:
  


Current Time: Fri Nov 28 17:18:16 GMT 2014

Powered by FUDForum. Page generated in 0.01636 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software