Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » Exception generation
Exception generation [message #794736] Thu, 09 February 2012 16:45 Go to next message
Paolo Missing name is currently offline Paolo Missing name
Messages: 9
Registered: January 2012
Junior Member
Hello.

I have this problem using Acceleo (2.Cool.
In project explorer I have a folder containing my model (called My.mydsl) and in a second folder I have a very simple Acceleo Project that investigate the model.

Lanching the "Generate.mtl" file, I have the following error :

An internal error occurred during: "Launching Generate".
java.lang.NullPointerException .

I have checked on the community for the same error, but I didn't find any useful info.
Can you please, give any suggestion about what to investigate because at the moment I am stuck on this error.

Regards.
Paolo.
Re: Exception generation [message #797296 is a reply to message #794736] Mon, 13 February 2012 09:41 Go to previous messageGo to next message
Stephane Begaudeau is currently offline Stephane Begaudeau
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

- Which version of Acceleo are you using? (Acceleo 2.8 does not have ".mtl" files it has ".mt" files so I'm pretty sure that you are using Acceleo 3.x)
- Is there something else in the stack trace (after the NullPointerException)?
- Can you isolate the problem in your generator and copy here the part of your generator that creates this problem?
- Does your generator generates files or does this error appear right at the beginning? (to determine if this is an error during the generation versus an error while loading the model).

Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau & @acceleo
Google+: stephane.begaudeau & acceleo
Blog: http://stephanebegaudeau.tumblr.com
Acceleo Documentation: http://docs.obeonetwork.com/acceleo



Re: Exception generation [message #798138 is a reply to message #797296] Tue, 14 February 2012 09:45 Go to previous messageGo to next message
Paolo Missing name is currently offline Paolo Missing name
Messages: 9
Registered: January 2012
Junior Member
Hi Stephane.

Many thank for your reply.

I realized I made an error copying my orginal .ecore project from the original workspace to a new one... the error was about the impossibility to create an "abstract class".
So in the new workspace I was using the template on an .ecore with an error, and so I had the "NullException" error.

I re-imported the .ecore project into the new workspace and now is working well.

I have a question for you : I checker my Acceleo version and I have 2.8.0 but when I created the template the extension was .mtl (Help --> About Eclipse --> Acceleo ).
Could you please give more explanation?

Best regards.

Paolo.
Re: Exception generation [message #799151 is a reply to message #798138] Wed, 15 February 2012 14:01 Go to previous message
Stephane Begaudeau is currently offline Stephane Begaudeau
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Paolo Mising name wrote on Tue, 14 February 2012 10:45

I have a question for you : I checker my Acceleo version and I have 2.8.0 but when I created the template the extension was .mtl (Help --> About Eclipse --> Acceleo ).
Could you please give more explanation?


Hi,

Well, you can have both version of Acceleo installed since Acceleo 2.x and Acceleo 3.X are two different products. The the plugins tab of the About Eclipse -> Installation Details dialog you may be able to see plugins named fr.obeo.acceleo for Acceleo 2.x and plugins named org.eclipse.acceleo for Acceleo 3.x

Acceleo 2 is the old version of Acceleo prior to its entrance in the Eclipse Foundation and it is only maintained today for critical bugs while Acceleo 3 is actively developed.

Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau & @acceleo
Google+: stephane.begaudeau & acceleo
Blog: http://stephanebegaudeau.tumblr.com
Acceleo Documentation: http://docs.obeonetwork.com/acceleo



Previous Topic:Xpand and Xtend2/Xtext
Next Topic:Errors in XPAND
Goto Forum:
  


Current Time: Wed Oct 22 08:07:07 GMT 2014

Powered by FUDForum. Page generated in 0.13209 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software