Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » AUT not appearing in Running AUTs View(Can't get Jubula to 'see' the AUT it has launched.)
icon5.gif  AUT not appearing in Running AUTs View [message #794602] Thu, 09 February 2012 13:38 Go to next message
Jessie Bannister is currently offline Jessie BannisterFriend
Messages: 3
Registered: February 2012
Junior Member
Hello,

I am currently trying to use Jubula to automate some tests of an RCP GUI and am having some problems getting the AUT to launch correctly.

If I use the toolbar Start AUT button, the application launches with nls_ errors where the field labels should be. The AUT appears in the Progress view as starting, but never appears in the Running AUTs View. I'm not able to use object map or observer mode.

If I use the autrun.exe to start the AUT (autrun.exe -i DEMO_AUTRUN -e C:\Users\jba\Desktop\JBA\Projects\XXXXX\PRIMUS\primus_20111020\eclipse\Primus_Client.exe -rcp -clean) the application launches with the correct field labels. However, the AUT neither appears in the Progress view nor in the Running AUTs View. I'm not able to use object map or observer mode.

I'm using Eclipse Release 3.6.2, SWT 3.6.2 and JRE 1.6.0., Jubula standalone version 5.2.00266. The RCP Jubula plugin is in my product plugins directory, so that doesn't seem to be the problem.

I've attached some screenshots including my Jubula configuration and would be extremely grateful if anyone can give me some tips on how to solve this issue.

JB

[Updated on: Thu, 09 February 2012 13:54]

Report message to a moderator

Re: AUT not appearing in Running AUTs View [message #794641 is a reply to message #794602] Thu, 09 February 2012 14:32 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1163
Registered: July 2009
Senior Member
Hi,

The first thing I would suspect is that you may need to add some information to the config.ini as described here.

HTH,
Alex
Re: AUT not appearing in Running AUTs View [message #794651 is a reply to message #794641] Thu, 09 February 2012 14:38 Go to previous messageGo to next message
Jessie Bannister is currently offline Jessie BannisterFriend
Messages: 3
Registered: February 2012
Junior Member
Hi Alex,

many thanks for your response! I unfortunately forgot to mention that I've already added org.eclipse.jubula.rc.rcp to the end of the osgi.bundles parameter in my product config.ini file.

Any other possibilities are very welcome!

Jessie
Re: AUT not appearing in Running AUTs View [message #794663 is a reply to message #794651] Thu, 09 February 2012 14:53 Go to previous messageGo to next message
Jessie Bannister is currently offline Jessie BannisterFriend
Messages: 3
Registered: February 2012
Junior Member
Success! It turned out there was a non-visible whitespace in the config.ini file which notepad (for reasons I can't really imagine) couldn't see. I was able to see it in an MS-Word file with non-print characters showing and once I removed it the app now is shown un the Running AUTs View.

Thanks for making me take another look at the config!

Jessie
Re: AUT not appearing in Running AUTs View [message #795212 is a reply to message #794663] Fri, 10 February 2012 07:50 Go to previous message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1163
Registered: July 2009
Senior Member
Ah, glad it helped in an indirect way Smile (especially since I will admit I would have otherwise been quite stumped Wink )

Alex
Previous Topic:How to test Browse for Folder window
Next Topic:How to test numbers with comma separator?
Goto Forum:
  


Current Time: Mon Nov 24 15:29:02 GMT 2014

Powered by FUDForum. Page generated in 0.02197 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software