Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Detaching/Attaching view causes TreeViewer white-out under non-Aero theme in Win7
Detaching/Attaching view causes TreeViewer white-out under non-Aero theme in Win7 [message #794507] Thu, 09 February 2012 11:27 Go to next message
Leung Wang Hei is currently offline Leung Wang HeiFriend
Messages: 62
Registered: July 2010
Member
My RCP with one TreeViewer is run under Win7. If using Aero theme,
everything works fine.

If changed to Basic or Classic Win7 theme, when detaching/attaching
views, the TreeViewer is white-out for 1 sec.

Canvas and other widgets does not have such issue.

I recalled there is a Win7 fix in 3.7 but seems does not fix this issue

I am using 3.7.1 build 20110916-0149

Thanks
Re: Detaching/Attaching view causes TreeViewer white-out under non-Aero theme in Win7 [message #848347 is a reply to message #794507] Wed, 18 April 2012 06:21 Go to previous message
Leung Wang Hei is currently offline Leung Wang HeiFriend
Messages: 62
Registered: July 2010
Member
OK. Always create viewer with SWT.VIRTUAL. That's it.


On 2/9/2012 7:27 PM, Leung Wang Hei wrote:
> My RCP with one TreeViewer is run under Win7. If using Aero theme,
> everything works fine.
>
> If changed to Basic or Classic Win7 theme, when detaching/attaching
> views, the TreeViewer is white-out for 1 sec.
>
> Canvas and other widgets does not have such issue.
>
> I recalled there is a Win7 fix in 3.7 but seems does not fix this issue
>
> I am using 3.7.1 build 20110916-0149
>
> Thanks
Previous Topic:Delete command
Next Topic:Add external Plug-in problem
Goto Forum:
  


Current Time: Thu Nov 27 04:46:32 GMT 2014

Powered by FUDForum. Page generated in 0.01538 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software