Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [CDO] Download sources of version 4.0
[CDO] Download sources of version 4.0 [message #794442] Thu, 09 February 2012 09:46 Go to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

I was downloading the source code for version 4.0 according to instructions on page http://wiki.eclipse.org/CDO_Source_Installation

Everything works fine untile I reach the step about materialization of the workspace contents.

At this point using the Buckminster MSpec at http://git.eclipse.org/c/cdo/cdo.git/plain/releng/org.eclipse.emf.cdo.releng/local.mspec?h=streams/4.0-maintenance

I get an error:
java.io.FileNotFoundException: File not found: http://git.eclipse.org/c/cdo/cdo.git/plain/releng/org.eclipse.emf.cdo.releng/build.cquery

Looking at path http://git.eclipse.org/c/cdo/cdo.git/plain I can see that there is not a child directory named releng (just .gitignore, features and plugins).

Is no more possible to download sources for version 4.0?


Re: [CDO] Download sources of version 4.0 [message #794498 is a reply to message #794442] Thu, 09 February 2012 11:20 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Am 09.02.2012 10:46, schrieb Federico Tomassetti:
> I was downloading the source code for version 4.0 according to instructions on page
> http://wiki.eclipse.org/CDO_Source_Installation
>
> Everything works fine untile I reach the step about materialization of the workspace contents.
>
> At this point using the Buckminster MSpec at
> http://git.eclipse.org/c/cdo/cdo.git/plain/releng/org.eclipse.emf.cdo.releng/local.mspec?h=streams/4.0-maintenance
>
> I get an error: java.io.FileNotFoundException: File not found:
> http://git.eclipse.org/c/cdo/cdo.git/plain/releng/org.eclipse.emf.cdo.releng/build.cquery
That's likely because of this bug in buckminster: https://bugs.eclipse.org/bugs/show_bug.cgi?id=368573

I can not tell where on their roadmap that is ;-(

> Looking at path http://git.eclipse.org/c/cdo/cdo.git/plain I can see that there is not a child directory named releng
> (just .gitignore, features and plugins).
Yes, we've moved it to plugins/ after 4.0 GA.

> Is no more possible to download sources for version 4.0?
The workaround is to manually clone the git repo and checkout the branch "streams/4.0-maintenance". Then just import the
local.mspec with buckminster.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: [CDO] Download sources of version 4.0 [message #794520 is a reply to message #794498] Thu, 09 February 2012 11:50 Go to previous messageGo to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

Thanks but I have a problem checking out the source code from git.

I executed:

git clone -b streams/4.0-maintenance http://git.eclipse.org/c/cdo/cdo.git


This is what I get:
Cloning into cdo...
error: The requested URL returned error: 403 (curl_result = 22, http_code = 403, sha1 = 6930e96c95da9ba3dfbc957db9ab3d936196d216)
error: Unable to get pack index http://git.eclipse.org/c/cdo/cdo.git/objects/pack/pack-ce4e763572d2abd05bf81693752c704ddd0ae0d8.idx

error: Unable to get pack index http://git.eclipse.org/c/cdo/cdo.git/objects/pack/pack-544ffb798818c38074eed954a26bcacfc346fa61.idx

error: Unable to find 6930e96c95da9ba3dfbc957db9ab3d936196d216 under http://git.eclipse.org/c/cdo/cdo.git
Cannot obtain needed object 6930e96c95da9ba3dfbc957db9ab3d936196d216
error: Fetch failed.


Re: [CDO] Download sources of version 4.0 [message #794536 is a reply to message #794520] Thu, 09 February 2012 12:07 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Am 09.02.2012 12:50, schrieb Federico Tomassetti:
> Thanks but I have a problem checking out the source code from git.
>
> I executed:
>
>
> git clone -b streams/4.0-maintenance http://git.eclipse.org/c/cdo/cdo.git
>
>
> This is what I get:
>
> Cloning into cdo...
> error: The requested URL returned error: 403 (curl_result = 22, http_code = 403, sha1 =
> 6930e96c95da9ba3dfbc957db9ab3d936196d216)
> error: Unable to get pack index
> http://git.eclipse.org/c/cdo/cdo.git/objects/pack/pack-ce4e763572d2abd05bf81693752c704ddd0ae0d8.idx
>
> error: Unable to get pack index
> http://git.eclipse.org/c/cdo/cdo.git/objects/pack/pack-544ffb798818c38074eed954a26bcacfc346fa61.idx
>
> error: Unable to find 6930e96c95da9ba3dfbc957db9ab3d936196d216 under http://git.eclipse.org/c/cdo/cdo.git
> Cannot obtain needed object 6930e96c95da9ba3dfbc957db9ab3d936196d216
> error: Fetch failed.
I've never seen that before. But I always clone the entire repo and not just a branch (if that's what -b does). Then I
*checkout* a working tree from a specific branch. Would that work for you?

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: [CDO] Download sources of version 4.0 [message #794539 is a reply to message #794536] Thu, 09 February 2012 12:15 Go to previous messageGo to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

Nope...

git clone http://git.eclipse.org/c/cdo/cdo.git
Cloning into cdo...
error: The requested URL returned error: 403 (curl_result = 22, http_code = 403, sha1 = 6930e96c95da9ba3dfbc957db9ab3d936196d216)
error: Unable to get pack index http://git.eclipse.org/c/cdo/cdo.git/objects/pack/pack-ce4e763572d2abd05bf81693752c704ddd0ae0d8.idx

error: Unable to get pack index http://git.eclipse.org/c/cdo/cdo.git/objects/pack/pack-544ffb798818c38074eed954a26bcacfc346fa61.idx

error: Unable to find 6930e96c95da9ba3dfbc957db9ab3d936196d216 under http://git.eclipse.org/c/cdo/cdo.git
Cannot obtain needed object 6930e96c95da9ba3dfbc957db9ab3d936196d216
error: Fetch failed.


Apparently I have a certain talent in finding weird ways to spot problems in a system...

ASAP I will try for a different machine, maybe something is wrong with my Git installation.


Re: [CDO] Download sources of version 4.0 [message #794546 is a reply to message #794539] Thu, 09 February 2012 12:26 Go to previous messageGo to next message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Am 09.02.2012 13:15, schrieb Federico Tomassetti:
> Nope...
>
>
> git clone http://git.eclipse.org/c/cdo/cdo.git
Only now I realize that you're using the http: URL. I always use git://git.eclipse.org/gitroot/cdo/cdo.git and
eventually escalate to ssh: when I want to push something.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Re: [CDO] Download sources of version 4.0 [message #794549 is a reply to message #794546] Thu, 09 February 2012 12:30 Go to previous messageGo to next message
Federico Tomassetti is currently offline Federico Tomassetti
Messages: 186
Registered: July 2009
Location: Torino
Senior Member

I tried also with the git schema. The error changes:

git clone -b streams/4.0-maintenance git://git.eclipse.org/c/cdo/cdo.git
Cloning into cdo...
fatal: The remote end hung up unexpectedly

git clone git://git.eclipse.org/c/cdo/cdo.git
Cloning into cdo...
fatal: The remote end hung up unexpectedly




Re: [CDO] Download sources of version 4.0 [message #794655 is a reply to message #794549] Thu, 09 February 2012 14:38 Go to previous message
Eike Stepper is currently offline Eike Stepper
Messages: 5524
Registered: July 2009
Senior Member
Am 09.02.2012 13:30, schrieb Federico Tomassetti:
> I tried also with the git schema. The error changes:
>
>
> git clone -b streams/4.0-maintenance git://git.eclipse.org/c/cdo/cdo.git
> Cloning into cdo...
> fatal: The remote end hung up unexpectedly
>
> git clone git://git.eclipse.org/c/cdo/cdo.git
> Cloning into cdo...
> fatal: The remote end hung up unexpectedly
I just tried it and here I have no problems. If you're sure that it's not a problem on your end you should ask
webmaster@eclipse.org for advice. I'm sorry that I can not help with this.

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper
Previous Topic:EMF and Schematron
Next Topic:Research Papers on CDO
Goto Forum:
  


Current Time: Sun Sep 21 12:23:33 GMT 2014

Powered by FUDForum. Page generated in 0.01814 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software