Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » No launcher in zip created by a command line headless build(Indigo headless build from command line does not contain exe)
No launcher in zip created by a command line headless build [message #794071] Wed, 08 February 2012 22:15 Go to next message
Terry Jahelka is currently offline Terry JahelkaFriend
Messages: 23
Registered: February 2012
Junior Member
I have a Eclipse RCP application created on Indigo. I can successfully export the product and the zip is complete and the application launches successfully.

Our environment requires us to be able to run standalone, continuous builds. Via the many helpful articles on the web I have an ant build.xml and the build.properties created. When I execute the build, it completes successfully but the zip does not contain an exe. Looking at the log file from the build the only error I see is:

generate.p2.metadata:
[java] Unable to find: Installable Unit [id=org.eclipse.equinox.executable_root.win32.win32.x86 ]

My eclipse installation is c:\eclipse with the deltapack installed in c:\eclipse\deltapack. I saw several posts that said the deltapack should not be installed in the eclipse SDK, so I also tried installing it alongside (c:\eclipse and c:\deltapack). This change had no effect on the build.

I've attached my build.properties and build.xml. Please advise.
  • Attachment: build.properties
    (Size: 10.51KB, Downloaded 107 times)
  • Attachment: build.xml
    (Size: 5.34KB, Downloaded 152 times)
Re: No launcher in zip created by a command line headless build [message #946721 is a reply to message #794071] Tue, 16 October 2012 12:46 Go to previous messageGo to next message
Tom Fleck is currently offline Tom FleckFriend
Messages: 3
Registered: July 2009
Junior Member
I have this exact problem myself, having just stepped up to Indigo. Did you find a solution?
Re: No launcher in zip created by a command line headless build [message #946733 is a reply to message #946721] Tue, 16 October 2012 12:57 Go to previous message
Terry Jahelka is currently offline Terry JahelkaFriend
Messages: 23
Registered: February 2012
Junior Member
Unfortunately no we did not solve this. Our company standard for builds is to use Maven and not ANT. So we used the org.eclipse.tycho package to build with Maven.
Previous Topic:Cannot open Eclipse from desktop
Next Topic:How to add "Code Sourcery's GNU compiler" in to tool chain
Goto Forum:
  


Current Time: Wed Dec 17 23:23:18 GMT 2014

Powered by FUDForum. Page generated in 0.01566 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software