Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Blueprint - Can I use Apache Aries?(Gemini Blueprint seems to cause some conflict on Virgo. Can I use Aries?)
Blueprint - Can I use Apache Aries? [message #792733] Tue, 07 February 2012 10:48 Go to next message
Eduardo Frazão is currently offline Eduardo FrazãoFriend
Messages: 118
Registered: January 2012
Senior Member
Hi all!
I'm working on a new project, and I belive that is better to focus on the standard Blueprint instead SpringDM (even when both is very similar).

I try to deploy Gemini Blueprint 1.0.0.Release on Virgo 3.0.2.Release, but sometimes in startup, Many errors occours, about Spring conflicts. I belive that is because the native support of Gemini to SpringDM, that is already present on Virgo.

So, I try to use Apache Aries 0.3. With my simple tests, it is working. I only create a PLAN, and deployed it before the UserRegion Bundles starts.

But i've read on a blog entry (http://underlap.blogspot.com/2011/07/virgo-30-maya-release-candidate-1.html), where Glyn Normington don't recommend the use of this implementation.
There's some incompatibility when running this implementation on Virgo? Can I trust on stability on a production environment?

I want to start the development using Aries blueprint, at least until Virgo does not adopt the Gemini Blueprint.

Thanks!
Eduardo
Re: Blueprint - Can I use Apache Aries? [message #792761 is a reply to message #792733] Tue, 07 February 2012 11:30 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
A year ago or so I tried running some Aries components inside Virgo and I didn't succeed, even with a few Aries committers helping. Admittedly we only tried for half an hour during a break at a conference, but it made me hesitant to recommend this approach generally to users. If you have got Aries Blueprint working in Virgo, that's great to hear. May I suggest that you blog your experience so others can learn and comment?
Re: Blueprint - Can I use Apache Aries? [message #792769 is a reply to message #792761] Tue, 07 February 2012 11:44 Go to previous messageGo to next message
Eduardo Frazão is currently offline Eduardo FrazãoFriend
Messages: 118
Registered: January 2012
Senior Member
Hi Glyn!
Sure, I can post something on my Blog (that I dont post nothing new for two years). But I only put Aries Blueprint Bundles, and create a Plan for start.
Im happy that it works, because, when Virgo supports Blueprint natively, I will not need to port config to blueprint. I have nothing against SpringDM. I only belive that the new focus enchancements will be on the osgi specification.
Any chances that Virgo 3.5 come with Gemini Blueprint?

Thanks!!!!
Re: Blueprint - Can I use Apache Aries? [message #792864 is a reply to message #792769] Tue, 07 February 2012 14:02 Go to previous message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Gemini Blueprint support is not currently in plan for Virgo 3.5, but please do comment in bug 317943 to add your support as that will help us prioritise if we find we have some spare capacity.
Previous Topic:Virgo and STS 2.7.2
Next Topic:Latest IDE snapshot build?
Goto Forum:
  


Current Time: Wed Nov 26 13:15:40 GMT 2014

Powered by FUDForum. Page generated in 0.02777 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software