Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » URL recorder - session handeling
URL recorder - session handeling [message #93065] Fri, 02 March 2007 14:49 Go to next message
Eclipse UserFriend
Originally posted by: asd.a.b.c

When using the URL recorder the replay fails due to problematic cookie
session handeling. The browser (IE) when recording placed the first session
cookie on the (ssl) URL string not within a header. Subsequent session
cookies are being placed with cookie headers. I modifed the JUnit test case
to cater for cookie in the URL and alls well - but I get another problem a
couple or requests later. Weblogic seams to think the session has timed out.
As far as I can tell I'm always tracking the correct cookie - Any ideas?

Thanks John
Re: URL recorder - session handeling [message #95744 is a reply to message #93065] Fri, 13 April 2007 11:44 Go to previous message
Paul Slauenwhite is currently offline Paul SlauenwhiteFriend
Messages: 970
Registered: July 2009
Senior Member
Hi John,
We do not expose session IDs to the test author in the URL test editor
or generated JUnit test code (see
https://bugs.eclipse.org/bugs/show_bug.cgi?id=139699#c1). Preserving user
session IDs to emulate unique user sessions when asynchronously looping
through a set of iterations will be covered under enhancement
https://bugs.eclipse.org/bugs/show_bug.cgi?id=128613. This enhancement
should provide the necessary function to resolve your problem. Please feel
free to add your comments to the enhancement.

Paul
"John" <asd@a.b.c> wrote in message news:es9dig$i8p$1@utils.eclipse.org...
> When using the URL recorder the replay fails due to problematic cookie
> session handeling. The browser (IE) when recording placed the first
> session cookie on the (ssl) URL string not within a header. Subsequent
> session cookies are being placed with cookie headers. I modifed the JUnit
> test case to cater for cookie in the URL and alls well - but I get
> another problem a couple or requests later. Weblogic seams to think the
> session has timed out. As far as I can tell I'm always tracking the
> correct cookie - Any ideas?
>
> Thanks John
>
Previous Topic:Users and different session id
Next Topic:IWAT0284E errors on linux x86_64
Goto Forum:
  


Current Time: Thu Dec 18 10:45:11 GMT 2014

Powered by FUDForum. Page generated in 0.09510 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software