Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » How to Override Eclipse Core Plug-ins
icon5.gif  How to Override Eclipse Core Plug-ins [message #784931] Sat, 28 January 2012 06:45 Go to next message
Kivanc Muslu is currently offline Kivanc Muslu
Messages: 153
Registered: November 2010
Senior Member
Hi all,

I know that the title is a little scary and it is actually not what I need to know at the moment, but pretty close.

For various reasons -research being the top- I have to change the code inside two Eclipse plug-ins: org.eclipse.jface.text and org.eclipse.jdt.ui.

To change it, I import the source as a plug-in project, change the source and re-compile it with a new version identifier.
Before this, I was only changing the first one (org.eclipse.jface.text) and it was working perfectly from the debug platform (i.e., running a second eclipse inside eclipse) and when I installed my final plug-in to other eclipses (i.e., deployed version). All hooks I have added to org.eclipse.jface.text work.

Then, I needed to change org.eclipse.jdt.ui. Similarly, it worked perfect inside the second eclipse (debugging). However, I am having problems with the deployment. I try the same trick for org.eclipse.jdt.ui, recompile it with a new version identifier, however for some reasons, when I move it under the dropins/ directory of another eclipse and restart that eclipse, it does not get loaded (my version).

I have attached a screenshot that shows the plug-ins that are currently running on my eclipse (partial). You can clearly see that I have two org.eclipse.jface.text running (my version and eclipse original), however for org.eclipse.jdt.ui, I only have one (original eclipse).

I guess my first question is: what could be the reason beyond that?
2. question: is there a workaround?
3. question: is there a better way to path existing eclipse source code for the purposes of your plug-in?

Finally, I have also attached another screenshot that shows the error I get when I tried to install my plug-in from an update site automatically. I don't know if it is related, however it was complaining about two org.eclipse.jdt.ui's being in conflict or something like that. It might mean more to someone who knows the error messages better.

All help is appreciated. Thanks in advance, best regards,

Cannot complete the install because of a conflicting dependency.
  Software being installed: Quick_Fix_Scout 0.1.0 (edu.washington.cs.quick-fix-scout.feature.group 0.1.0)
  Software currently installed: Eclipse SDK 3.7.1.M20110909-1335 (org.eclipse.sdk.ide 3.7.1.M20110909-1335)
  Only one of the following can be installed at once: 
    Java Development Tools UI 3.7.1.r371_v20110824-1200 (org.eclipse.jdt.ui 3.7.1.r371_v20110824-1200)
    Java Development Tools UI 3.7.0.v20110531-1200 (org.eclipse.jdt.ui 3.7.0.v20110531-1200)
    Java Development Tools UI 3.7.1.r371_v20110824-0800 (org.eclipse.jdt.ui 3.7.1.r371_v20110824-0800)
  Cannot satisfy dependency:
    From: Quick_Fix_Scout 0.1.0 (edu.washington.cs.quick-fix-scout.feature.group 0.1.0)
    To: org.eclipse.jdt.ui [3.7.1.r371_v20110824-1200]
  Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK (org.eclipse.jdt.feature.group 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK)
    To: org.eclipse.jdt.ui [3.7.1.r371_v20110824-0800]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 3.7.1.r37x_v20110728-7Q7xAEDDePtVvBAYYD3z-il0ox7CoGe6mz-B8FDdVn0YR (org.eclipse.sdk.feature.group 3.7.1.r37x_v20110728-7Q7xAEDDePtVvBAYYD3z-il0ox7CoGe6mz-B8FDdVn0YR)
    To: org.eclipse.jdt.feature.group [3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK]
  Cannot satisfy dependency:
    From: Eclipse SDK 3.7.1.M20110909-1335 (org.eclipse.sdk.ide 3.7.1.M20110909-1335)
    To: org.eclipse.sdk.feature.group [3.7.1.r37x_v20110728-7Q7xAEDDePtVvBAYYD3z-il0ox7CoGe6mz-B8FDdVn0YR]

Re: How to Override Eclipse Core Plug-ins [message #786289 is a reply to message #784931] Mon, 30 January 2012 08:21 Go to previous messageGo to next message
Deepak Azad is currently offline Deepak Azad
Messages: 545
Registered: July 2009
Senior Member
Using dropins folder here is not the best of ideas. I have tried to do
this in the past for o.e.jdt.ui but it does not work. Think 'p2' :-)

I generally have to install o.e.jdt.ui only in my eclipse installation
(for testing a feature I just wrote), and for that I use 'Export >
Deployable Plugins > Install into host'.

If you want to distribute the modified versions of the plugins, you may
want to create a 'p2 repository' and then follow the standard 'Help >
Install/update' route.

--
Deepak Azad
http://wiki.eclipse.org/JDT/FAQ
Re: How to Override Eclipse Core Plug-ins [message #786321 is a reply to message #786289] Mon, 30 January 2012 09:10 Go to previous messageGo to next message
Kivanc Muslu is currently offline Kivanc Muslu
Messages: 153
Registered: November 2010
Senior Member
Hi Deepak,

Thanks for the reply. I tried to use Update Site Publisher (found from here: http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.pde.doc.user/tasks/pde_p2_builds.htm) to convert my existing update site to a p2 repository. It seemed to work, however when I uploaded it to the web and tried to install it from Help > Install/update, it gave me a similar error to my original one. The error is attached. Am I doing (or understanding) something wrong?

Thanks,

Cannot complete the install because of a conflicting dependency.
  Software being installed: Quick_Fix_Scout 0.1.0 (edu.washington.cs.qfs_371.feature.group 0.1.0)
  Software currently installed: Eclipse SDK 3.7.1.M20110909-1335 (org.eclipse.sdk.ide 3.7.1.M20110909-1335)
  Only one of the following can be installed at once: 
    Java Development Tools UI 3.7.1.r371_v20110824-1200 (org.eclipse.jdt.ui 3.7.1.r371_v20110824-1200)
    Java Development Tools UI 3.7.0.v20110531-1200 (org.eclipse.jdt.ui 3.7.0.v20110531-1200)
    Java Development Tools UI 3.7.1.r371_v20110824-0800 (org.eclipse.jdt.ui 3.7.1.r371_v20110824-0800)
  Cannot satisfy dependency:
    From: Quick_Fix_Scout 0.1.0 (edu.washington.cs.qfs_371.feature.group 0.1.0)
    To: org.eclipse.jdt.ui [3.7.1.r371_v20110824-1200]
  Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK (org.eclipse.jdt.feature.group 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK)
    To: org.eclipse.jdt.ui [3.7.1.r371_v20110824-0800]
  Cannot satisfy dependency:
    From: Eclipse Project SDK 3.7.1.r37x_v20110728-7Q7xAEDDePtVvBAYYD3z-il0ox7CoGe6mz-B8FDdVn0YR (org.eclipse.sdk.feature.group 3.7.1.r37x_v20110728-7Q7xAEDDePtVvBAYYD3z-il0ox7CoGe6mz-B8FDdVn0YR)
    To: org.eclipse.jdt.feature.group [3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK]
  Cannot satisfy dependency:
    From: Eclipse SDK 3.7.1.M20110909-1335 (org.eclipse.sdk.ide 3.7.1.M20110909-1335)
    To: org.eclipse.sdk.feature.group [3.7.1.r37x_v20110728-7Q7xAEDDePtVvBAYYD3z-il0ox7CoGe6mz-B8FDdVn0YR]

Re: How to Override Eclipse Core Plug-ins [message #786574 is a reply to message #786321] Mon, 30 January 2012 15:48 Go to previous message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

You have to create a feature patch (New>Other...>Plug-in Development) and patch the JDT feature to get it to accept your changed version.

PW


Previous Topic:using refactoring descriptor with JDT
Next Topic:Disabling action/commands from JDT/ thirdparty plugins
Goto Forum:
  


Current Time: Sat Oct 25 16:54:02 GMT 2014

Powered by FUDForum. Page generated in 0.01686 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software