Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » "Exception in thread "main" java.lang.NoClassDefFoundError: " while profiling
"Exception in thread "main" java.lang.NoClassDefFoundError: " while profiling [message #91058] Thu, 11 January 2007 03:13 Go to next message
Eclipse User
Originally posted by: jakub.jurkiewicz.gmail.com

Hi,

I've got Eclipse 3.2.1 and TPTP installed by Update Manager. When I try
to profile (Basic Memory Analysis, Execution Time Analysis, Method Code
Coverage) simple project (form some tutorial) I get message like that on
my console:
Exception in thread "main" java.lang.NoClassDefFoundError:

And the profiling is terminated. Any ideas what can go wrong?

I'm using vidalinux 1.3, java: 1.5.0_08-b03, Eclipse 3.2.1.

Thanks for any help
Jakub Jurkiewicz
Re: "Exception in thread "main" java.lang.NoClassDefFoundError: " while profilin [message #91068 is a reply to message #91058] Thu, 11 January 2007 04:48 Go to previous messageGo to next message
Asaf Yaffe is currently offline Asaf Yaffe
Messages: 333
Registered: July 2009
Senior Member
Jakub Jurkiewicz wrote:
> Hi,
>
> I've got Eclipse 3.2.1 and TPTP installed by Update Manager. When I try
> to profile (Basic Memory Analysis, Execution Time Analysis, Method Code
> Coverage) simple project (form some tutorial) I get message like that on
> my console:
> Exception in thread "main" java.lang.NoClassDefFoundError:
>
> And the profiling is terminated. Any ideas what can go wrong?
>
> I'm using vidalinux 1.3, java: 1.5.0_08-b03, Eclipse 3.2.1.
>
> Thanks for any help
> Jakub Jurkiewicz

Jakub,

Please provide us with the following information:
1. What type of Launch Configuration are you using? An "internal" Java
application (i.e., Java project in the current workspace)? External
Java application? Something else?
2. Can you launch the Java application *without* the TPTP profiler?
3. Are you using the Agent Controller (did you install it)? If not, I
assume you are using the "Integrated Agent Controller" (default when the
Agent Controller is not installed). If this is the case, can you
specify the configuration of the Integrated Agent Controller (available
in the "Environment" page of the "Agent Controller > Integrated Agent
Controller" section of the Eclipse Preferences dialog).

Thanks,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Re: "Exception in thread "main" java.lang.NoClassDefFoundError: " while profilin [message #91083 is a reply to message #91068] Thu, 11 January 2007 04:57 Go to previous messageGo to next message
Eclipse User
Originally posted by: jakub.jurkiewicz.gmail.com

>
> Jakub,
>
> Please provide us with the following information:
> 1. What type of Launch Configuration are you using? An "internal" Java
> application (i.e., Java project in the current workspace)? External Java
> application? Something else?
> 2. Can you launch the Java application *without* the TPTP profiler?
> 3. Are you using the Agent Controller (did you install it)? If not, I
> assume you are using the "Integrated Agent Controller" (default when the
> Agent Controller is not installed). If this is the case, can you
> specify the configuration of the Integrated Agent Controller (available
> in the "Environment" page of the "Agent Controller > Integrated Agent
> Controller" section of the Eclipse Preferences dialog).
>
> Thanks,
> Asaf
>

1. This is a project in my workspace.
2. I run this application without any problems.
3. I'm using Agent Controller run from the command line. After
downloading it I ran SetConfig.sh script.
I run Agent Controller by running RAStart.sh. I get the message:
Starting Agent Controller
RAServer started successfully
So I guess that it starts fine.

Do you need any other information?
Jakub
Re: "Exception in thread "main" java.lang.NoClassDefFoundError: " while profilin [message #91098 is a reply to message #91083] Thu, 11 January 2007 06:09 Go to previous message
Asaf Yaffe is currently offline Asaf Yaffe
Messages: 333
Registered: July 2009
Senior Member
Jakub Jurkiewicz wrote:
>
> 1. This is a project in my workspace.
> 2. I run this application without any problems.
> 3. I'm using Agent Controller run from the command line. After
> downloading it I ran SetConfig.sh script.
> I run Agent Controller by running RAStart.sh. I get the message:
> Starting Agent Controller
> RAServer started successfully
> So I guess that it starts fine.
>
> Do you need any other information?
>

In the configuration you just described, the Agent Controller is
responsible for executing your Java application. Based on the error
message you get, I assume it either does not interpret the Java class
name correctly, or does not correctly set the working directory of the
Java process. My technical knowledge with regard to the Agent Controller
is limited, so I suggest to wait for someone from the AC team to respond
to this thread.

You may want to try the following alternatives:
- Use the Integrated Agent Controller. This is easy - just shutdown the
Agent Controller and launch the profiler as you normally do. Eclipse
should detect that the AC is not running and use Integrated AC instead.

- Use the new Tech Preview JVMTI Profiler and the New Technology Agent
Controller: shutdown your AC, install the New Technology AC, the JVMTI
Profiler runtime and the JVMTI Profiler client (all available on the
TPTP 4.3 download page), and select the "Java Profiling with
Instrumentation" data collector on the Monitor tab (will appear after
you successfully install the JVMTI Profiler client).

HTH,
Asaf

--
Asaf Yaffe
Eclipse TPTP Committer, JVMTI Profiler
Previous Topic:HELP with Integrated Agent !!
Next Topic:How to use the Log View to a view a server's log file
Goto Forum:
  


Current Time: Thu Aug 21 14:01:42 EDT 2014

Powered by FUDForum. Page generated in 0.14429 seconds