Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Setup Eclipse php environment
Setup Eclipse php environment [message #783917] Thu, 26 January 2012 18:23 Go to next message
Jeroen de Kock is currently offline Jeroen de Kock
Messages: 2
Registered: January 2012
Junior Member
I'm trying to setup an eclipse php development environment and following this instruction: docs.joomla.org/Setting_up_your_workstation_for_Joomla!_development#Edit_PHP.INI_File

I already installed eclipse with pdt 3.0.x
After that i installed xampp 1.7.7 and make some changes to the php.ini to use xdebug.
So far everything seems ok.
But than i'm trying to make a test php project.
The problem i now have is configure the php server. Because the screen shows on this instruction is from an older version of eclipse i think.
I now don't know what i have to fill in with the Server properties "Base URL" and "Local Web Root".
I tried for the base url = "//localhost:10000" and for local web root = "D:\xampp\htdocs\Joomla_development". In this Joomla_development directory i placed the directory with the Test Debug project. I also add a path mapping. path on server = "D:\xampp\htdocs\Joomla_development" and path in workspace = "/Test Debug".

When i now try to run the test.php as a PHP web page, Firefox opens but it doesn't come up with my test page. Instead it shows "Object not found the url wasn't found on this server error 404". In the address said : //localhost/Test, but my project calls Test Debug and my page is test.php

On a second tab in firefox the message shows "An unexpected problem has occured with the application. UPDATE `ubh_settings` SET global_code = '' WHERE setting_id = '1'"

Maybe someone can help me with my problem ?

[Updated on: Thu, 26 January 2012 18:28]

Report message to a moderator

Re: Setup Eclipse php environment [message #784280 is a reply to message #783917] Fri, 27 January 2012 09:38 Go to previous messageGo to next message
Jeroen de Kock is currently offline Jeroen de Kock
Messages: 2
Registered: January 2012
Junior Member
Almost 200 views and nobody can help me ?
Re: Setup Eclipse php environment [message #784475 is a reply to message #783917] Fri, 27 January 2012 15:31 Go to previous message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2308
Registered: July 2009
Senior Member
On 1/26/2012 1:23 PM, Jeroen de Kock wrote:
> I'm trying to setup an eclipse php development environment and following
> this instruction:
> docs.joomla.org/Setting_up_your_workstation_for_Joomla!_development#Edit_PHP.INI_File
>
>
> I already installed eclipse with pdt 3.0.x
> After that i installed xampp 1.7.7 and make some changes to the php.ini
> to use xdebug.
> So far everything seems ok.
> But than i'm trying to make a test php project.
> The problem i now have is configure the php server. Because the screen
> shows on this instruction is from an older version of eclipse i think.
> I now don't know what i have to fill in with the Server properties "Base
> URL" and "Local Web Root". I tried for the base url = "localhost:10000"
> and for local web root = "D:\xampp\htdocs\Joomla_development". In this
> Joomla_development directory i placed the directory with the Test Debug
> project. I also add a path mapping. path on server =
> "D:\xampp\htdocs\Joomla_development" and path in workspace = "/Test Debug".
>
> When i now try to run the test.php as a PHP web page, Firefox opens but
> it doesn't come up with my test page. Instead it shows "Object not found
> the url wasn't found on this server error 404".
>
> Maybe someone can help me with my problem ?
>
Perhaps you could mention what URL it was trying to load? I'm surprised
that you wouldn't use d:\xampp\htdocs as the root.

--
---
Nitin Dahyabhai
Eclipse WTP Source Editing and JSDT
IBM Rational


---
Nitin Dahyabhai
Eclipse WTP, IBM
Previous Topic:Advanced Debugging for a complex PHP project
Next Topic:Projects mngt organization basis for a newbie Eclipse user
Goto Forum:
  


Current Time: Wed Oct 22 12:34:06 GMT 2014

Powered by FUDForum. Page generated in 0.01766 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software