Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EclipseLink » EclipseLink weaving fragment require-bundle version
EclipseLink weaving fragment require-bundle version [message #783471] Wed, 25 January 2012 19:20 Go to next message
Charlie Mordant is currently offline Charlie MordantFriend
Messages: 88
Registered: July 2010


I'm trying to make eclipselink working in an osgi environment (not eclipse pde environment, but just standalone equinox).

But when I look at the org.eclipse.persistence.jpa.equinox.weaving bundle, I see that the fragment-Host is defined as:
Fragment-Host: org.eclipse.osgi;extension:=framework;bundle-version="3.4.0"

I'm running this combo on eclipse 3.7.1.XXXXX, resulting that the fragment can't start.

How can I find a workaround (I prefer not to override manifest, neither overriding all the manifest that imports org.eclipse.osgi)?


Re: EclipseLink weaving fragment require-bundle version [message #783481 is a reply to message #783471] Wed, 25 January 2012 19:57 Go to previous message
Shaun Smith is currently offline Shaun SmithFriend
Messages: 197
Registered: July 2009
Senior Member
Hi Charlie,

Take a look at the Equinox byte code weaving example and the main OSGi Examples page which provides some general OSGi config info. They should cover what you're looking for.

Previous Topic:Mysterious duplicate insert
Next Topic:update in new transaction hangs program
Goto Forum:

Current Time: Wed Nov 25 08:16:53 GMT 2015

Powered by FUDForum. Page generated in 0.04835 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software