Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » testexec doesn't wait for AUT
testexec doesn't wait for AUT [message #782339] Mon, 23 January 2012 15:06 Go to next message
Andreas Scharf is currently offline Andreas Scharf
Messages: 21
Registered: December 2011
Junior Member
Hi,

I have problems with running my suite using testexec. The problem seems to be that our AUT takes some time to start which obviously is too long for testexec. The result is that testexec reports

[...]
Mon Jan 23 15:51:56 CET 2012    Executing Test Suite...
!!Error occurred !!
        Could not connect to AUT: MyAUT


If I then (keeping the AUT running) use the -autid parameter for testexec instead of -autconfig and give the AUT some time to settle down before invoking testexec again, everything works as expected.

So my question is: Is it possible to define some timeout for testexec which waits a specified amount of time to let the AUT startup completely?

Best regards,
Andreas

Re: testexec doesn't wait for AUT [message #782662 is a reply to message #782339] Tue, 24 January 2012 07:14 Go to previous messageGo to next message
Sascha Mising name is currently offline Sascha Mising name
Messages: 22
Registered: December 2011
Junior Member
I am dealing currently with the same issue, and added some delays.

So I do following:

autstart -> wait 10 seconds (hoping this is enough) -> autrun -> wait 30 seconds (hoping this will be enough) -> testexec ->

I really would enjoy that the internal timeouts of the processes are set high enough, and they try to recontect on their own, so that i would not need these manual delays.

Re: testexec doesn't wait for AUT [message #782668 is a reply to message #782662] Tue, 24 January 2012 07:31 Go to previous messageGo to next message
Andreas Scharf is currently offline Andreas Scharf
Messages: 21
Registered: December 2011
Junior Member
Hi Sascha,

that was my first idea too but I couldn't imagine that this is the only way.
Re: testexec doesn't wait for AUT [message #782685 is a reply to message #782668] Tue, 24 January 2012 08:29 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi Andreas and Sascha,

The current default (hard-coded) wait between starting an AUT and checking that it is there is 5000ms. There is an environment variable that you can use called GD_AUT_STARTUP_DELAY to add more of a delay before the presence of the AUT is checked.

The name GD_ is a remnant of pre-Jubula times. I've put in an enhancement here that it be renamed to TEST_AUT_STARTUP_DELAY, this will be included as of Juno M5.

In the meantime, use the GD_AUT_STARTUP_DELAY = <TIMEOUT_IN_MS> as an environment variable to avoid having to use autrun and waits at other places. We're hoping to make various timeouts and waits that are currently hard-coded configurable in a later version to make AUT-specific differences easier to handle. Hopefully this should help a bit in the meantime.

HTH,
Alex

Re: testexec doesn't wait for AUT [message #782740 is a reply to message #782685] Tue, 24 January 2012 10:37 Go to previous messageGo to next message
Andreas Scharf is currently offline Andreas Scharf
Messages: 21
Registered: December 2011
Junior Member
Hi Alex,

this works great.

However it would be great to not define a delay but a timeout. That would enable the user to say that the testexecutor should wait a maximum of let's say 5 minutes to let the AUT start but start the execution if the AUT is ready after 1 minute.

Best regards,
Andreas
Re: testexec doesn't wait for AUT [message #782754 is a reply to message #782740] Tue, 24 January 2012 11:18 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi Andreas,

Glad to hear that helps Smile

I've noted the point about it being a timeout in the product backlog for when we look at this area.

Best regards,
Alex
Re: testexec doesn't wait for AUT [message #782759 is a reply to message #782754] Tue, 24 January 2012 11:36 Go to previous message
Sascha Mising name is currently offline Sascha Mising name
Messages: 22
Registered: December 2011
Junior Member
Hello Alex, Andrea
I think there should more than only a timeout.
If you need three processes for running a test (auagent, autrun, testexec) there sould be a communication model between them, which also covers errors.

1. I for example experienced the Problem, the test exec has an error and exits.
The RCP Application from autrun is still running ... as this a buld machine with many instances running, i dont know which eclipse process to kill.
There is then no proper possibility to stop the from autrun executed rcp.
If i make stopautagent, the rcp from autrun keeps running and I have some undefined states in my environement which is bad.

2. Also if the testexec executes until the end.
- How do i properly deinitialize the autrun ?
- How do i prooerly deinitalize the RCP Application ?
- StopAutAgent only stops the Aut Agent.

Best regards,
Sascha

[Updated on: Tue, 24 January 2012 16:22]

Report message to a moderator

Previous Topic:AUT starting in progress
Next Topic:Autrun RCP Workspace not working
Goto Forum:
  


Current Time: Fri Oct 24 20:51:10 GMT 2014

Powered by FUDForum. Page generated in 0.10967 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software