Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Using GUI Recorder to Test Plug-ins?
Using GUI Recorder to Test Plug-ins? [message #89696] Thu, 07 December 2006 20:42 Go to next message
Eclipse User
Originally posted by: emmanuelproulx.yahoo.com

Has anyone successfully used the GUI Recorder to test plug-ins?

I was able to record tests using the GUI Recorder in the Runtime Workbench
successfully. But when I ran these tests I saw that my plug-in is not even
available.

Right now I had to resort to creating a separate Eclipse installation,
including the plug-ins to test, in order to run the tests. This is a bummer
because I lose the ability to debug.

Any information would be useful.

Thanks,
Emmanuel Proulx
Re: Using GUI Recorder to Test Plug-ins? [message #89744 is a reply to message #89696] Thu, 07 December 2006 22:06 Go to previous messageGo to next message
Liz Dancy is currently offline Liz Dancy
Messages: 77
Registered: July 2009
Member
There is currently an enhancement open to provide the kind of support for
plug-in testing you are looking for. Please see:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=109880

Feel free to add yourself to the cc list and add comments to the enhancement
as well.

Sincerely,

Liz Dancy

"Emmanuel Proulx" <emmanuelproulx@yahoo.com> wrote in message
news:el9ubb$28e$1@utils.eclipse.org...
> Has anyone successfully used the GUI Recorder to test plug-ins?
>
> I was able to record tests using the GUI Recorder in the Runtime Workbench
> successfully. But when I ran these tests I saw that my plug-in is not even
> available.
>
> Right now I had to resort to creating a separate Eclipse installation,
> including the plug-ins to test, in order to run the tests. This is a
> bummer because I lose the ability to debug.
>
> Any information would be useful.
>
> Thanks,
> Emmanuel Proulx
>
Re: Using GUI Recorder to Test Plug-ins? [message #89848 is a reply to message #89696] Sat, 09 December 2006 21:38 Go to previous message
No real name is currently offline No real name
Messages: 404
Registered: July 2009
Senior Member
This is also related to https://bugs.eclipse.org/bugs/show_bug.cgi?id=165526

Thanks,
Ali Mehregani

"Emmanuel Proulx" <emmanuelproulx@yahoo.com> wrote in message
news:el9ubb$28e$1@utils.eclipse.org...
> Has anyone successfully used the GUI Recorder to test plug-ins?
>
> I was able to record tests using the GUI Recorder in the Runtime Workbench
> successfully. But when I ran these tests I saw that my plug-in is not even
> available.
>
> Right now I had to resort to creating a separate Eclipse installation,
> including the plug-ins to test, in order to run the tests. This is a
> bummer because I lose the ability to debug.
>
> Any information would be useful.
>
> Thanks,
> Emmanuel Proulx
>
Previous Topic:profiler stops receiving data after a few mins
Next Topic:TPTP Test Results with "no verdict" while Total test performed reported
Goto Forum:
  


Current Time: Tue Sep 30 11:55:00 GMT 2014

Powered by FUDForum. Page generated in 0.02191 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software