Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » WebSphere deployment problem
WebSphere deployment problem [message #778535] Fri, 13 January 2012 07:03 Go to next message
Karoly Guba is currently offline Karoly GubaFriend
Messages: 4
Registered: January 2012
Junior Member

I am totally new to WebSphere ap server.

Before I say enything, you have to know that I strongly followed "WASCE Getting Started PDF"!
So I do the follownigs:
Downloaded WASCE (WebSphere App Server Community Edition) 3.0 installed it to winXP SP3 machine. I have also installed Eclipse indigo for Java EE developing.
Based on WASCE Getting Started PDF i have created the totally simple "Hello World" dynamic web project with Eclipse and WebSphere. I have WEP (WebSphere Eclipse Plugin) in my Eclipse. I can see and start/stop WebSphere App server from Eclipse, but when I try to run my web application I get the following error:

   1. Unable to create configuration for deployment: dependencies: null  
   2. org.apache.geronimo.common.DeploymentException: Unable to create configuration for deployment: dependencies: null  
   3.     at org.apache.geronimo.deployment.DeploymentContext.createTempConfiguration(  
   4.     at org.apache.geronimo.deployment.DeploymentContext.initializeConfiguration(  
   5.     at org.apache.geronimo.j2ee.deployment.EARConfigBuilder.buildConfiguration(  
   6.     at org.apache.geronimo.deployment.Deployer.deploy(  
   7.     at org.apache.geronimo.deployment.Deployer.deploy(  
   8.     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)  
   9.     at sun.reflect.NativeMethodAccessorImpl.invoke(  
  10.     at sun.reflect.DelegatingMethodAccessorImpl.invoke(  
  11.     at java.lang.reflect.Method.invoke(  
  12.     at org.apache.geronimo.gbean.runtime.ReflectionMethodInvoker.invoke(  
  13.     at org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(  
  14.     at org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(  
  15.     at org.apache.geronimo.kernel.basic.BasicKernel.invoke(  
  16.     at org.apache.geronimo.kernel.KernelGBean.invoke(  
  17.     at sun.reflect.GeneratedMethodAccessor88.invoke(Unknown Source)  
  18.     at sun.reflect.DelegatingMethodAccessorImpl.invoke(  
  19.     at java.lang.reflect.Method.invoke(  
  20.     at org.apache.geronimo.gbean.runtime.ReflectionMethodInvoker.invoke(  
  21.     at org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(  
  22.     at org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(  
  23.     at org.apache.geronimo.kernel.basic.BasicKernel.invoke(  
  24.     at org.apache.geronimo.system.jmx.MBeanGBeanBridge.invoke(  
  25.     at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(  
  26.     at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(  
  27.     at  
  28.     at$200(  
  29.     at$  
  30.     at Method)  
  31.     at  
  32.     at  
  33.     at sun.reflect.GeneratedMethodAccessor70.invoke(Unknown Source)  
  34.     at sun.reflect.DelegatingMethodAccessorImpl.invoke(  
  35.     at java.lang.reflect.Method.invoke(  
  36.     at sun.rmi.server.UnicastServerRef.dispatch(  
  37.     at sun.rmi.transport.Transport$  
  38.     at Method)  
  39.     at sun.rmi.transport.Transport.serviceCall(  
  40.     at sun.rmi.transport.tcp.TCPTransport.handleMessages(  
  41.     at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(  
  42.     at sun.rmi.transport.tcp.TCPTransport$  
  43.     at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(  
  44.     at java.util.concurrent.ThreadPoolExecutor$  
  45.     at  
  46. Caused by: org.apache.geronimo.kernel.config.LifecycleException: load of default/wasce1/1.0/car failed  
  47.     at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(  
  48.     at org.apache.geronimo.deployment.DeploymentConfigurationManager.loadConfiguration(  
  49.     at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(  
  50.     at org.apache.geronimo.deployment.DeploymentConfigurationManager.loadConfiguration(  
  51.     at org.apache.geronimo.deployment.DeploymentContext.createTempConfiguration(  
  52.     ... 42 more  
  53. Caused by: org.apache.geronimo.kernel.repository.MissingDependencyException: Missing dependency: org.apache.geronimo.configs/sharedlib//car  
  54.     at org.apache.geronimo.kernel.repository.DefaultArtifactResolver.resolveInClassLoader(  
  55.     at org.apache.geronimo.kernel.repository.DefaultArtifactResolver.resolveInClassLoader(  
  56.     at org.apache.geronimo.kernel.config.SimpleConfigurationManager.resolveParentIds(  
  57.     at org.apache.geronimo.kernel.config.SimpleConfigurationManager.loadConfiguration(  
  58.     ... 46 more  

What could be the problem?

Re: WebSphere deployment problem [message #785236 is a reply to message #778535] Sat, 28 January 2012 17:59 Go to previous message
sri charan is currently offline sri charanFriend
Messages: 4
Registered: January 2012
Junior Member
Try creating a simple html page and name it as index.html and run your web project in your webserver. (Mention the webserver tat u use)
Previous Topic:Find Eclipse java build command
Next Topic:Where is Eclipse's Android SDK Looking for Rev Status?
Goto Forum:

Current Time: Wed Oct 07 04:39:02 GMT 2015

Powered by FUDForum. Page generated in 0.01648 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software