Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Issue with Postgresql connection(Where does the postgresql jdbc driver go)
Issue with Postgresql connection [message #778386] Thu, 12 January 2012 12:28 Go to next message
Carl Bader is currently offline Carl Bader
Messages: 15
Registered: November 2011
Junior Member
I was able to get Postgresql database to work with the standalone Jubula and connect with a Windows Jubula standalone installation. I am trying to connect to the Postgresql on a linux box with Eclipse for Tester installation. I keep getting a no driver found when I select to connect to the remote Postgresql database.

I am trying to get a linux and windows Eclipse for Testers so I can use the tests I have created and stored on the Postgresql database.

I have found a location under the standalone linux .jubula/configAreas/jubula/5.2.00266/org.eclipse.osgi/10/1/.cp/database/drivers where I find a postgresql-8.4-701.jdbc3.jar.

Is there a location on the Eclipse for Testers. I have found a location on the system and loaded the driver but still get the no driver found.

Location:
/eclipse/configuration/org.eclipse.osgi/bundles/ but I can't find a place for database/driver is there somewhere else I can look?
Re: Issue with Postgresql connection [message #778533 is a reply to message #778386] Fri, 13 January 2012 01:53 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1092
Registered: July 2009
Senior Member
Hi,

The Eclipse for Testers does not include any database drivers - you must get these from the marketplace. See the section on additional software on the downloads page.

Regards,
Alex
Re: Issue with Postgresql connection [message #778739 is a reply to message #778533] Fri, 13 January 2012 13:34 Go to previous messageGo to next message
Carl Bader is currently offline Carl Bader
Messages: 15
Registered: November 2011
Junior Member
I tried to locate the drivers on the MarketPlace. I was only able to locate under the Yoxos selection "Data Tools Platform Enablement for PostgreSQL" and "Data Tools Platform Enablement for PostgreSQL Sou". I have install both since they seem to want each other. I still get a "no drivers found" error when trying to connect to my PostgreSQL database.

Any time I try to sort by Database it closes the window and opens up a panel in the frame just times out.

Is there some other package that I can't find I should install to get the correct driver?

Thanks
Re: Issue with Postgresql connection [message #778780 is a reply to message #778739] Fri, 13 January 2012 15:21 Go to previous messageGo to next message
Achim Loerke is currently offline Achim Loerke
Messages: 331
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

As Alex mentioned above have a look at the download page. There are links to the Marketplace and brief instructions on how to install the db drivers.

- Achim
Re: Issue with Postgresql connection [message #778795 is a reply to message #778780] Fri, 13 January 2012 16:11 Go to previous messageGo to next message
Carl Bader is currently offline Carl Bader
Messages: 15
Registered: November 2011
Junior Member
I am sorry. I am not seeing any Database drivers other than the ones I list in the reply above. Can someone point out which one I need to search for?
Re: Issue with Postgresql connection [message #778822 is a reply to message #778795] Fri, 13 January 2012 17:32 Go to previous message
Carl Bader is currently offline Carl Bader
Messages: 15
Registered: November 2011
Junior Member
OK I feel stupid. I just realized that I could drag the Install box to the workspace and the marketspace would call the installer for me.

It is installing the drivers and I think I will be fine. Thank you for putting up with my small knowledge.
Previous Topic:can't close a window (swt)
Next Topic:Upcoming training courses at BREDEX
Goto Forum:
  


Current Time: Sat Aug 02 02:32:45 EDT 2014

Powered by FUDForum. Page generated in 0.05256 seconds