Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » External Application Text input error with unix location path as parameter value
External Application Text input error with unix location path as parameter value [message #778277] Thu, 12 January 2012 05:59 Go to next message
Claire Lee is currently offline Claire LeeFriend
Messages: 9
Registered: July 2009
Junior Member
I created a test step to enter unix path location in a native dialog with External Application Text Input but the test execution always failed with error saying "Invalid parameter value". The location path is in the following format:
/path/to/a/folder

I have tried setting the parameter value with:
'/path/to/a/folder'
\\/path\\/to\\/a\\/folder
"/path/to/a/folder'

but they are failed. It worked when I enter just a single word as the parameter value. Please let me know what I have missed out. Thanks!
Re: External Application Text input error with unix location path as parameter value [message #778283 is a reply to message #778277] Thu, 12 January 2012 07:00 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1163
Registered: July 2009
Senior Member
Hi,

As described in the documentation for this action (under this link, (search for "External Input Text (Application)" in the file), the external input text for SWT and RCP can only enter ASCII characters.

For your case here, I'd recommend building a module that copies the path you want to the clipboard and then using external key combination to paste it in the field with Ctrl+V or Mod1+V.

HTH,
Alex
Re: External Application Text input error with unix location path as parameter value [message #778296 is a reply to message #778283] Thu, 12 January 2012 08:11 Go to previous message
Claire Lee is currently offline Claire LeeFriend
Messages: 9
Registered: July 2009
Junior Member
Perfect. That works. Thanks!
Previous Topic:"teardown" to clean application's database?
Next Topic:Problems with jubula on OpenSuse 11.2/KDE
Goto Forum:
  


Current Time: Thu Nov 27 00:44:56 GMT 2014

Powered by FUDForum. Page generated in 0.06442 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software