Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » AUT will not start(I cannot get my AUT to start)
AUT will not start [message #777527] Tue, 10 January 2012 11:29 Go to next message
Diane Mising name is currently offline Diane Mising name
Messages: 22
Registered: June 2011
Junior Member
I have followed the instructions. I have tried two different PC's and I cannot get my AUT to start. I am using Eclipse Indigo with the Jubula plugin. I have also downloaded the database drivers from the Eclipse Marketplace. I can get the Agent to start, but I constantly get the edit that the AUT has failed to start. I have tried everything I can think of. Here is the error that is in the log.

2012-01-10 09:53:41.549 [Worker-2] WARN o.e.j.c.c.c.ServerConnection - connecting the AUT Agent failed
2012-01-10 10:03:38.205 [Connection.ReaderThread:Socket[addr=/127.0.0.1,port=2842,localport=60000]] ERROR o.e.j.a.c.StartAUTServerCommand - An error occured:
java.lang.NullPointerException: null
at org.eclipse.core.runtime.FileLocator.getBundleFile(FileLocator.java:243) ~[na:na]
at org.eclipse.jubula.autagent.commands.AbstractStartToolkitAut.getClasspathEntriesForBundleId(AbstractStartToolkitAut.java:275) ~[na:na]
at org.eclipse.jubula.autagent.commands.AbstractStartToolkitAut.getClasspathForBundleId(AbstractStartToolkitAut.java:321) ~[na:na]
at org.eclipse.jubula.autagent.commands.StartHtmlAutServerCommand.createCmdArray(StartHtmlAutServerCommand.java:109) ~[na:na]
at org.eclipse.jubula.autagent.commands.AbstractStartToolkitAut.startAut(AbstractStartToolkitAut.java:75) ~[na:na]
at org.eclipse.jubula.autagent.commands.StartAUTServerCommand.execute(StartAUTServerCommand.java:116) ~[na:na]
at org.eclipse.jubula.communication.Communicator$ConnectionListener.received(Communicator.java:845) [org.eclipse.jubula.communication_1.1.0.201109140653.jar:na]
at org.eclipse.jubula.communication.connection.Connection.fireMessageReceived(Connection.java:402) [org.eclipse.jubula.communication_1.1.0.201109140653.jar:na]
at org.eclipse.jubula.communication.connection.Connection.access$3(Connection.java:391) [org.eclipse.jubula.communication_1.1.0.201109140653.jar:na]
at org.eclipse.jubula.communication.connection.Connection$ReaderThread.run(Connection.java:454) [org.eclipse.jubula.communication_1.1.0.201109140653.jar:na]
2012-01-10 10:03:38.205 [Connection.ReaderThread:Socket[addr=localhost/127.0.0.1,port=60000,localport=2842]] ERROR o.e.j.c.c.c.StartAUTServerStateCommand - AUTServer could not start:

My configuration is as follows:

AUT Configuration Name: ACMS@localhost
AUT Agent Host: localhost
AUT ID: ACMS
AUT URL: ...iratetest.acuity.com/content/index/ui/main.jsp
Browser: IE

I am using IE8, Windows XP machine. I am connecting to the Embedded AUT agent. I am using the embedded database.

What am I missing?!? Thanks for your help.
Re: AUT will not start [message #778263 is a reply to message #777527] Wed, 11 January 2012 21:59 Go to previous messageGo to next message
Douglas Hardy is currently offline Douglas Hardy
Messages: 1
Registered: January 2012
Junior Member
Hi

Has anyone found a cause / solution for this? I am having exactly the same problem, on a Windows XP box.

Thanks
Douglas
Re: AUT will not start [message #778308 is a reply to message #778263] Thu, 12 January 2012 05:00 Go to previous messageGo to next message
Oliver Goetz is currently offline Oliver Goetz
Messages: 91
Registered: May 2011
Member
Hi,

the problem here is the missing web support in the plugin version of Jubula. Try using the standalone version which you can find here.
Regards
Oliver
Re: AUT will not start [message #778352 is a reply to message #778308] Thu, 12 January 2012 09:42 Go to previous message
Diane Mising name is currently offline Diane Mising name
Messages: 22
Registered: June 2011
Junior Member
I can definitely try the standalone version, but we would prefer to use the plugin version. Is this something that is going to be fixed?

Thanks
Diane
Previous Topic:Problems with jubula on OpenSuse 11.2/KDE
Next Topic:can't close a window (swt)
Goto Forum:
  


Current Time: Wed Jul 23 05:57:04 EDT 2014

Powered by FUDForum. Page generated in 0.03761 seconds