Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » subversive will not install
subversive will not install [message #8063] Sat, 14 July 2007 12:48 Go to next message
Eclipse User
Originally posted by: hansm.science.uva.nlDELETE

Installed Eclipse 3.3
Downloaded Subversive_1.1.3-LocalUpdateSite.zip
Got following error message on installing in eclipse through the installer:
Subversive Integration for the CSC Project Set Project (Optional) (1.0.4)
requires feature "com.csc.dip.projectset.feature".

What is this? I cannot imagine the full eclipse 3.3 download (rcp version) is
incomplete. So is this subversive localupdatesite.zip incomplete? Why then?
I have worked with subversive before on older eclipse versions, but if it now
will not install I have no choice but to drop its usage.

Hans van der Meer
Re: subversive will not install [message #8157 is a reply to message #8063] Mon, 16 July 2007 09:27 Go to previous messageGo to next message
Igor Vinnykov is currently offline Igor Vinnykov
Messages: 61
Registered: July 2009
Member
Dear Hans,

Project Set integration is an optional feature, which you can install only
if you use CSC Project Set plugin. You can find detailed information for all
features in Subversive installation if you select feature in the Updates
dialog. Then under the tree you will see description text. For CSC Project
Set Project it looks like "Integration with ProjectSet
(http://vpms.de.csc.com/projectset/). Installation is possible only if
ProjectSet is already installed or installed in one step with Subversive."

Best regards,
Igor Vinnykov
Subversive Team

"dr. Hans van der Meer" <hansm@science.uva.nlDELETE>
Re: subversive will not install [message #8221 is a reply to message #8157] Mon, 16 July 2007 14:53 Go to previous messageGo to next message
Eclipse User
Originally posted by: hansm.science.uva.nlDELETE

In article <f7fdm8$lvd$1@build.eclipse.org>,
"Igor Vinnykov" <igor.vinnykov@polarion.org> wrote:

> Dear Hans,
>
> Project Set integration is an optional feature, which you can install only
> if you use CSC Project Set plugin. You can find detailed information for all
> features in Subversive installation if you select feature in the Updates
> dialog. Then under the tree you will see description text. For CSC Project
> Set Project it looks like "Integration with ProjectSet
> (http://vpms.de.csc.com/projectset/). Installation is possible only if
> ProjectSet is already installed or installed in one step with Subversive."
>
> Best regards,
> Igor Vinnykov
> Subversive Team

I do not completely understand the answer. Does it mean that I do need to have
the CSC Project Set plugin also, in order to be able to install and work with
subversive under eclipse 3.3?

As for the installation of javaHL for MacOSX, I did reply to your 1.1.3 release
announcement: I cannot find on the subversion site how to acquire the necessary
javaHL.

Hans van der Meer
Re: subversive will not install [message #8284 is a reply to message #8221] Wed, 18 July 2007 09:12 Go to previous messageGo to next message
Igor Vinnykov is currently offline Igor Vinnykov
Messages: 61
Registered: July 2009
Member
Dear Hans,

Like I mentioned in the post - Subversive Project Set integration is an
optional feature, which should be installed only if you use CSC Project Set
plugin and want to have it integrated with Subversive. I all other cases you
don't need to install this instagretion. It doesn't have influence to the
Subversive functionality.

Best regards,
Igor Vinnykov

"dr. Hans van der Meer" <hansm@science.uva.nlDELETE>
Re: subversive will not install [message #8316 is a reply to message #8284] Wed, 18 July 2007 12:19 Go to previous message
Eclipse User
Originally posted by: hansm.science.uva.nlDELETE

Thanks Igor.

Just now I found out that the install has several subitems and then found the
one that must be disabled in order to remove the error message. Glad to here
noninstalling that option does not restrict svn usage. However, could you
consider some explaining comment about this in the install dialog? Perhaps
others like me do not suspect that deselecting a subfeature will make the evil
looking error message go away and, like me, might be intimidated by it.

As for the javaHL problem I encountered: downloading and installing svnkit as
eclipse plugin from its homesite and selecting it in the eclipse team-svn
preferences solved that.

Hans van der Meer

In article <f7kli7$8j4$1@build.eclipse.org>,
"Igor Vinnykov" <igor.vinnykov@polarion.org> wrote:

> Dear Hans,
>
> Like I mentioned in the post - Subversive Project Set integration is an
> optional feature, which should be installed only if you use CSC Project Set
> plugin and want to have it integrated with Subversive. I all other cases you
> don't need to install this instagretion. It doesn't have influence to the
> Subversive functionality.
>
> Best regards,
> Igor Vinnykov
>
> "dr. Hans van der Meer" <hansm@science.uva.nlDELETE>
Previous Topic:Announcement: Subversive 1.1.3 release
Next Topic:Any news on a release to support Mylin?
Goto Forum:
  


Current Time: Tue Sep 30 18:06:34 GMT 2014

Powered by FUDForum. Page generated in 0.01681 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software