Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Window Builder problems(Problem when i try to add a Swing User Interface)
Window Builder problems [message #777175] Mon, 09 January 2012 20:09 Go to next message
Ashaelon P is currently offline Ashaelon P
Messages: 2
Registered: January 2012
Junior Member
Hi all -

Let me start off by saying that I have written one Java app in my entire life, and it consisted of displaying "Hello World". Now, I installed the Window Builder plug-in to try to create a GUI app, and when I try to add the Swing User Interface, I am prompted to click "Finish" to install the toolkit. The install stops and displays a window that has "Swing Designer" in a listbox and it is checked. When i click on it, it tells me "Cannot complete the install because of a conflicting dependency". The only option i have is to uncheck it, which only allows me to cancel, or just click cancel. Clicking Next does nothing.

I am using Eclipse SDK 3.7.1, and i installed WB for Indigo 3.7.

Any ideas of how i can fix this problem?

Also, i get a similar error when i try to add the SWT User Interface. The only difference is that it lists the SWT Designer.

TIA
Re: Window Builder problems [message #777491 is a reply to message #777175] Tue, 10 January 2012 10:44 Go to previous messageGo to next message
Nick Clevery is currently offline Nick Clevery
Messages: 50
Registered: January 2012
Member
Indigo comes with WindowBuilder already and Swing toolkit is installed so don't have to install it.
In your case, did Eclipse provide details for the error?
Re: Window Builder problems [message #777531 is a reply to message #777491] Tue, 10 January 2012 11:33 Go to previous messageGo to next message
Ashaelon P is currently offline Ashaelon P
Messages: 2
Registered: January 2012
Junior Member
No, it did not give any error details.

I think i figured out what happened. I guess i just needed to walk away for the night because i was frustrated. I didnt have WindowBuilder that i know of before i installed it as new software. I fixed it by going back to "Install New Software..." and selecting Swing Designer and SWT Designer for the items to install. I didnt do that before. I only selected to install WindowBuilder Engine.

It appears to be working now. Sorry for the false alarm. Smile Thanks for the reply.
Re: Window Builder problems [message #1120003 is a reply to message #777531] Sun, 29 September 2013 00:22 Go to previous message
sea tony is currently offline sea tony
Messages: 1
Registered: September 2013
Junior Member
i got the same problem what you said,and i uninstall the wb bundle that i installed for a few times ago,and install it again .it's ok.
Previous Topic:Problems with Eclipse download
Next Topic:Which load testing tool is a right tool for load/perf testing on Eclipse Plug-In application
Goto Forum:
  


Current Time: Sat Aug 30 02:39:44 EDT 2014

Powered by FUDForum. Page generated in 0.02176 seconds