Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse Package Installation Errors(Missing packages)
Eclipse Package Installation Errors [message #776260] Sat, 07 January 2012 20:02 Go to next message
James Murdock is currently offline James Murdock
Messages: 3
Registered: January 2012
Junior Member
CentOS 6
Linux 2.6.32-131.0.15.el6.x86_64 #1 SMP
Repo: download.eclipse.org/releases/helios
Eclipse Platform Version: 3.6.1
Build id: M20100909-0800

I am trying to install WDT and I get the following error no matter what I do:

An error occurred while collecting items to be installed
session context was:(profile=PlatformProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: osgi.bundle,org.eclipse.cvs.source,1.0.500.v20100414
No repository found containing: org.eclipse.update.feature,org.eclipse.cvs.source,1.2.0.v20100427-7B77FKt90GE5h0NCO35T7A01911
No repository found containing: osgi.bundle,org.eclipse.ecf.filetransfer.source,4.0.0.201110251336
No repository found containing: osgi.bundle,org.eclipse.ecf.identity.source,3.1.0.201110251336
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer.httpclient.source,4.0.0.201110251336
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer.httpclient.ssl.source,1.0.0.201110251336
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer.source,3.1.0.201110251336
No repository found containing: osgi.bundle,org.eclipse.ecf.provider.filetransfer.ssl.source,1.0.0.201110251336
No repository found containing: osgi.bundle,org.eclipse.ecf.source,3.1.0.201110251336
No repository found containing: osgi.bundle,org.eclipse.ecf.ssl.source,1.0.100.201110251336
No repository found containing: org.eclipse.update.feature,org.eclipse.equinox.p2.user.ui.source,2.0.1.r361_v20100903-897HF_oFSRe_8pL9GBQDCs7
No repository found containing: osgi.bundle,org.eclipse.help.base.source,3.5.2.r36_r20100816
No repository found containing: org.eclipse.update.feature,org.eclipse.help.source,1.2.0.v20100427-7e7jESFCsz-mFu_PfwL1ht5
No repository found containing: osgi.bundle,org.eclipse.jdt,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.jdt,3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX
No repository found containing: osgi.bundle,org.eclipse.jdt.source,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.jdt.source,3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX
No repository found containing: osgi.bundle,org.eclipse.pde,3.6.1.v20100625_r361
No repository found containing: org.eclipse.update.feature,org.eclipse.pde,3.6.1.r361_v20100727-7b7mFL-FDX-bf3Q-g1cCcoM
No repository found containing: osgi.bundle,org.eclipse.pde.source,3.6.1.v20100625_r361
No repository found containing: org.eclipse.update.feature,org.eclipse.pde.source,3.6.1.r361_v20100727-7b7mFL-FDX-bf3Q-g1cCcoM
No repository found containing: osgi.bundle,org.eclipse.platform.source,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.platform.source,3.6.1.r361_v20100909-9pF78H4oFrRqnz-rr2sGKT6TX5Jjk3z0UdMaW
No repository found containing: osgi.bundle,org.eclipse.rcp.source,3.6.0.v20100527-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.rcp.source,3.6.1.r361_v20100827-9oBYFOtFkzKz-AxIz-fgWr5_V
No repository found containing: osgi.bundle,org.eclipse.sdk,3.6.1.r361_v20100714-0800
No repository found containing: org.eclipse.update.feature,org.eclipse.sdk,3.6.1.r361_v20100714-0800-7Q7m6D9kQffjB-G1z-jfKYkc-vqs8r_Xuk3eIYZU8_cvU
No repository found containing: osgi.bundle,org.objectweb.asm,3.2.0
Re: Eclipse Package Installation Errors [message #776499 is a reply to message #776260] Sun, 08 January 2012 10:58 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin Dahyabhai
Messages: 2237
Registered: July 2009
Senior Member
You're going to have to give more information than that. What's WDT? From what Update Site were you getting it from? Were you letting Eclipse check all of its known update sites? Why are you starting from Helios (and not even the latest Helios) instead of Indigo SR1?

---
Nitin Dahyabhai
Eclipse WTP, IBM
Re: Eclipse Package Installation Errors [message #776683 is a reply to message #776499] Sun, 08 January 2012 23:14 Go to previous messageGo to next message
James Murdock is currently offline James Murdock
Messages: 3
Registered: January 2012
Junior Member
Quote:
You're going to have to give more information than that.


Well, I thought that was quite enough information...

Quote:
What's WDT?


WDT = Web Development Tools

Quote:
From what Update Site were you getting it from?


The update site is already listed above "Repo: download.eclipse.org/releases/helios"
Or at least that is where the Web Development Tools is listed under when I check the pretty little box. (eclipse newb here)

Quote:
Were you letting Eclipse check all of its known update sites?


What do you mean? I let Eclipse do whatever it needs to do, not sure how I would be restricting it??

Quote:
Why are you starting from Helios (and not even the latest Helios) instead of Indigo SR1?


because that is what gets installed when I perform: yum install eclipse-platform
I still don't see how this matters at all... please explain. What if I knew what I was doing and wanted to use this version? Should that matter whatsoever? I wouldn't think so. (again, eclipse newb here)

Thank you for any help you can offer me Wink

Much Respect,

James
Re: Eclipse Package Installation Errors [message #776941 is a reply to message #776683] Mon, 09 January 2012 10:15 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3136
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 08-Jan-12 21:14, James Murdock wrote:
> [snip]
> because that is what gets installed when I perform: yum install
> eclipse-platform
> I still don't see how this matters at all... please explain. What if I
> knew what I was doing and wanted to use this version? Should that matter
> whatsoever? I wouldn't think so. (again, eclipse newb here)

Ah, there's the rub! Never, never, never install Eclipse from any Linux
distro package manager. Always download it from eclipse.org unless your
platform is just too weird and needs special treatment.
Re: Eclipse Package Installation Errors [message #777161 is a reply to message #776941] Mon, 09 January 2012 19:28 Go to previous message
James Murdock is currently offline James Murdock
Messages: 3
Registered: January 2012
Junior Member
Well I'll be! That is just lame that you can't use the package managers. However, you were right Wink Thank you for your help.

Respect,

James
Previous Topic:starting eclipse on Linux
Next Topic:Referenced part does not exist yet: org.eclipse.ui.editorss.
Goto Forum:
  


Current Time: Thu Jul 31 03:28:11 EDT 2014

Powered by FUDForum. Page generated in 0.01837 seconds