Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » P2 Update not working
P2 Update not working [message #775033] Thu, 05 January 2012 06:59
Vishal seth is currently offline Vishal seth
Messages: 32
Registered: April 2010
Member
Hi,

I am trying to build a p2 enabled update site for RCP application, but have failed to do so. The product consists of features.

Went through following articles but in vain

http://www.ralfebert.de/blog/eclipsercp/p2_updates_tutorial_36/
http://aniefer.blogspot.com/2009/07/composing-and-updating-custom-eclipse.html
http://aniefer.blogspot.com/2009/07/adt-part-2-more-like-epp.html

When I try to update with new version it says :

My Feature" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
Software being installed: My Feature 1.2.1 (my.feature.group 1.2.1)
Software currently installed: My Studio 1.1.1 (my 1.1.1)
Only one of the following can be installed at once:
my 1.2.1 (x 1.2.1)
my 1.1.1 (x 1.1.1)
Cannot satisfy dependency:
From:My Studio 1.1.1 (My 1.1.1)
To: my.feature.group [1.1.1]
Cannot satisfy dependency:
From: My Feature 1.1.1 (my.feature.group 1.1.1)
To: my [1.1.1]

Tried various things mentioned in above article, but guess definitely missing something.

If I add the plugin in feature as dependencies, then it does not get included in the build as mentioned in the adt-epp article. Not sure how to achieve that.

I am using Helios SR1 release.

Any clue?

Regards
Vishal

Previous Topic:Problem with partial mirroring from update site that only contains packed bundles
Next Topic:How to prevent uninstalling itself?
Goto Forum:
  


Current Time: Wed Sep 17 01:38:39 GMT 2014

Powered by FUDForum. Page generated in 0.02921 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software