Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Greenpages 2.4 not working(Greenpages 2.4 not working)
Greenpages 2.4 not working [message #774909] Wed, 04 January 2012 17:26 Go to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
Hello all,

I've been developing OSGi for bit and I decided that Virgo would probably be a great platform for my project. So far my bundles appear to be installing and running correctly however it's not time for the front end. Since I haven't really developed for Virgo I decided to start with Greenpages 2.4 and Virgo Tomcat 3.0.2. In following the instructions I was able to successfully install and run Virgo with a maven built par of Greenpages. It worked exactly as expected. I have since tried to open the projects in Eclipse - this has been very frustrating and where I need some assistance.

I have the Jave EE version of Indigo and Helios and installed the Virgo Tools. I have tried just about every combination I can come across. I have copy the dependencies to repository/usr and import the projects. I've installed the Virgo Tools into Eclipse and configured a Virgo server then added the web project. I always seem to run into the same problem where the various projects can't resolve org.springsource.*.

I'm not entirely sure that I'm getting Eclipse set up correctly so any specific information about versions/steps would be helpful.

Thanks!
Re: Greenpages 2.4 not working [message #775060 is a reply to message #774909] Thu, 05 January 2012 03:31 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Are you sure you are using the Virgo tooling and not the SpringSource dm Server tooling? Follow the installation instructions on the wiki and ensure that you choose a server from the EclipseRT category.
Re: Greenpages 2.4 not working [message #775196 is a reply to message #775060] Thu, 05 January 2012 09:39 Go to previous messageGo to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
Yes, I'm sure that I've done that. I will try again from completely fresh installs just to be absolutely sure.
Re: Greenpages 2.4 not working [message #775200 is a reply to message #775196] Thu, 05 January 2012 09:49 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Thanks. org.springsource.* rang alarm bells for me. Perhaps you were referring to com.springsource.* packages from the Enterprise Bundle Repository, but other than those, Virgo does not include any springsource packages (like it used to do when it was SpringSource dm Server).

Anyway, please let us know how you get on.
Re: Greenpages 2.4 not working [message #775252 is a reply to message #775060] Thu, 05 January 2012 11:35 Go to previous messageGo to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
The files that I am using are:

eclipse-jee-indigo-SR1-win32-x86_64.zip
greenpages-2.4.0.RELEASE.zip
virgo-tomcat-server-3.0.2.RELEASE.zip

with JDK 1.6.0 u27 on Windows 7 Pro 64 bit.

These are the steps that I took:

1. Unpack all zip files to c:\temp
(C:\temp\eclipse)
(C:\temp\greenpages-2.4.0.RELEASE)
(C:\temp\virgo-tomcat-server-3.0.2.RELEASE)

2. Run eclipse, add 'http//dist.springsource.com/release/TOOLS/update/2.7.1.RELEASE/e3.6' to update sites but didn't install anything. Added site 'http//download.eclipse.org/virgo/milestone/IDE/' and installed Eclipse Virgo Tools.

3. Open command prompt and went to C:\temp\greenpages-2.4.0.RELEASE\solution and ran 'mvn package'

4. copied C:\temp\greenpages-2.4.0.RELEASE\solution\greenpages\target\par-provided\*.jar to C:\temp\virgo-tomcat-server-3.0.2.RELEASE\repository\usr

5. Configured Virgo Server runtime in Eclipse using EclipseRT / Virgo Web Server and pointed it to C:\temp\virgo-tomcat-server-3.0.2.RELEASE with Workbench default JRE (runtime was named Virgo Web Server (Runtime) v2.1)

6. Imported projects into Eclipse from C:\temp\greenpages-2.4.0.RELEASE\solution using Eclipse import wizard.

7. Closed and reopened projects as stated in the greenpages setup and the performed a Project -> Clean on all projects.

The problems still persist. Eclipse is showing 99 errors and most of them appear to be the result of unresolved org.springframework.*

I hope this was descriptive enough as I really want to solve this so I can start using Virgo.

Thanks again for any assistance!
Re: Greenpages 2.4 not working [message #775254 is a reply to message #775252] Thu, 05 January 2012 11:38 Go to previous messageGo to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
Glyn thanks for the replies! Yes I must have gotten the packages confused. org.springframework.* is what I meant but I must have seen com.springsource in there somewhere and mixed them together.
Re: Greenpages 2.4 not working [message #775262 is a reply to message #775254] Thu, 05 January 2012 11:59 Go to previous messageGo to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
Forgot one more step. Added project greenpages.web-solution to the Virgo server configuration.
Re: Greenpages 2.4 not working [message #775552 is a reply to message #775262] Fri, 06 January 2012 04:06 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Hi Brian

Since you have so carefully documented the steps you took, we'll try to recreate the problem in next week's sprint and then get back to you.

Regards,
Glyn
Re: Greenpages 2.4 not working [message #775555 is a reply to message #775552] Fri, 06 January 2012 04:12 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
Raised bug 368008 to track.
Re: Greenpages 2.4 not working [message #775556 is a reply to message #775555] Fri, 06 January 2012 04:12 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn Normington
Messages: 1222
Registered: July 2009
Senior Member
(I mistook a slow forum response for a no-op and accidentally created a blank post)

[Updated on: Fri, 06 January 2012 04:13]

Report message to a moderator

Re: Greenpages 2.4 not working [message #775655 is a reply to message #775556] Fri, 06 January 2012 08:21 Go to previous messageGo to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
Glyn, that's great. I really appreciate your help.

The one thing that I did notice was that in the GreenPages installation directions, there is mention to add the greenpages-solution project to the Virgo server setup. When I display the add/remove options for the server, the only option I get is the greenpages.web-solution. Would this be the a part of the problem?

Thanks - Brian
Re: Greenpages 2.4 not working [message #778258 is a reply to message #775655] Wed, 11 January 2012 21:16 Go to previous messageGo to next message
Leo Dos Santos is currently offline Leo Dos Santos
Messages: 26
Registered: July 2009
Junior Member
Brian I followed the same steps you did and also came to 99 errors! The solution was to install the old m2eclipse plugins. It's possible the instructions were written with the SpringSource Tool Suite in mind, which did include m2eclipse but won't be part of a vanilla Eclipse.
Re: Greenpages 2.4 not working [message #778341 is a reply to message #778258] Thu, 12 January 2012 08:19 Go to previous messageGo to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
Leo,

Thanks for looking into that. I will give it a shot today and report back my findings. Is there anything other than installing m2eclipse that I need to do? (remove m2e first etc?)

Thanks again - Brian
Re: Greenpages 2.4 not working [message #778384 is a reply to message #778341] Thu, 12 January 2012 12:00 Go to previous messageGo to next message
Chris Frost is currently offline Chris Frost
Messages: 230
Registered: January 2010
Location: Southampton, England
Senior Member

Hi,

I've had a look at this and it turns out that their were a few problems. These have all been fixed in the sample and will be available for the next release of Greenpages. Unfortunately it's more than I can guide you through here, the best thing would be to check out the source for the sample from out git repo and try again (http://git.eclipse.org/c/virgo/org.eclipse.virgo.sample-greenpages.git) I've made changes to the code and docs but you would only need to build the doc as an extra as you build the solution as a part of the sample anyway.

This problem is a result of moving to the new Virgo tooling, we missed some renaming in the settings files and there is an extra step to install the 'm2e' plugin in to Eclipse.

Chris.


------------------------------------------------
Chris Frost, Twitter @cgfrost
Springsource, a divison of VMware.
Re: Greenpages 2.4 not working [message #778851 is a reply to message #778384] Fri, 13 January 2012 19:14 Go to previous messageGo to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
Thank's for the information Chris. I was able to get greenpages 2.5 and get it configured in Eclipse Indigo. I have one problem remaining and then I should be in business. I am getting one error:

maven-dependency-plugin (goals "copy-dependencies", "unpack") is not supported by m2e.

This is a problem with the execution node in pom.xml in the greenpages-solution project. I've searched google several times and there info about this error however none of it seems to pertain to this node. Any ideas on how to get past it? I installed m2e v1.0.1 if helps.

Thanks - Brian
Re: Greenpages 2.4 not working [message #778852 is a reply to message #778851] Fri, 13 January 2012 19:17 Go to previous messageGo to next message
Brian Williamson is currently offline Brian Williamson
Messages: 22
Registered: January 2012
Location: Toledo, Ohio
Junior Member
On another note I was able to remove that node and run the project successfully. I guess I'll have to dive in and figure out what it is used for.
Re: Greenpages 2.4 not working [message #780944 is a reply to message #778852] Fri, 20 January 2012 00:37 Go to previous messageGo to next message
Miles Parker is currently offline Miles Parker
Messages: 1338
Registered: July 2009
Senior Member
Brian,

Leo and I also came across that Maven issue. It doesn't seem to actually break anything AFAICT. Leo found this:

http://stackoverflow.com/questions/8706017/maven-dependency-plugin-goals-copy-dependencies-unpack-is-not-supported-b

So we tried pasting in:


<?xml version="1.0" encoding="UTF-8"?>
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">

<parent>
<groupId>org.eclipse.virgo</groupId>
<artifactId>greenpages.parent-solution</artifactId>
<version>2.5.0.RELEASE</version>
<relativePath>../parent</relativePath>
</parent>

<modelVersion>4.0.0</modelVersion>
<artifactId>greenpages-solution</artifactId>
<name>greenpages.par</name>
<description>GreenPages PAR</description>
<packaging>par</packaging>

<dependencies>
<dependency>
<groupId>org.eclipse.virgo</groupId>
<artifactId>greenpages.app-solution</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.eclipse.virgo</groupId>
<artifactId>greenpages.jpa-solution</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.eclipse.virgo</groupId>
<artifactId>greenpages.db-solution</artifactId>
<version>${project.version}</version>
</dependency>
<dependency>
<groupId>org.eclipse.virgo</groupId>
<artifactId>greenpages.web-solution</artifactId>
<version>${project.version}</version>
<type>war</type>
</dependency>
<!-- Required for the web bundle as dependencies are not propagated up
from war build types -->
<dependency>
<groupId>org.freemarker</groupId>
<artifactId>com.springsource.freemarker</artifactId>
<scope>provided</scope>
</dependency>
</dependencies>
<build>
<pluginManagement>
<plugins>
<!-- Ignore/Execute plugin execution -->
<plugin>
<groupId>org.eclipse.m2e</groupId>
<artifactId>lifecycle-mapping</artifactId>
<version>1.0.0</version>
<configuration>
<lifecycleMappingMetadata>
<pluginExecutions>
<!-- copy-dependency plugin -->
<pluginExecution>
<pluginExecutionFilter>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-dependency-plugin</artifactId>
<versionRange>[1.0.0,)</versionRange>
<goals>
<goal>copy-dependencies</goal>
</goals>
</pluginExecutionFilter>
<action>
<ignore />
</action>
</pluginExecution>
</pluginExecutions>
</lifecycleMappingMetadata>
</configuration>
</plugin>
</plugins>
</pluginManagement>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-par-plugin</artifactId>
<version>1.0.0.RELEASE</version>
<configuration>
<applicationSymbolicName>greenpages</applicationSymbolicName>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-dependency-plugin</artifactId>
<configuration>
<outputDirectory>${project.build.directory}/par-provided</outputDirectory>
<overWriteIfNewer>true</overWriteIfNewer>
<excludeGroupIds>org.eclipse.virgo,org.apache.log4j</excludeGroupIds>
</configuration>
<executions>
<execution>
<id>copy-dependencies</id>
<phase>package</phase>
<goals>
<goal>copy-dependencies</goal>
</goals>
</execution>
</executions>
</plugin>
</plugins>
</build>

</project>


Which seemed to make the error go away, but I'm not sure what it accomplished short of adding more Mavenish elements to the file and making the error marker go away. ;D
Re: Greenpages 2.4 not working [message #871735 is a reply to message #780944] Mon, 14 May 2012 15:05 Go to previous message
Thorsten Schlathölter is currently offline Thorsten Schlathölter
Messages: 208
Registered: February 2012
Location: Düsseldorf
Senior Member
I have just tried to get the greenpages example 2.5 running. Installed Eclipse 3.7.2 all current toolings etc. The copy-dependencies error is still there. Just to clarify this issue: the copy dependencies goal is responsible for copying the dependent bundles into the target/par-provided directory.

Regards,
Thorsten
Previous Topic:Weird ClassNotFoundException
Next Topic:How to view bundle dependency graph on Virgo
Goto Forum:
  


Current Time: Thu Aug 28 23:39:46 EDT 2014

Powered by FUDForum. Page generated in 0.02321 seconds