Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Virgo » Virgo Server Tooling on STS 2.9.0.M1 works!(and FYI Virgo tooling/IDE is only a separation of Virgo (/DM Server) stuff inside STS)
icon4.gif  Virgo Server Tooling on STS 2.9.0.M1 works! [message #774689] Wed, 04 January 2012 12:11 Go to next message
Jochen Szostek is currently offline Jochen SzostekFriend
Messages: 24
Registered: January 2011
Location: Maasmechelen
Junior Member

Just wanted to let people know that the Virgo Tooling works on STS 2.9.0.M1 via update site: http://download.eclipse.org/virgo/snapshot/IDE

I got confused because the Virgo Tooling site got me thinking that this wouldn't work. (I thought that is was needed from now on to plug the tooling in a "normal" Eclipse) So I guess the whole Virgo IDE concept is just the whole Virgo Tooling being separated from STS.

I did update/add this info too @ http://wiki.eclipse.org/index.php?title=Virgo/Tooling
Hope that was ok? (as it makes the whole Virgo IDE concept a bit more clear)

[Updated on: Wed, 04 January 2012 12:18]

Report message to a moderator

Re: Virgo Server Tooling on STS 2.9.0.M1 works! [message #774698 is a reply to message #774689] Wed, 04 January 2012 12:20 Go to previous messageGo to next message
Glyn Normington is currently offline Glyn NormingtonFriend
Messages: 1222
Registered: July 2009
Senior Member
Thanks for pointing this out Jochen. It wasn't ok that you updated the wiki - it was very good! Smile
Re: Virgo Server Tooling on STS 2.9.0.M1 works! [message #774886 is a reply to message #774689] Wed, 04 January 2012 21:07 Go to previous messageGo to next message
Frieder Heugel is currently offline Frieder HeugelFriend
Messages: 61
Registered: October 2010
Location: Basel, CH
Member
Hi Jochen

Did you do something special to get Virgo IDE running in STS 2.9.0M1? I downloaded the latest STS milestone and tried to install the Virgo Tools from the snapshot update site but it still complains about the Spring version (org.eclipse.virgo.ide.manifest.core 1.0.0.201110312003-SNAPSHOT) requires 'bundle org.springframework.core [3.0.4.RELEASE,3.1.0)').

Would be nice to have the latest STS running with the latest Virgo IDE snapshot Wink
Re: Virgo Server Tooling on STS 2.9.0.M1 works! [message #777579 is a reply to message #774886] Tue, 10 January 2012 18:46 Go to previous messageGo to next message
john smith is currently offline john smithFriend
Messages: 4
Registered: January 2012
Junior Member
Yup, I also got the same error message. Dont know how Jochen got it working.
Re: Virgo Server Tooling on STS 2.9.0.M1 works! [message #778259 is a reply to message #777579] Thu, 12 January 2012 02:27 Go to previous messageGo to next message
Leo Dos Santos is currently offline Leo Dos SantosFriend
Messages: 26
Registered: July 2009
Junior Member
Virgo IDE doesn't have any dependencies on STS, but if you install the latest versions of STS and Spring IDE you'll also get Spring Framework 3.1. Right now Virgo IDE doesn't like Spring Framework 3.1.

The good new is that Virgo IDE is going to be decoupled from Spring IDE soon*, and once that's done we can look into loosening the Spring Framework version constraints on Virgo IDE so that these kinds of installation road bumps are less common.

Leo Dos Santos
- STS committer
Re: Virgo Server Tooling on STS 2.9.0.M1 works! [message #779986 is a reply to message #774886] Tue, 17 January 2012 00:05 Go to previous messageGo to next message
Jochen Szostek is currently offline Jochen SzostekFriend
Messages: 24
Registered: January 2011
Location: Maasmechelen
Junior Member

Frieder Heugel wrote on Wed, 04 January 2012 16:07
Hi Jochen

Did you do something special to get Virgo IDE running in STS 2.9.0M1? I downloaded the latest STS milestone and tried to install the Virgo Tools from the snapshot update site but it still complains about the Spring version (org.eclipse.virgo.ide.manifest.core 1.0.0.201110312003-SNAPSHOT) requires 'bundle org.springframework.core [3.0.4.RELEASE,3.1.0)').

Would be nice to have the latest STS running with the latest Virgo IDE snapshot Wink


I just downloaded STS2.9.0M1 and added the snapshot update site http://download.eclipse.org/virgo/snapshot/IDE (on Windows 7)

On my ubuntu 10.10 I had some issues too but they got resolved after uninstalling some other DM Server / Virgo related packages I had previously installed.

Hope that helps!

Jochen
Re: Virgo Server Tooling on STS 2.9.0.M1 works! [message #792838 is a reply to message #779986] Tue, 07 February 2012 13:29 Go to previous messageGo to next message
Jochen Szostek is currently offline Jochen SzostekFriend
Messages: 24
Registered: January 2011
Location: Maasmechelen
Junior Member

The current virgo server adapter install via http://download.eclipse.org/virgo/snapshot/IDE in the latest STS seems to fail due to missing dependencies on
org.springframework.core_3.0.5.RELEASE.jar
org.springframework.beans_3.0.5.RELEASE.jar
org.springframework.asm_3.0.5.RELEASE.jar

I added them to my dropins folder and then I was able to update my STS with the server adapter.
So the comments at http://wiki.eclipse.org/index.php?title=Virgo/Tooling are outdated.

Should I update the page with this info? What about the missing dependencies? Could be easy for the users to offer them for download.

Greets
Re: Virgo Server Tooling on STS 2.9.0.M1 works! [message #797267 is a reply to message #774689] Mon, 13 February 2012 08:55 Go to previous messageGo to next message
Jochen Szostek is currently offline Jochen SzostekFriend
Messages: 24
Registered: January 2011
Location: Maasmechelen
Junior Member

STS 2.9.0 M2 currently works with the virgo tooling snapshot update site without the need for adding the previously mentioned jars. It does have a dependency on Eclipse Libra, therefore you'd have to add the Libra update site too. (see http://eclipse.org/libra/download/)

Updated the tooling wiki too to reflect this: http://wiki.eclipse.org/Virgo/Tooling
Re: Virgo Server Tooling on STS 2.9.0.M1 works! [message #797816 is a reply to message #797267] Mon, 13 February 2012 23:02 Go to previous message
Leo Dos Santos is currently offline Leo Dos SantosFriend
Messages: 26
Registered: July 2009
Junior Member
Indeed. Our snapshot builds are uploading to the update site once again, and we've taken steps to loosen the coupling on Spring Framework so that you're free to use 3.0 or 3.1. That means that STS 2.9 will work with the Virgo tools now. Miles Parker and I will continue to make changes in the coming weeks so that STS/Spring IDE won't be a requirement for Virgo tools.
Previous Topic:spring dm test startup failes
Next Topic:greenpages 2.5.0 on Virgo 3.1.0 org.h2.Driver ClassNotFoundException
Goto Forum:
  


Current Time: Sat Dec 20 13:52:29 GMT 2014

Powered by FUDForum. Page generated in 0.05012 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software