Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » TPTP Test Results with "no verdict" while Total test performed reported
TPTP Test Results with "no verdict" while Total test performed reported [message #88639] Fri, 24 November 2006 04:26 Go to next message
Eclipse UserFriend
Originally posted by: jaikumar.sharma.barco.com

Hi,

I have stumbled in TPTP test reports, in which total tests peformed are
reported but there is no verdict reported either -- pass / fail / error.
I have same report as shown under comment#19 in the following URL in which
Total tests on the top of the report are reported but no verdict (pass /
fail / error)
https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&a mp;id=144045

I am platform includes the followings for the TPTP and BIRT :

birt-report-framework-sdk-2.1.1
TPTP-SDK-4.2.1
GEF-ALL-3.2
emf-sdo-xsd-SDK-2.2.1

Awaiting your response!

Thanks!

Regards, Jaikumar
Re: TPTP Test Results with "no verdict" while Total test performed reported [message #89150 is a reply to message #88639] Thu, 30 November 2006 15:40 Go to previous messageGo to next message
Liz Dancy is currently offline Liz DancyFriend
Messages: 77
Registered: July 2009
Member
Could you provide more information on when you are seeing the reports with
no verdict? A screen capture of the Test Log View or a test log file would
be very helpful in narrowing down what is causing this.

Sincerely,

Liz Dancy


"Sharma, Jaikumar" <jaikumar.sharma@barco.com> wrote in message
news:ek5s98$9c2$1@utils.eclipse.org...
> Hi,
>
> I have stumbled in TPTP test reports, in which total tests peformed are
> reported but there is no verdict reported either -- pass / fail / error.
> I have same report as shown under comment#19 in the following URL in which
> Total tests on the top of the report are reported but no verdict (pass /
> fail / error)
> https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&a mp;id=144045
>
> I am platform includes the followings for the TPTP and BIRT :
>
> birt-report-framework-sdk-2.1.1
> TPTP-SDK-4.2.1
> GEF-ALL-3.2
> emf-sdo-xsd-SDK-2.2.1
>
> Awaiting your response!
>
> Thanks!
>
> Regards, Jaikumar
>
>
>
Re: TPTP Test Results with "no verdict" while Total test performed reported [message #89165 is a reply to message #89150] Fri, 01 December 2006 04:10 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jaikumar.sharma.barco.com

Hi Liz,
Thanks for your response. Actually I execute JUnit tests headless using
TPTP, when I execute JUnit tests in Eclipse UI, I always get 100 percent
pass result, but when I try to execute the testsuite headless then at times
(randomly) I get the Test Execution History report like (which is attached)
in which Total test are reported, but no verdict appears -- either it is
pass or fail or error .. etc.

Regards,
Jaikumar

"Liz Dancy" <lizdancy@ca.ibm.com> wrote in message
news:ekmu38$j56$1@utils.eclipse.org...
>
> Could you provide more information on when you are seeing the reports with
> no verdict? A screen capture of the Test Log View or a test log file would
> be very helpful in narrowing down what is causing this.
>
> Sincerely,
>
> Liz Dancy
>
>
> "Sharma, Jaikumar" <jaikumar.sharma@barco.com> wrote in message
> news:ek5s98$9c2$1@utils.eclipse.org...
>> Hi,
>>
>> I have stumbled in TPTP test reports, in which total tests peformed are
>> reported but there is no verdict reported either -- pass / fail / error.
>> I have same report as shown under comment#19 in the following URL in
>> which
>> Total tests on the top of the report are reported but no verdict (pass /
>> fail / error)
>> https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&a mp;id=144045
>>
>> I am platform includes the followings for the TPTP and BIRT :
>>
>> birt-report-framework-sdk-2.1.1
>> TPTP-SDK-4.2.1
>> GEF-ALL-3.2
>> emf-sdo-xsd-SDK-2.2.1
>>
>> Awaiting your response!
>>
>> Thanks!
>>
>> Regards, Jaikumar
>>
>>
>>
>
>


Re: TPTP Test Results with "no verdict" while Total test performed reported [message #89446 is a reply to message #89165] Tue, 05 December 2006 21:17 Go to previous messageGo to next message
Sheldon Lee-Loy is currently offline Sheldon Lee-LoyFriend
Messages: 48
Registered: July 2009
Member
Hi Jaikumar,

Do you know if the test execution histories contain the correct
verdict? I want to know if this is the problem with the report or the
execution histories are not recording the correct verdict.

Does your junit test reference other junit tests?

Thanks,

Sheldon.

On Fri, 1 Dec 2006 09:40:50 +0530, "Sharma, Jaikumar"
<jaikumar.sharma@barco.com> wrote:

>Hi Liz,
>Thanks for your response. Actually I execute JUnit tests headless using
>TPTP, when I execute JUnit tests in Eclipse UI, I always get 100 percent
>pass result, but when I try to execute the testsuite headless then at times
>(randomly) I get the Test Execution History report like (which is attached)
>in which Total test are reported, but no verdict appears -- either it is
>pass or fail or error .. etc.
>
>Regards,
>Jaikumar
>
>"Liz Dancy" <lizdancy@ca.ibm.com> wrote in message
>news:ekmu38$j56$1@utils.eclipse.org...
>>
>> Could you provide more information on when you are seeing the reports with
>> no verdict? A screen capture of the Test Log View or a test log file would
>> be very helpful in narrowing down what is causing this.
>>
>> Sincerely,
>>
>> Liz Dancy
>>
>>
>> "Sharma, Jaikumar" <jaikumar.sharma@barco.com> wrote in message
>> news:ek5s98$9c2$1@utils.eclipse.org...
>>> Hi,
>>>
>>> I have stumbled in TPTP test reports, in which total tests peformed are
>>> reported but there is no verdict reported either -- pass / fail / error.
>>> I have same report as shown under comment#19 in the following URL in
>>> which
>>> Total tests on the top of the report are reported but no verdict (pass /
>>> fail / error)
>>> https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&a mp;id=144045
>>>
>>> I am platform includes the followings for the TPTP and BIRT :
>>>
>>> birt-report-framework-sdk-2.1.1
>>> TPTP-SDK-4.2.1
>>> GEF-ALL-3.2
>>> emf-sdo-xsd-SDK-2.2.1
>>>
>>> Awaiting your response!
>>>
>>> Thanks!
>>>
>>> Regards, Jaikumar
>>>
>>>
>>>
>>
>>
>
Re: TPTP Test Results with "no verdict" while Total test performed reported [message #89462 is a reply to message #89446] Wed, 06 December 2006 04:10 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: jaikumar.sharma.barco.com

Hi Sheldon,

Thanks for respone!

I think execution history does not contain correct verdict. I can see the
following contents in the file -- ResourceContents inside
LoggerTest.execution as as a result of running LoggerTest.testsute.
____________________________________________________________ ____________________________________________________________
<?xml version="1.0" encoding="UTF-8"?>
<Common_Testprofile:TPFExecutionResult xmi:version="2.0"
xmlns:xmi="http://www.omg.org/XMI"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:Common_Testprofile="http://www.eclipse.org/hyades/models/common/testprofile.xmi"
id="F783B9E0EA62B0BFE2A28BB0837411DB" name="LoggerTest"
type="org.eclipse.hyades.test.java.junit.testSuite">
<executionHistory>
<executionEvents xsi:type="Common_Testprofile:TPFMessageEvent"
timestamp="1165376663689"
text="System.out:&#xA;log4j.properties&#xD;&#xA; "/>
</executionHistory>
<test xsi:type="Common_Testprofile:TPFTestSuite"
href=" src/com/barco/cmstest/foundation/logging/LoggerTest.testsuit e#F783B9E0EA62B0BFE2A28BB0837411DB "/>
</Common_Testprofile:TPFExecutionResult>
____________________________________________________________ ____________________________________________________________ __

My JUnit test does not refer to other JUnit tests. Kindly let me know, in
case you need further info.

Regards,
Jaikumar


<sleeloy@ca.ibm.com> wrote in message
news:qbobn29ct25cc3ppisqcvuf5vr2gfremt2@4ax.com...
> Hi Jaikumar,
>
> Do you know if the test execution histories contain the correct
> verdict? I want to know if this is the problem with the report or the
> execution histories are not recording the correct verdict.
>
> Does your junit test reference other junit tests?
>
> Thanks,
>
> Sheldon.
>
> On Fri, 1 Dec 2006 09:40:50 +0530, "Sharma, Jaikumar"
> <jaikumar.sharma@barco.com> wrote:
>
>>Hi Liz,
>>Thanks for your response. Actually I execute JUnit tests headless using
>>TPTP, when I execute JUnit tests in Eclipse UI, I always get 100 percent
>>pass result, but when I try to execute the testsuite headless then at
>>times
>>(randomly) I get the Test Execution History report like (which is
>>attached)
>>in which Total test are reported, but no verdict appears -- either it is
>>pass or fail or error .. etc.
>>
>>Regards,
>>Jaikumar
>>
>>"Liz Dancy" <lizdancy@ca.ibm.com> wrote in message
>>news:ekmu38$j56$1@utils.eclipse.org...
>>>
>>> Could you provide more information on when you are seeing the reports
>>> with
>>> no verdict? A screen capture of the Test Log View or a test log file
>>> would
>>> be very helpful in narrowing down what is causing this.
>>>
>>> Sincerely,
>>>
>>> Liz Dancy
>>>
>>>
>>> "Sharma, Jaikumar" <jaikumar.sharma@barco.com> wrote in message
>>> news:ek5s98$9c2$1@utils.eclipse.org...
>>>> Hi,
>>>>
>>>> I have stumbled in TPTP test reports, in which total tests peformed are
>>>> reported but there is no verdict reported either -- pass / fail /
>>>> error.
>>>> I have same report as shown under comment#19 in the following URL in
>>>> which
>>>> Total tests on the top of the report are reported but no verdict (pass
>>>> /
>>>> fail / error)
>>>> https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&a mp;id=144045
>>>>
>>>> I am platform includes the followings for the TPTP and BIRT :
>>>>
>>>> birt-report-framework-sdk-2.1.1
>>>> TPTP-SDK-4.2.1
>>>> GEF-ALL-3.2
>>>> emf-sdo-xsd-SDK-2.2.1
>>>>
>>>> Awaiting your response!
>>>>
>>>> Thanks!
>>>>
>>>> Regards, Jaikumar
>>>>
>>>>
>>>>
>>>
>>>
>>
Re: TPTP Test Results with "no verdict" while Total test performed reported [message #89549 is a reply to message #89462] Wed, 06 December 2006 19:28 Go to previous messageGo to next message
Sheldon Lee-Loy is currently offline Sheldon Lee-LoyFriend
Messages: 48
Registered: July 2009
Member
Would it be possible to email me the .execution file and .testsuite
file to me directly.

Also are you running the testsuite within an eclipse environment or
via an ant script.

email: sleeloy@ca.ibm.com
Thanks,

Sheldon.

On Wed, 6 Dec 2006 09:40:47 +0530, "Sharma, Jaikumar"
<jaikumar.sharma@barco.com> wrote:

>Hi Sheldon,
>
>Thanks for respone!
>
>I think execution history does not contain correct verdict. I can see the
>following contents in the file -- ResourceContents inside
>LoggerTest.execution as as a result of running LoggerTest.testsute.
> ____________________________________________________________ ____________________________________________________________
><?xml version="1.0" encoding="UTF-8"?>
><Common_Testprofile:TPFExecutionResult xmi:version="2.0"
>xmlns:xmi="http://www.omg.org/XMI"
>xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>xmlns:Common_Testprofile="http://www.eclipse.org/hyades/models/common/testprofile.xmi"
>id="F783B9E0EA62B0BFE2A28BB0837411DB" name="LoggerTest"
>type="org.eclipse.hyades.test.java.junit.testSuite">
> <executionHistory>
> <executionEvents xsi:type="Common_Testprofile:TPFMessageEvent"
>timestamp="1165376663689"
>text="System.out:&#xA;log4j.properties&#xD;&#xA; "/>
> </executionHistory>
> <test xsi:type="Common_Testprofile:TPFTestSuite"
>href=" src/com/barco/cmstest/foundation/logging/LoggerTest.testsuit e#F783B9E0EA62B0BFE2A28BB0837411DB "/>
></Common_Testprofile:TPFExecutionResult>
> ____________________________________________________________ ____________________________________________________________ __
>
>My JUnit test does not refer to other JUnit tests. Kindly let me know, in
>case you need further info.
>
>Regards,
>Jaikumar
>
>
><sleeloy@ca.ibm.com> wrote in message
>news:qbobn29ct25cc3ppisqcvuf5vr2gfremt2@4ax.com...
>> Hi Jaikumar,
>>
>> Do you know if the test execution histories contain the correct
>> verdict? I want to know if this is the problem with the report or the
>> execution histories are not recording the correct verdict.
>>
>> Does your junit test reference other junit tests?
>>
>> Thanks,
>>
>> Sheldon.
>>
>> On Fri, 1 Dec 2006 09:40:50 +0530, "Sharma, Jaikumar"
>> <jaikumar.sharma@barco.com> wrote:
>>
>>>Hi Liz,
>>>Thanks for your response. Actually I execute JUnit tests headless using
>>>TPTP, when I execute JUnit tests in Eclipse UI, I always get 100 percent
>>>pass result, but when I try to execute the testsuite headless then at
>>>times
>>>(randomly) I get the Test Execution History report like (which is
>>>attached)
>>>in which Total test are reported, but no verdict appears -- either it is
>>>pass or fail or error .. etc.
>>>
>>>Regards,
>>>Jaikumar
>>>
>>>"Liz Dancy" <lizdancy@ca.ibm.com> wrote in message
>>>news:ekmu38$j56$1@utils.eclipse.org...
>>>>
>>>> Could you provide more information on when you are seeing the reports
>>>> with
>>>> no verdict? A screen capture of the Test Log View or a test log file
>>>> would
>>>> be very helpful in narrowing down what is causing this.
>>>>
>>>> Sincerely,
>>>>
>>>> Liz Dancy
>>>>
>>>>
>>>> "Sharma, Jaikumar" <jaikumar.sharma@barco.com> wrote in message
>>>> news:ek5s98$9c2$1@utils.eclipse.org...
>>>>> Hi,
>>>>>
>>>>> I have stumbled in TPTP test reports, in which total tests peformed are
>>>>> reported but there is no verdict reported either -- pass / fail /
>>>>> error.
>>>>> I have same report as shown under comment#19 in the following URL in
>>>>> which
>>>>> Total tests on the top of the report are reported but no verdict (pass
>>>>> /
>>>>> fail / error)
>>>>> https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&a mp;id=144045
>>>>>
>>>>> I am platform includes the followings for the TPTP and BIRT :
>>>>>
>>>>> birt-report-framework-sdk-2.1.1
>>>>> TPTP-SDK-4.2.1
>>>>> GEF-ALL-3.2
>>>>> emf-sdo-xsd-SDK-2.2.1
>>>>>
>>>>> Awaiting your response!
>>>>>
>>>>> Thanks!
>>>>>
>>>>> Regards, Jaikumar
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>
>
Re: TPTP Test Results with "no verdict" while Total test performed reported [message #89862 is a reply to message #89549] Mon, 11 December 2006 03:24 Go to previous message
Eclipse UserFriend
Originally posted by: jaikumar.sharma.barco.com

Hi Sheldon,

Were you able to pinpoint the problem. I had sent you both (.execution and
..testsuite) files, you had asked for.

Regards, Jaikumar

<sleeloy@ca.ibm.com> wrote in message
news:kc6en2dd97evqjvublsng9eodlcnq262ob@4ax.com...
> Would it be possible to email me the .execution file and .testsuite
> file to me directly.
>
> Also are you running the testsuite within an eclipse environment or
> via an ant script.
>
> email: sleeloy@ca.ibm.com
> Thanks,
>
> Sheldon.
>
> On Wed, 6 Dec 2006 09:40:47 +0530, "Sharma, Jaikumar"
> <jaikumar.sharma@barco.com> wrote:
>
>>Hi Sheldon,
>>
>>Thanks for respone!
>>
>>I think execution history does not contain correct verdict. I can see the
>>following contents in the file -- ResourceContents inside
>>LoggerTest.execution as as a result of running LoggerTest.testsute.
>> ____________________________________________________________ ____________________________________________________________
>><?xml version="1.0" encoding="UTF-8"?>
>><Common_Testprofile:TPFExecutionResult xmi:version="2.0"
>>xmlns:xmi="http://www.omg.org/XMI"
>>xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>xmlns:Common_Testprofile="http://www.eclipse.org/hyades/models/common/testprofile.xmi"
>>id="F783B9E0EA62B0BFE2A28BB0837411DB" name="LoggerTest"
>>type="org.eclipse.hyades.test.java.junit.testSuite">
>> <executionHistory>
>> <executionEvents xsi:type="Common_Testprofile:TPFMessageEvent"
>>timestamp="1165376663689"
>>text="System.out:&#xA;log4j.properties&#xD;&#xA; "/>
>> </executionHistory>
>> <test xsi:type="Common_Testprofile:TPFTestSuite"
>>href=" src/com/barco/cmstest/foundation/logging/LoggerTest.testsuit e#F783B9E0EA62B0BFE2A28BB0837411DB "/>
>></Common_Testprofile:TPFExecutionResult>
>> ____________________________________________________________ ____________________________________________________________ __
>>
>>My JUnit test does not refer to other JUnit tests. Kindly let me know, in
>>case you need further info.
>>
>>Regards,
>>Jaikumar
>>
>>
>><sleeloy@ca.ibm.com> wrote in message
>>news:qbobn29ct25cc3ppisqcvuf5vr2gfremt2@4ax.com...
>>> Hi Jaikumar,
>>>
>>> Do you know if the test execution histories contain the correct
>>> verdict? I want to know if this is the problem with the report or the
>>> execution histories are not recording the correct verdict.
>>>
>>> Does your junit test reference other junit tests?
>>>
>>> Thanks,
>>>
>>> Sheldon.
>>>
>>> On Fri, 1 Dec 2006 09:40:50 +0530, "Sharma, Jaikumar"
>>> <jaikumar.sharma@barco.com> wrote:
>>>
>>>>Hi Liz,
>>>>Thanks for your response. Actually I execute JUnit tests headless using
>>>>TPTP, when I execute JUnit tests in Eclipse UI, I always get 100 percent
>>>>pass result, but when I try to execute the testsuite headless then at
>>>>times
>>>>(randomly) I get the Test Execution History report like (which is
>>>>attached)
>>>>in which Total test are reported, but no verdict appears -- either it is
>>>>pass or fail or error .. etc.
>>>>
>>>>Regards,
>>>>Jaikumar
>>>>
>>>>"Liz Dancy" <lizdancy@ca.ibm.com> wrote in message
>>>>news:ekmu38$j56$1@utils.eclipse.org...
>>>>>
>>>>> Could you provide more information on when you are seeing the reports
>>>>> with
>>>>> no verdict? A screen capture of the Test Log View or a test log file
>>>>> would
>>>>> be very helpful in narrowing down what is causing this.
>>>>>
>>>>> Sincerely,
>>>>>
>>>>> Liz Dancy
>>>>>
>>>>>
>>>>> "Sharma, Jaikumar" <jaikumar.sharma@barco.com> wrote in message
>>>>> news:ek5s98$9c2$1@utils.eclipse.org...
>>>>>> Hi,
>>>>>>
>>>>>> I have stumbled in TPTP test reports, in which total tests peformed
>>>>>> are
>>>>>> reported but there is no verdict reported either -- pass / fail /
>>>>>> error.
>>>>>> I have same report as shown under comment#19 in the following URL in
>>>>>> which
>>>>>> Total tests on the top of the report are reported but no verdict
>>>>>> (pass
>>>>>> /
>>>>>> fail / error)
>>>>>> https://bugs.eclipse.org/bugs/show_bug.cgi?format=multiple&a mp;id=144045
>>>>>>
>>>>>> I am platform includes the followings for the TPTP and BIRT :
>>>>>>
>>>>>> birt-report-framework-sdk-2.1.1
>>>>>> TPTP-SDK-4.2.1
>>>>>> GEF-ALL-3.2
>>>>>> emf-sdo-xsd-SDK-2.2.1
>>>>>>
>>>>>> Awaiting your response!
>>>>>>
>>>>>> Thanks!
>>>>>>
>>>>>> Regards, Jaikumar
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>
Previous Topic:Using GUI Recorder to Test Plug-ins?
Next Topic:Duplicate meta object ID's after code generation
Goto Forum:
  


Current Time: Sat Nov 22 03:07:11 GMT 2014

Powered by FUDForum. Page generated in 0.02041 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software