Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » Using the Value "*" in Data Sets isn't possible(In the AUT it changes to ")")
Using the Value "*" in Data Sets isn't possible [message #774187] Tue, 03 January 2012 13:08 Go to next message
Maria Schubert is currently offline Maria SchubertFriend
Messages: 2
Registered: January 2012
Junior Member
Hi,

I'm new with Jubula and just running into a little Problem I find no solution for:

In my Testcase for our RCP-Application I use "<ub_cti_replace_Text>[TEXT]" with the Parameter Values:

Parameter Name: TEXT,
Parameter Type: String,
Parameter Value: =MYVAR

In "Data Sets" of the Test Case I enter "*" for MYVAR.
(The application I want to test is a GUI for searching something...and I want to search with wildcards)

When I start the Test, it works as it should, but it enteres "(" in the Textfield instead of "*".

Can you help me with this problem? Thanks in advance!


Re: Using the Value "*" in Data Sets isn't possible [message #774192 is a reply to message #774187] Tue, 03 January 2012 13:27 Go to previous messageGo to next message
Achim Loerke is currently offline Achim LoerkeFriend
Messages: 355
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

For RCP/SWT you have to specify a keyboard layout (which matches your test environment) in the AUT config dialog.

- Achim
Re: Using the Value "*" in Data Sets isn't possible [message #774194 is a reply to message #774192] Tue, 03 January 2012 13:34 Go to previous messageGo to next message
Maria Schubert is currently offline Maria SchubertFriend
Messages: 2
Registered: January 2012
Junior Member
Thank you for the fast help! That really solved the problem... Smile
Re: Using the Value "*" in Data Sets isn't possible [message #776922 is a reply to message #774187] Mon, 09 January 2012 14:43 Go to previous message
fan Missing name is currently offline fan Missing nameFriend
Messages: 7
Registered: June 2011
Junior Member
No Message Body

[Updated on: Mon, 09 January 2012 15:53]

Report message to a moderator

Previous Topic:conditionial testing
Next Topic:Jubula + IE9
Goto Forum:
  


Current Time: Thu Nov 27 03:15:02 GMT 2014

Powered by FUDForum. Page generated in 0.02165 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software