Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Epsilon » [Eugenia] Custom Icons for Tools
[Eugenia] Custom Icons for Tools [message #772748] Fri, 30 December 2011 08:39 Go to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 15
Registered: December 2011
Junior Member
Hi again,

first, i want to ask a simple question for better understanding.
In the Eugenia GMF Tutorial (http://eclipse.org/gmt/epsilon/doc/articles/eugenia-gmf-tutorial/) there is a Metamodel and a Screenshot from the generated Editor.

But: i don't think that one get the editor shown using the given metamodel because it has custom icons for the tools. This isn't described in the Metamodel. Am i right?

What i am trying to do is right that. I have nodes with user defined images and set the icons for the tools. Here is one example:

@gmf.node(figure="figures.MailFigure",
label.icon="false", label.placement="none",
tool.name="EMail versenden",
tool.small.bundle="erc.eugenia", tool.small.path="icons/Mail16.png",
tool.large.bundle="erc.eugenia", tool.large.path="icons/Mail32.png")
class MailAction extends Action{
}

The images for the nodes are in another Project holding all the xyFigure.java-Code (like the Friends-Example)
The Images for the Tools are in an icons folder beside my model.

The generated editor looks fine. I can see the nodes as images and the custom icons in the palette. But i can't see them in the toolbar. Why? Do i manually have to copy them to the generated .diagram-Project?

Thanks in Advance.

Cheers,
Wolly

Re: [Eugenia] Custom Icons for Tools [message #774604 is a reply to message #772748] Wed, 04 January 2012 04:18 Go to previous messageGo to next message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 795
Registered: July 2009
Senior Member
Hi Wolly,

You'll need to replace the auto-generated icons under xyz.edit/icons/full/obj16 with your custom icons.

Cheers,
Dimitris
Re: [Eugenia] Custom Icons for Tools [message #774617 is a reply to message #774604] Wed, 04 January 2012 04:41 Go to previous messageGo to next message
Missing name Missing name is currently offline Missing name Missing name
Messages: 15
Registered: December 2011
Junior Member
Hi Dimitris,

thanks for reply.

Well, i suppose, i have to do so each time i generate from scratch?!
So it's one thing more which i wish to be automated.

What i did:
Copy my custom icons to the told folder in a resolution of 16x16 and rename it accordingly.

And it worked! But the File-Extension has to be .gif (and it doesn't matters if it's in fact a png). I've had png as File-Extension in the first try and saw nothing.

My fault was that i thought my custom icons would be copied "by magic" into the right folder in the xxx.edit-Project Wink

Cheers,
Wolly


Re: [Eugenia] Custom Icons for Tools [message #774625 is a reply to message #774617] Wed, 04 January 2012 04:59 Go to previous message
Dimitris Kolovos is currently offline Dimitris Kolovos
Messages: 795
Registered: July 2009
Senior Member
Hi Wolly,

If you regenerate the icons won't be replaced so I don't think that should be a problem.

Cheers,
Dimitris
Previous Topic:[Eugenia] Can't draw link in generated editor.
Next Topic:EGL 101
Goto Forum:
  


Current Time: Mon Jul 28 10:38:06 EDT 2014

Powered by FUDForum. Page generated in 0.03724 seconds