Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » [AGR] Disablement of test macros in suite editor's Behavior tab
[AGR] Disablement of test macros in suite editor's Behavior tab [message #88185] Tue, 21 November 2006 15:05 Go to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-SchwartzFriend
Messages: 448
Registered: July 2009
Senior Member
Hello everybody.

In the Behavior tab of a test suite I have a sequence of macros listed.
I want to exclude one temporarily from the sequence and therefore I
disable it using the Disable/Enable button to the right of the list, but
the macro is still being ran. Why is that? Am I misunderstanding the
purpose of the Disable/Enable button?

TIA
B.
Re: [AGR] Disablement of test macros in suite editor's Behavior tab [message #88325 is a reply to message #88185] Tue, 21 November 2006 18:56 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 404
Registered: July 2009
Senior Member
The disable/enable button is only applicable when the test suite is launched
in standard mode. It seems to be working fine in TPTP4.2.1.
Are you experiencing this with newly created test suites or existing test
suites?


"Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
news:ejv4jl$q8f$1@utils.eclipse.org...
> Hello everybody.
>
> In the Behavior tab of a test suite I have a sequence of macros listed. I
> want to exclude one temporarily from the sequence and therefore I disable
> it using the Disable/Enable button to the right of the list, but the macro
> is still being ran. Why is that? Am I misunderstanding the purpose of the
> Disable/Enable button?
>
> TIA
> B.
Re: [AGR] Disablement of test macros in suite editor's Behavior tab [message #88414 is a reply to message #88325] Wed, 22 November 2006 15:15 Go to previous messageGo to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-SchwartzFriend
Messages: 448
Registered: July 2009
Senior Member
Ali Mehregani wrote:
> The disable/enable button is only applicable when the test suite is launched
> in standard mode. It seems to be working fine in TPTP4.2.1.
> Are you experiencing this with newly created test suites or existing test
> suites?
>
>
> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
> news:ejv4jl$q8f$1@utils.eclipse.org...
>> Hello everybody.
>>
>> In the Behavior tab of a test suite I have a sequence of macros listed. I
>> want to exclude one temporarily from the sequence and therefore I disable
>> it using the Disable/Enable button to the right of the list, but the macro
>> is still being ran. Why is that? Am I misunderstanding the purpose of the
>> Disable/Enable button?
>>
>> TIA
>> B.
>
>
Hi Ali.

Thanks for your reply.

Yes, I am launching the suite in standard mode, under TPTP4.2.1 and
Eclipse 3.2.1 and I have this problem with an existing test suite (I
have not yet tried with a new suite). The test case that I am disabling
does not belong to the same suite, but is defined elsewhere and invoked
in this suite.

Thanks,
B.
Re: [AGR] Disablement of test macros in suite editor's Behavior tab [message #88596 is a reply to message #88414] Thu, 23 November 2006 15:42 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 404
Registered: July 2009
Senior Member
I can't reproduce this problem with newly created test suites.
I even tried disabling test invocations that belong to other test suites.

"Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
news:ek1pil$8rv$1@utils.eclipse.org...
> Ali Mehregani wrote:
>> The disable/enable button is only applicable when the test suite is
>> launched in standard mode. It seems to be working fine in TPTP4.2.1.
>> Are you experiencing this with newly created test suites or existing test
>> suites?
>>
>>
>> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in
>> message news:ejv4jl$q8f$1@utils.eclipse.org...
>>> Hello everybody.
>>>
>>> In the Behavior tab of a test suite I have a sequence of macros listed.
>>> I want to exclude one temporarily from the sequence and therefore I
>>> disable it using the Disable/Enable button to the right of the list, but
>>> the macro is still being ran. Why is that? Am I misunderstanding the
>>> purpose of the Disable/Enable button?
>>>
>>> TIA
>>> B.
>>
>>
> Hi Ali.
>
> Thanks for your reply.
>
> Yes, I am launching the suite in standard mode, under TPTP4.2.1 and
> Eclipse 3.2.1 and I have this problem with an existing test suite (I have
> not yet tried with a new suite). The test case that I am disabling does
> not belong to the same suite, but is defined elsewhere and invoked in this
> suite.
>
> Thanks,
> B.
Re: [AGR] Disablement of test macros in suite editor's Behavior tab [message #88669 is a reply to message #88596] Fri, 24 November 2006 08:37 Go to previous messageGo to next message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-SchwartzFriend
Messages: 448
Registered: July 2009
Senior Member
So does this mean that I cannot use the feature with pre existing test
suites? Or is it a bug that I should enter in Bugzilla?

Thanks,
B.

Ali Mehregani wrote:
> I can't reproduce this problem with newly created test suites.
> I even tried disabling test invocations that belong to other test suites.
>
> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
> news:ek1pil$8rv$1@utils.eclipse.org...
>> Ali Mehregani wrote:
>>> The disable/enable button is only applicable when the test suite is
>>> launched in standard mode. It seems to be working fine in TPTP4.2.1.
>>> Are you experiencing this with newly created test suites or existing test
>>> suites?
>>>
>>>
>>> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in
>>> message news:ejv4jl$q8f$1@utils.eclipse.org...
>>>> Hello everybody.
>>>>
>>>> In the Behavior tab of a test suite I have a sequence of macros listed.
>>>> I want to exclude one temporarily from the sequence and therefore I
>>>> disable it using the Disable/Enable button to the right of the list, but
>>>> the macro is still being ran. Why is that? Am I misunderstanding the
>>>> purpose of the Disable/Enable button?
>>>>
>>>> TIA
>>>> B.
>>>
>> Hi Ali.
>>
>> Thanks for your reply.
>>
>> Yes, I am launching the suite in standard mode, under TPTP4.2.1 and
>> Eclipse 3.2.1 and I have this problem with an existing test suite (I have
>> not yet tried with a new suite). The test case that I am disabling does
>> not belong to the same suite, but is defined elsewhere and invoked in this
>> suite.
>>
>> Thanks,
>> B.
>
>
Re: [AGR] Disablement of test macros in suite editor's Behavior tab [message #88762 is a reply to message #88669] Mon, 27 November 2006 14:59 Go to previous messageGo to next message
No real name is currently offline No real nameFriend
Messages: 404
Registered: July 2009
Senior Member
If you can verify that the option works for newly created test suites and it
doesn't function for pre-existing test suites, then it is a defect.


"Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
news:ek6b00$u42$1@utils.eclipse.org...
> So does this mean that I cannot use the feature with pre existing test
> suites? Or is it a bug that I should enter in Bugzilla?
>
> Thanks,
> B.
>
> Ali Mehregani wrote:
>> I can't reproduce this problem with newly created test suites.
>> I even tried disabling test invocations that belong to other test suites.
>>
>> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in
>> message news:ek1pil$8rv$1@utils.eclipse.org...
>>> Ali Mehregani wrote:
>>>> The disable/enable button is only applicable when the test suite is
>>>> launched in standard mode. It seems to be working fine in TPTP4.2.1.
>>>> Are you experiencing this with newly created test suites or existing
>>>> test suites?
>>>>
>>>>
>>>> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in
>>>> message news:ejv4jl$q8f$1@utils.eclipse.org...
>>>>> Hello everybody.
>>>>>
>>>>> In the Behavior tab of a test suite I have a sequence of macros
>>>>> listed. I want to exclude one temporarily from the sequence and
>>>>> therefore I disable it using the Disable/Enable button to the right of
>>>>> the list, but the macro is still being ran. Why is that? Am I
>>>>> misunderstanding the purpose of the Disable/Enable button?
>>>>>
>>>>> TIA
>>>>> B.
>>>>
>>> Hi Ali.
>>>
>>> Thanks for your reply.
>>>
>>> Yes, I am launching the suite in standard mode, under TPTP4.2.1 and
>>> Eclipse 3.2.1 and I have this problem with an existing test suite (I
>>> have not yet tried with a new suite). The test case that I am disabling
>>> does not belong to the same suite, but is defined elsewhere and invoked
>>> in this suite.
>>>
>>> Thanks,
>>> B.
>>
Re: [AGR] Disablement of test macros in suite editor's Behavior tab [message #89041 is a reply to message #88762] Wed, 29 November 2006 12:39 Go to previous message
Barbara Rosi-Schwartz is currently offline Barbara Rosi-SchwartzFriend
Messages: 448
Registered: July 2009
Senior Member
No, I cannot get it to work either with old or with newly recorded test
suites. Adn still I cannot understand what I am doing wrong... :-(

Regards,
B.

Ali Mehregani wrote:
> If you can verify that the option works for newly created test suites and it
> doesn't function for pre-existing test suites, then it is a defect.
>
>
> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in message
> news:ek6b00$u42$1@utils.eclipse.org...
>> So does this mean that I cannot use the feature with pre existing test
>> suites? Or is it a bug that I should enter in Bugzilla?
>>
>> Thanks,
>> B.
>>
>> Ali Mehregani wrote:
>>> I can't reproduce this problem with newly created test suites.
>>> I even tried disabling test invocations that belong to other test suites.
>>>
>>> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in
>>> message news:ek1pil$8rv$1@utils.eclipse.org...
>>>> Ali Mehregani wrote:
>>>>> The disable/enable button is only applicable when the test suite is
>>>>> launched in standard mode. It seems to be working fine in TPTP4.2.1.
>>>>> Are you experiencing this with newly created test suites or existing
>>>>> test suites?
>>>>>
>>>>>
>>>>> "Barbara Rosi-Schwartz" <Barbara.Rosi-Schwartz@Etish.org> wrote in
>>>>> message news:ejv4jl$q8f$1@utils.eclipse.org...
>>>>>> Hello everybody.
>>>>>>
>>>>>> In the Behavior tab of a test suite I have a sequence of macros
>>>>>> listed. I want to exclude one temporarily from the sequence and
>>>>>> therefore I disable it using the Disable/Enable button to the right of
>>>>>> the list, but the macro is still being ran. Why is that? Am I
>>>>>> misunderstanding the purpose of the Disable/Enable button?
>>>>>>
>>>>>> TIA
>>>>>> B.
>>>> Hi Ali.
>>>>
>>>> Thanks for your reply.
>>>>
>>>> Yes, I am launching the suite in standard mode, under TPTP4.2.1 and
>>>> Eclipse 3.2.1 and I have this problem with an existing test suite (I
>>>> have not yet tried with a new suite). The test case that I am disabling
>>>> does not belong to the same suite, but is defined elsewhere and invoked
>>>> in this suite.
>>>>
>>>> Thanks,
>>>> B.
>
Previous Topic:No Execution Statistics on stand-alone
Next Topic:libpiAgent.so can not be found
Goto Forum:
  


Current Time: Mon Nov 24 12:43:32 GMT 2014

Powered by FUDForum. Page generated in 0.02764 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software