Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Common Navigator Framework - lazy loading?
Common Navigator Framework - lazy loading? [message #772349] Thu, 29 December 2011 15:12 Go to next message
Michal Borek is currently offline Michal BorekFriend
Messages: 25
Registered: August 2010
Junior Member
Hello,
I'm trying to use Common Navigator Framework in my Project
I used Template "Common Navigator View" from org.eclipse.ui.navigator.viewer and everything would be fine but the navigator is empty (doesn't contain resources) unless i right-click on the view.

Could you help me solving this issue?

Thanks a lot.


Re: Common Navigator Framework - lazy loading? [message #772379 is a reply to message #772349] Thu, 29 December 2011 16:36 Go to previous messageGo to next message
Francis Upton IV is currently offline Francis Upton IVFriend
Messages: 472
Registered: July 2009
Location: Oakland, CA
Senior Member
If you follow these instructions you should be able to get what you need:

http://help.eclipse.org/indigo/topic/org.eclipse.platform.doc.isv/guide/cnf_steps.htm


Re: Common Navigator Framework - lazy loading? [message #772634 is a reply to message #772379] Fri, 30 December 2011 08:58 Go to previous messageGo to next message
Michal Borek is currently offline Michal BorekFriend
Messages: 25
Registered: August 2010
Junior Member
Thanks for your answer.

Francis I followed this instruction and I have the same problem.

I turned on tracing and after application is started, when i right-click on (empty) navigator, then data is initialized (just like it weren't initialized automatically).

Trace output:
Application Started: 44265 <------ AFTER THIS I RIGHT-CLICKED ON NAVIGATOR

Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.OpenActions
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.GotoActions
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.GoIntoActions
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.PortingActions
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.NewActions
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.PropertiesActionProvider
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.WorkManagementActionProvider
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.ResourceMgmtActions
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.UndoRedoActionProvider
Viewer Binding: actionExtension to: org.eclipse.ui.navigator.resources.WorkingSetActions
createContentProvider: Content[org.eclipse.ui.navigator.resourceContent(4) , "Resources"]
...



Just like it was normal that it is initialized lazily...


[Updated on: Fri, 30 December 2011 09:12]

Report message to a moderator

Re: Common Navigator Framework - lazy loading? [message #772694 is a reply to message #772634] Fri, 30 December 2011 11:23 Go to previous messageGo to next message
Michal Borek is currently offline Michal BorekFriend
Messages: 25
Registered: August 2010
Junior Member
After further investigation I found that
CommonNavigator.getInitialInput (which was returning getSite().getPage().getInput()) was returning null (instead of workspace root).

I saw that there is an information that WorkbenchWindowAdvisor should have getDefaultPageInput overridden but it isn't called from workspace.

Any thoughts?


Re: Common Navigator Framework - lazy loading? [message #775320 is a reply to message #772694] Thu, 05 January 2012 19:05 Go to previous messageGo to next message
Francis Upton IV is currently offline Francis Upton IVFriend
Messages: 472
Registered: July 2009
Location: Oakland, CA
Senior Member
Quote:
After further investigation I found that
CommonNavigator.getInitialInput (which was returning getSite().getPage().getInput()) was returning null (instead of workspace root).

I saw that there is an information that WorkbenchWindowAdvisor should have getDefaultPageInput overridden but it isn't called from workspace.


I'm thinking you don't have an RCP application, that instead you are using the CN in a set of plugins that you install into an Eclipse environment? Is that correct? The WorkbenchWindowAdvisor is only used for an RCP application.

If you are not using an RCP application, then you should make a subclass of the CommonNavigator class and override getInitialInput() to point to the workspace root.


Re: Common Navigator Framework - lazy loading? [message #1011521 is a reply to message #775320] Tue, 19 February 2013 17:45 Go to previous messageGo to next message
Craig Foote is currently offline Craig FooteFriend
Messages: 195
Registered: July 2009
Senior Member
We have the same problem; our CNF view is not rendering initially. We are using a launch config that points to our RCP product backed by our application but the WorkbenchWindowAdvisor#getDefaultPageInput is not being called. What could we be doing wrong?

Craig
Re: Common Navigator Framework - lazy loading? [message #1011638 is a reply to message #1011521] Tue, 19 February 2013 23:57 Go to previous message
Craig Foote is currently offline Craig FooteFriend
Messages: 195
Registered: July 2009
Senior Member
Mystery solved. Cleared the workspace and the method was called.
Previous Topic:Available custom swt based widget & components
Next Topic:Add MPart in all MPerspective in eclipse Juno
Goto Forum:
  


Current Time: Sun Dec 21 08:38:25 GMT 2014

Powered by FUDForum. Page generated in 0.01856 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software