Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EPP » EPP Nightly Build. What is "Replacing feature version"?
EPP Nightly Build. What is "Replacing feature version"? [message #7955] Thu, 10 April 2008 10:07 Go to next message
Felix Dorner is currently offline Felix Dorner
Messages: 675
Registered: July 2009
Senior Member
Hey,

I downloaded 20080410-0540_eclipse-modeling-ganymede-M6-linux.gtk.x86.tar .gz
from the EPP Nighly build site. As the page says, the nighly builds
are made from the Ganymede Staging Update Site.

Surprisingly the zip includes:

Eclipse Modeling Framework (EMF)
Version: 2.4.0.v200802090050
Build id: 200802090050


This confuses me, I thought It'd contain the M6 Packages, as these are already available at the
Staging Update site. In the build log, these lines are suspicious:

!ENTRY org.eclipse.update.core 4 0 2008-04-10 02:37:27.748
!MESSAGE Digest could not be parsed:Element type "includes" must be followed by either attribute specifications, ">" or "/>".
Replacing feature version of org.eclipse.platform with version 3.4.0.v20080324a-9F94EjREj_pBVPliz-q3jhrqxLcUuo66usz00mM
Replacing feature version of org.eclipse.sdk with version 3.4.0.v20080328-7M7Q_7BI5lpaYWEcz04kOkMCucvDSaaFWc1V9KoCK2ZP 7
Replacing feature version of org.eclipse.emf with version 2.4.0.v200802090050
Replacing feature version of org.eclipse.gef with version 3.4.0.v20080115-677-8082A5655G2337
Replacing feature version of org.eclipse.uml2.sdk with version 2.2.0.v200802201645
Replacing feature version of org.eclipse.emf.transaction with version 1.2.0.v200711141947-23-8s733H464D5EAG
Replacing feature version of org.eclipse.emf.validation with version 1.2.0.v200711071738-35-9oA55P898H9MBK
Replacing feature version of org.eclipse.emf.workspace with version 1.2.0.v200711141947-23-8s733H464D5EAG
Replacing feature version of org.eclipse.emf.query with version 1.2.0.v200711141856-11-7w311823172914
Replacing feature version of org.eclipse.ocl with version 1.2.0.v200711121858-34-9oA55R696J8AFA
Replacing feature version of org.eclipse.emf.ocl with version 1.1.100.v200710171842-108Y7w311823172739
Replacing feature version of org.eclipse.gmf.sdk with version 2.0.1.v20071003-0000-7f7BEAVEMnXQGKPLmcKJkkUIF--J
Replacing feature version of org.eclipse.uml2tools.sdk with version 0.7.1.v200802180622
Replacing feature version of org.eclipse.ocl.all.sdk with version 1.2.0.v200709211511-67_8Y_-NQOaOSTWJqiy-urjWGamY
Replacing feature version of org.eclipse.emf.emfqtv.all.sdk with version 1.2.0.v200710032115-7A7J-DjlSb7SveltvElLGf4JRlDE
Replacing feature version of org.eclipse.m2m.qvt.oml.sdk with version 1.0.0.v20080215-1734-79--A7JC0m3ljfa8HufpLDQkBsSU
Replacing feature version of org.eclipse.epp.usagedata.feature with version 0.5.2.N200802202215


It would be cool if someone could explain. It's really confusing...

Thanks,
Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #7974 is a reply to message #7955] Fri, 11 April 2008 07:56 Go to previous messageGo to next message
Eclipse User
Originally posted by: mknauer.innoopract.com

Hi Felix,

the short answer: If there is no specific version of a feature defined in
the EPP configuration file, the available update sites will be searched and
the version 'replaced' by the highest version.

But I'll have a look if everything works as expected. You are right that
this looks a bit strange.

Markus


Felix Dorner wrote:

> Hey,
>
> I downloaded
> 20080410-0540_eclipse-modeling-ganymede-M6-linux.gtk.x86.tar .gz from the
> EPP Nighly build site. As the page says, the nighly builds are made from
> the Ganymede Staging Update Site.
>
> Surprisingly the zip includes:
>
> Eclipse Modeling Framework (EMF)
> Version: 2.4.0.v200802090050
> Build id: 200802090050
>
>
> This confuses me, I thought It'd contain the M6 Packages, as these are
> already available at the Staging Update site. In the build log, these
> lines are suspicious:
>
> !ENTRY org.eclipse.update.core 4 0 2008-04-10 02:37:27.748
> !MESSAGE Digest could not be parsed:Element type "includes" must be
> followed by either attribute specifications, ">" or "/>". Replacing
> feature version of org.eclipse.platform with version
> 3.4.0.v20080324a-9F94EjREj_pBVPliz-q3jhrqxLcUuo66usz00mM Replacing feature
> version of org.eclipse.sdk with version
> 3.4.0.v20080328-7M7Q_7BI5lpaYWEcz04kOkMCucvDSaaFWc1V9KoCK2ZP 7 Replacing
> feature version of org.eclipse.emf with version 2.4.0.v200802090050
> Replacing feature version of org.eclipse.gef with version
> 3.4.0.v20080115-677-8082A5655G2337 Replacing feature version of
> org.eclipse.uml2.sdk with version 2.2.0.v200802201645 Replacing feature
> version of org.eclipse.emf.transaction with version
> 1.2.0.v200711141947-23-8s733H464D5EAG Replacing feature version of
> org.eclipse.emf.validation with version
> 1.2.0.v200711071738-35-9oA55P898H9MBK Replacing feature version of
> org.eclipse.emf.workspace with version
> 1.2.0.v200711141947-23-8s733H464D5EAG Replacing feature version of
> org.eclipse.emf.query with version 1.2.0.v200711141856-11-7w311823172914
> Replacing feature version of org.eclipse.ocl with version
> 1.2.0.v200711121858-34-9oA55R696J8AFA Replacing feature version of
> org.eclipse.emf.ocl with version 1.1.100.v200710171842-108Y7w311823172739
> Replacing feature version of org.eclipse.gmf.sdk with version
> 2.0.1.v20071003-0000-7f7BEAVEMnXQGKPLmcKJkkUIF--J Replacing feature
> version of org.eclipse.uml2tools.sdk with version 0.7.1.v200802180622
> Replacing feature version of org.eclipse.ocl.all.sdk with version
> 1.2.0.v200709211511-67_8Y_-NQOaOSTWJqiy-urjWGamY Replacing feature version
> of org.eclipse.emf.emfqtv.all.sdk with version
> 1.2.0.v200710032115-7A7J-DjlSb7SveltvElLGf4JRlDE Replacing feature version
> of org.eclipse.m2m.qvt.oml.sdk with version
> 1.0.0.v20080215-1734-79--A7JC0m3ljfa8HufpLDQkBsSU Replacing feature
> version of org.eclipse.epp.usagedata.feature with version
> 0.5.2.N200802202215
>
>
> It would be cool if someone could explain. It's really confusing...
>
> Thanks,
> Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #8008 is a reply to message #7974] Fri, 11 April 2008 09:04 Go to previous messageGo to next message
Eclipse User
Originally posted by: mknauer.innoopract.com

Thanks for spotting this... in the EPP configuration file the 'stable' and
not the 'staging' Ganymede update site was referenced.

Well, the result is... that the build is failing now. :(

Thanks
Markus


Markus Knauer wrote:

> Hi Felix,
>
> the short answer: If there is no specific version of a feature defined in
> the EPP configuration file, the available update sites will be searched
> and the version 'replaced' by the highest version.
>
> But I'll have a look if everything works as expected. You are right that
> this looks a bit strange.
>
> Markus
>
>
> Felix Dorner wrote:
>
>> Hey,
>>
>> I downloaded
>> 20080410-0540_eclipse-modeling-ganymede-M6-linux.gtk.x86.tar .gz from the
>> EPP Nighly build site. As the page says, the nighly builds are made from
>> the Ganymede Staging Update Site.
>>
>> Surprisingly the zip includes:
>>
>> Eclipse Modeling Framework (EMF)
>> Version: 2.4.0.v200802090050
>> Build id: 200802090050
>>
>>
>> This confuses me, I thought It'd contain the M6 Packages, as these are
>> already available at the Staging Update site. In the build log, these
>> lines are suspicious:
>>
>> !ENTRY org.eclipse.update.core 4 0 2008-04-10 02:37:27.748
>> !MESSAGE Digest could not be parsed:Element type "includes" must be
>> followed by either attribute specifications, ">" or "/>". Replacing
>> feature version of org.eclipse.platform with version
>> 3.4.0.v20080324a-9F94EjREj_pBVPliz-q3jhrqxLcUuo66usz00mM Replacing
>> feature version of org.eclipse.sdk with version
>> 3.4.0.v20080328-7M7Q_7BI5lpaYWEcz04kOkMCucvDSaaFWc1V9KoCK2ZP 7 Replacing
>> feature version of org.eclipse.emf with version 2.4.0.v200802090050
>> Replacing feature version of org.eclipse.gef with version
>> 3.4.0.v20080115-677-8082A5655G2337 Replacing feature version of
>> org.eclipse.uml2.sdk with version 2.2.0.v200802201645 Replacing feature
>> version of org.eclipse.emf.transaction with version
>> 1.2.0.v200711141947-23-8s733H464D5EAG Replacing feature version of
>> org.eclipse.emf.validation with version
>> 1.2.0.v200711071738-35-9oA55P898H9MBK Replacing feature version of
>> org.eclipse.emf.workspace with version
>> 1.2.0.v200711141947-23-8s733H464D5EAG Replacing feature version of
>> org.eclipse.emf.query with version 1.2.0.v200711141856-11-7w311823172914
>> Replacing feature version of org.eclipse.ocl with version
>> 1.2.0.v200711121858-34-9oA55R696J8AFA Replacing feature version of
>> org.eclipse.emf.ocl with version 1.1.100.v200710171842-108Y7w311823172739
>> Replacing feature version of org.eclipse.gmf.sdk with version
>> 2.0.1.v20071003-0000-7f7BEAVEMnXQGKPLmcKJkkUIF--J Replacing feature
>> version of org.eclipse.uml2tools.sdk with version 0.7.1.v200802180622
>> Replacing feature version of org.eclipse.ocl.all.sdk with version
>> 1.2.0.v200709211511-67_8Y_-NQOaOSTWJqiy-urjWGamY Replacing feature
>> version of org.eclipse.emf.emfqtv.all.sdk with version
>> 1.2.0.v200710032115-7A7J-DjlSb7SveltvElLGf4JRlDE Replacing feature
>> version of org.eclipse.m2m.qvt.oml.sdk with version
>> 1.0.0.v20080215-1734-79--A7JC0m3ljfa8HufpLDQkBsSU Replacing feature
>> version of org.eclipse.epp.usagedata.feature with version
>> 0.5.2.N200802202215
>>
>>
>> It would be cool if someone could explain. It's really confusing...
>>
>> Thanks,
>> Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #8042 is a reply to message #8008] Fri, 11 April 2008 10:30 Go to previous messageGo to next message
Felix Dorner is currently offline Felix Dorner
Messages: 675
Registered: July 2009
Senior Member
Markus Knauer wrote:
> Thanks for spotting this... in the EPP configuration file the 'stable' and
> not the 'staging' Ganymede update site was referenced.
>
> Well, the result is... that the build is failing now. :(

Not a terribly bad thing, imagine we think that all's fine, but
really isn't.


Greetings,
Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #8073 is a reply to message #8008] Fri, 11 April 2008 10:34 Go to previous messageGo to next message
Felix Dorner is currently offline Felix Dorner
Messages: 675
Registered: July 2009
Senior Member
Markus Knauer wrote:
> Thanks for spotting this... in the EPP configuration file the 'stable' and
> not the 'staging' Ganymede update site was referenced.
>
> Well, the result is... that the build is failing now. :(

I looked into the log, it seems there are some unresolved dependencies
from GMF examples to EMF examples. I also got these errors at startup
time after installing the per-project builds manually.


Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #8103 is a reply to message #8073] Fri, 11 April 2008 11:12 Go to previous messageGo to next message
Eclipse User
Originally posted by: merks.ca.ibm.com

Felix,

We don't ship EMF's examples as plugins that would be installed into the
running IDE, so it doesn't make sense for any downstream builds to
expect otherwise. We have
https://bugs.eclipse.org/bugs/show_bug.cgi?id=188989 open to ship them
in a form that would allow the user to "unzip" them into their workspace
via a wizard. That's probably the most sensible for all examples, so
perhaps it makes sense that GMF should be planning the same thing.


Felix Dorner wrote:
> Markus Knauer wrote:
>> Thanks for spotting this... in the EPP configuration file the
>> 'stable' and
>> not the 'staging' Ganymede update site was referenced.
>>
>> Well, the result is... that the build is failing now. :(
>
> I looked into the log, it seems there are some unresolved dependencies
> from GMF examples to EMF examples. I also got these errors at startup
> time after installing the per-project builds manually.
>
>
> Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #8134 is a reply to message #8103] Fri, 11 April 2008 12:09 Go to previous messageGo to next message
Richard Gronback is currently offline Richard Gronback
Messages: 605
Registered: July 2009
Senior Member
We're planning to build an M6a that removes the examples from our SDK to
resolve this issue ASAP. Sorry for the trouble.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=226511#c4

- Rich


On 4/11/08 7:12 AM, in article 47FF4790.3010407@ca.ibm.com, "Ed Merks"
<merks@ca.ibm.com> wrote:

> Felix,
>
> We don't ship EMF's examples as plugins that would be installed into the
> running IDE, so it doesn't make sense for any downstream builds to
> expect otherwise. We have
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=188989 open to ship them
> in a form that would allow the user to "unzip" them into their workspace
> via a wizard. That's probably the most sensible for all examples, so
> perhaps it makes sense that GMF should be planning the same thing.
>
>
> Felix Dorner wrote:
>> Markus Knauer wrote:
>>> Thanks for spotting this... in the EPP configuration file the
>>> 'stable' and
>>> not the 'staging' Ganymede update site was referenced.
>>>
>>> Well, the result is... that the build is failing now. :(
>>
>> I looked into the log, it seems there are some unresolved dependencies
>> from GMF examples to EMF examples. I also got these errors at startup
>> time after installing the per-project builds manually.
>>
>>
>> Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #8166 is a reply to message #8073] Sat, 12 April 2008 08:48 Go to previous message
Eclipse User
Originally posted by: mknauer.innoopract.com

Should be fixed now: http://www.eclipse.org/epp/download.php

The 20080412-0540 build doesn't contain the EMF examples any more and the
feature versions are new and updated:

http://build.eclipse.org/technology/epp/epp_build/34/downloa d/20080412-0540/modeling.log

Markus

Felix Dorner wrote:

> Markus Knauer wrote:
>> Thanks for spotting this... in the EPP configuration file the 'stable'
>> and not the 'staging' Ganymede update site was referenced.
>>
>> Well, the result is... that the build is failing now. :(
>
> I looked into the log, it seems there are some unresolved dependencies
> from GMF examples to EMF examples. I also got these errors at startup
> time after installing the per-project builds manually.
>
>
> Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #576462 is a reply to message #7955] Fri, 11 April 2008 07:56 Go to previous message
Markus Knauer is currently offline Markus Knauer
Messages: 107
Registered: July 2009
Senior Member

Hi Felix,

the short answer: If there is no specific version of a feature defined in
the EPP configuration file, the available update sites will be searched and
the version 'replaced' by the highest version.

But I'll have a look if everything works as expected. You are right that
this looks a bit strange.

Markus


Felix Dorner wrote:

> Hey,
>
> I downloaded
> 20080410-0540_eclipse-modeling-ganymede-M6-linux.gtk.x86.tar .gz from the
> EPP Nighly build site. As the page says, the nighly builds are made from
> the Ganymede Staging Update Site.
>
> Surprisingly the zip includes:
>
> Eclipse Modeling Framework (EMF)
> Version: 2.4.0.v200802090050
> Build id: 200802090050
>
>
> This confuses me, I thought It'd contain the M6 Packages, as these are
> already available at the Staging Update site. In the build log, these
> lines are suspicious:
>
> !ENTRY org.eclipse.update.core 4 0 2008-04-10 02:37:27.748
> !MESSAGE Digest could not be parsed:Element type "includes" must be
> followed by either attribute specifications, ">" or "/>". Replacing
> feature version of org.eclipse.platform with version
> 3.4.0.v20080324a-9F94EjREj_pBVPliz-q3jhrqxLcUuo66usz00mM Replacing feature
> version of org.eclipse.sdk with version
> 3.4.0.v20080328-7M7Q_7BI5lpaYWEcz04kOkMCucvDSaaFWc1V9KoCK2ZP 7 Replacing
> feature version of org.eclipse.emf with version 2.4.0.v200802090050
> Replacing feature version of org.eclipse.gef with version
> 3.4.0.v20080115-677-8082A5655G2337 Replacing feature version of
> org.eclipse.uml2.sdk with version 2.2.0.v200802201645 Replacing feature
> version of org.eclipse.emf.transaction with version
> 1.2.0.v200711141947-23-8s733H464D5EAG Replacing feature version of
> org.eclipse.emf.validation with version
> 1.2.0.v200711071738-35-9oA55P898H9MBK Replacing feature version of
> org.eclipse.emf.workspace with version
> 1.2.0.v200711141947-23-8s733H464D5EAG Replacing feature version of
> org.eclipse.emf.query with version 1.2.0.v200711141856-11-7w311823172914
> Replacing feature version of org.eclipse.ocl with version
> 1.2.0.v200711121858-34-9oA55R696J8AFA Replacing feature version of
> org.eclipse.emf.ocl with version 1.1.100.v200710171842-108Y7w311823172739
> Replacing feature version of org.eclipse.gmf.sdk with version
> 2.0.1.v20071003-0000-7f7BEAVEMnXQGKPLmcKJkkUIF--J Replacing feature
> version of org.eclipse.uml2tools.sdk with version 0.7.1.v200802180622
> Replacing feature version of org.eclipse.ocl.all.sdk with version
> 1.2.0.v200709211511-67_8Y_-NQOaOSTWJqiy-urjWGamY Replacing feature version
> of org.eclipse.emf.emfqtv.all.sdk with version
> 1.2.0.v200710032115-7A7J-DjlSb7SveltvElLGf4JRlDE Replacing feature version
> of org.eclipse.m2m.qvt.oml.sdk with version
> 1.0.0.v20080215-1734-79--A7JC0m3ljfa8HufpLDQkBsSU Replacing feature
> version of org.eclipse.epp.usagedata.feature with version
> 0.5.2.N200802202215
>
>
> It would be cool if someone could explain. It's really confusing...
>
> Thanks,
> Felix


--
Markus Knauer

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: EPP Nightly Build. What is "Replacing feature version"? [message #576517 is a reply to message #7974] Fri, 11 April 2008 09:04 Go to previous message
Markus Knauer is currently offline Markus Knauer
Messages: 107
Registered: July 2009
Senior Member

Thanks for spotting this... in the EPP configuration file the 'stable' and
not the 'staging' Ganymede update site was referenced.

Well, the result is... that the build is failing now. :(

Thanks
Markus


Markus Knauer wrote:

> Hi Felix,
>
> the short answer: If there is no specific version of a feature defined in
> the EPP configuration file, the available update sites will be searched
> and the version 'replaced' by the highest version.
>
> But I'll have a look if everything works as expected. You are right that
> this looks a bit strange.
>
> Markus
>
>
> Felix Dorner wrote:
>
>> Hey,
>>
>> I downloaded
>> 20080410-0540_eclipse-modeling-ganymede-M6-linux.gtk.x86.tar .gz from the
>> EPP Nighly build site. As the page says, the nighly builds are made from
>> the Ganymede Staging Update Site.
>>
>> Surprisingly the zip includes:
>>
>> Eclipse Modeling Framework (EMF)
>> Version: 2.4.0.v200802090050
>> Build id: 200802090050
>>
>>
>> This confuses me, I thought It'd contain the M6 Packages, as these are
>> already available at the Staging Update site. In the build log, these
>> lines are suspicious:
>>
>> !ENTRY org.eclipse.update.core 4 0 2008-04-10 02:37:27.748
>> !MESSAGE Digest could not be parsed:Element type "includes" must be
>> followed by either attribute specifications, ">" or "/>". Replacing
>> feature version of org.eclipse.platform with version
>> 3.4.0.v20080324a-9F94EjREj_pBVPliz-q3jhrqxLcUuo66usz00mM Replacing
>> feature version of org.eclipse.sdk with version
>> 3.4.0.v20080328-7M7Q_7BI5lpaYWEcz04kOkMCucvDSaaFWc1V9KoCK2ZP 7 Replacing
>> feature version of org.eclipse.emf with version 2.4.0.v200802090050
>> Replacing feature version of org.eclipse.gef with version
>> 3.4.0.v20080115-677-8082A5655G2337 Replacing feature version of
>> org.eclipse.uml2.sdk with version 2.2.0.v200802201645 Replacing feature
>> version of org.eclipse.emf.transaction with version
>> 1.2.0.v200711141947-23-8s733H464D5EAG Replacing feature version of
>> org.eclipse.emf.validation with version
>> 1.2.0.v200711071738-35-9oA55P898H9MBK Replacing feature version of
>> org.eclipse.emf.workspace with version
>> 1.2.0.v200711141947-23-8s733H464D5EAG Replacing feature version of
>> org.eclipse.emf.query with version 1.2.0.v200711141856-11-7w311823172914
>> Replacing feature version of org.eclipse.ocl with version
>> 1.2.0.v200711121858-34-9oA55R696J8AFA Replacing feature version of
>> org.eclipse.emf.ocl with version 1.1.100.v200710171842-108Y7w311823172739
>> Replacing feature version of org.eclipse.gmf.sdk with version
>> 2.0.1.v20071003-0000-7f7BEAVEMnXQGKPLmcKJkkUIF--J Replacing feature
>> version of org.eclipse.uml2tools.sdk with version 0.7.1.v200802180622
>> Replacing feature version of org.eclipse.ocl.all.sdk with version
>> 1.2.0.v200709211511-67_8Y_-NQOaOSTWJqiy-urjWGamY Replacing feature
>> version of org.eclipse.emf.emfqtv.all.sdk with version
>> 1.2.0.v200710032115-7A7J-DjlSb7SveltvElLGf4JRlDE Replacing feature
>> version of org.eclipse.m2m.qvt.oml.sdk with version
>> 1.0.0.v20080215-1734-79--A7JC0m3ljfa8HufpLDQkBsSU Replacing feature
>> version of org.eclipse.epp.usagedata.feature with version
>> 0.5.2.N200802202215
>>
>>
>> It would be cool if someone could explain. It's really confusing...
>>
>> Thanks,
>> Felix


--
Markus Knauer

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Re: EPP Nightly Build. What is "Replacing feature version"? [message #576531 is a reply to message #8008] Fri, 11 April 2008 10:30 Go to previous message
Felix Dorner is currently offline Felix Dorner
Messages: 675
Registered: July 2009
Senior Member
Markus Knauer wrote:
> Thanks for spotting this... in the EPP configuration file the 'stable' and
> not the 'staging' Ganymede update site was referenced.
>
> Well, the result is... that the build is failing now. :(

Not a terribly bad thing, imagine we think that all's fine, but
really isn't.


Greetings,
Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #576544 is a reply to message #8008] Fri, 11 April 2008 10:34 Go to previous message
Felix Dorner is currently offline Felix Dorner
Messages: 675
Registered: July 2009
Senior Member
Markus Knauer wrote:
> Thanks for spotting this... in the EPP configuration file the 'stable' and
> not the 'staging' Ganymede update site was referenced.
>
> Well, the result is... that the build is failing now. :(

I looked into the log, it seems there are some unresolved dependencies
from GMF examples to EMF examples. I also got these errors at startup
time after installing the per-project builds manually.


Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #576586 is a reply to message #8073] Fri, 11 April 2008 11:12 Go to previous message
Ed Merks is currently offline Ed Merks
Messages: 26054
Registered: July 2009
Senior Member
Felix,

We don't ship EMF's examples as plugins that would be installed into the
running IDE, so it doesn't make sense for any downstream builds to
expect otherwise. We have
https://bugs.eclipse.org/bugs/show_bug.cgi?id=188989 open to ship them
in a form that would allow the user to "unzip" them into their workspace
via a wizard. That's probably the most sensible for all examples, so
perhaps it makes sense that GMF should be planning the same thing.


Felix Dorner wrote:
> Markus Knauer wrote:
>> Thanks for spotting this... in the EPP configuration file the
>> 'stable' and
>> not the 'staging' Ganymede update site was referenced.
>>
>> Well, the result is... that the build is failing now. :(
>
> I looked into the log, it seems there are some unresolved dependencies
> from GMF examples to EMF examples. I also got these errors at startup
> time after installing the per-project builds manually.
>
>
> Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #576612 is a reply to message #8103] Fri, 11 April 2008 12:09 Go to previous message
Richard Gronback is currently offline Richard Gronback
Messages: 605
Registered: July 2009
Senior Member
We're planning to build an M6a that removes the examples from our SDK to
resolve this issue ASAP. Sorry for the trouble.

https://bugs.eclipse.org/bugs/show_bug.cgi?id=226511#c4

- Rich


On 4/11/08 7:12 AM, in article 47FF4790.3010407@ca.ibm.com, "Ed Merks"
<merks@ca.ibm.com> wrote:

> Felix,
>
> We don't ship EMF's examples as plugins that would be installed into the
> running IDE, so it doesn't make sense for any downstream builds to
> expect otherwise. We have
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=188989 open to ship them
> in a form that would allow the user to "unzip" them into their workspace
> via a wizard. That's probably the most sensible for all examples, so
> perhaps it makes sense that GMF should be planning the same thing.
>
>
> Felix Dorner wrote:
>> Markus Knauer wrote:
>>> Thanks for spotting this... in the EPP configuration file the
>>> 'stable' and
>>> not the 'staging' Ganymede update site was referenced.
>>>
>>> Well, the result is... that the build is failing now. :(
>>
>> I looked into the log, it seems there are some unresolved dependencies
>> from GMF examples to EMF examples. I also got these errors at startup
>> time after installing the per-project builds manually.
>>
>>
>> Felix
Re: EPP Nightly Build. What is "Replacing feature version"? [message #576665 is a reply to message #8073] Sat, 12 April 2008 08:48 Go to previous message
Markus Knauer is currently offline Markus Knauer
Messages: 107
Registered: July 2009
Senior Member

Should be fixed now: http://www.eclipse.org/epp/download.php

The 20080412-0540 build doesn't contain the EMF examples any more and the
feature versions are new and updated:

http://build.eclipse.org/technology/epp/epp_build/34/downloa d/20080412-0540/modeling.log

Markus

Felix Dorner wrote:

> Markus Knauer wrote:
>> Thanks for spotting this... in the EPP configuration file the 'stable'
>> and not the 'staging' Ganymede update site was referenced.
>>
>> Well, the result is... that the build is failing now. :(
>
> I looked into the log, it seems there are some unresolved dependencies
> from GMF examples to EMF examples. I also got these errors at startup
> time after installing the per-project builds manually.
>
>
> Felix


--
Markus Knauer

Twitter: @EclipseRAP
Blog: http://eclipsesource.com/blogs/

Professional services for RAP and RCP?
http://eclipsesource.com/services/rap/
Previous Topic:EPP Nightly Build. What is "Replacing feature version"?
Next Topic:Getting the org.eclipse.releng.eclipse.builder code
Goto Forum:
  


Current Time: Sat Sep 20 02:00:53 GMT 2014

Powered by FUDForum. Page generated in 0.03206 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software