Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Issues with extra lines in Eclipse after upgrading to Windows 7
Issues with extra lines in Eclipse after upgrading to Windows 7 [message #771932] Wed, 28 December 2011 15:08 Go to next message
John Perry is currently offline John PerryFriend
Messages: 1
Registered: December 2011
Junior Member
So I was using an older version of Eclipse for the longest time for my php projects, I believe I was using Galileo, on Windows XP 64 bit. I then upgraded to Windows 7 64 bit and I am now using the latest version of Eclipse, Indigo. When I open up any php files via Eclipse every line has an extra new line. For example:

//Old Eclipse code
$this = 'that';
$that = 'this';

//New Eclipse code
$this = 'that';

$that = 'this';


And if I edit the php file in the new Eclipse, save it, then upload it to my web server I get an invalid php character error. I then re-open the same php script and its all on one line and I have to manually add back all the formatting. In order to bypass this issue I have to open the php script via Eclipse, copy the whole script, paste it into notepad, copy it from notepad and then paste it over the old script in Eclipse and save. Any idea why this is happening? The same issue seems to be happening in other IDE's as well such as NetBeans, PHPDesigner and Aptana Studio 3.
Re: Issues with extra lines in Eclipse after upgrading to Windows 7 [message #775604 is a reply to message #771932] Fri, 06 January 2012 10:46 Go to previous message
Dani Megert is currently offline Dani MegertFriend
Messages: 3801
Registered: July 2009
Senior Member
On 28.12.2011 16:08, John Perry wrote:
> So I was using an older version of Eclipse for the longest time for my
> php projects, I believe I was using Galileo, on Windows XP 64 bit. I
> then upgraded to Windows 7 64 bit and I am now using the latest
> version of Eclipse, Indigo. When I open up any php files via Eclipse
> every line has an extra new line. For example:
>
> //Old Eclipse code
> $this = 'that';
> $that = 'this';
>
> //New Eclipse code
> $this = 'that';
>
> $that = 'this';
Could be an encoding or line delimiter issue. Enable to show whitespace
characters and/or take a look at the file in a Hex editor.

Dani
>
> And if I edit the php file in the new Eclipse, save it, then upload it
> to my web server I get an invalid php character error. I then re-open
> the same php script and its all on one line and I have to manually add
> back all the formatting. In order to bypass this issue I have to open
> the php script via Eclipse, copy the whole script, paste it into
> notepad, copy it from notepad and then paste it over the old script in
> Eclipse and save. Any idea why this is happening? The same issue seems
> to be happening in other IDE's as well such as NetBeans, PHPDesigner
> and Aptana Studio 3.
>
Previous Topic:How to show browser view in Eclipse
Next Topic:Scrapbook
Goto Forum:
  


Current Time: Thu Nov 27 14:38:54 GMT 2014

Powered by FUDForum. Page generated in 0.02185 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software