Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Linux Tools Project » Problem with OPofiler in Ubuntu(i have 10.10)
icon5.gif  Problem with OPofiler in Ubuntu [message #770780] Sun, 25 December 2011 10:02 Go to next message
El ni is currently offline El ni
Messages: 8
Registered: February 2010
Junior Member
Hello,
i installed the oprofiler with the incubation eclipse (indigo).

i tried to use oprofiler on my ubuntu 10.10.

i got a lot of process, i managed to download the missing packeges,

and i got to secction:
wiki.eclipse.org/Linux_Tools_Project/OProfile/User_Guide#Troubleshooting

in step it says "make". but make what...
i couldn't create the libs.

is there an easier process for all that? it is very complicated...

can anyone help me how to proceed?

thanks in advance,

by the way i have oprofile-0.9.6
Re: Problem with OPofiler in Ubuntu [message #774759 is a reply to message #770780] Wed, 04 January 2012 14:43 Go to previous messageGo to next message
Roland Grunberg is currently offline Roland Grunberg
Messages: 26
Registered: December 2009
Junior Member
El ni wrote on Sun, 25 December 2011 05:02
Hello,
i installed the oprofiler with the incubation eclipse (indigo).

i tried to use oprofiler on my ubuntu 10.10.

i got a lot of process, i managed to download the missing packeges,

and i got to secction:
wiki.eclipse.org/Linux_Tools_Project/OProfile/User_Guide#Troubleshooting

in step it says "make". but make what...
i couldn't create the libs.

is there an easier process for all that? it is very complicated...

can anyone help me how to proceed?

thanks in advance,

by the way i have oprofile-0.9.6


I haven't tested this on Ubuntu, but the compiling of opxml is not necessary as of 0.7.0 of the Eclipse Oprofile plugin (note that this is not the same as the version of the oprofile tool, which is 0.9.6 in your case).

If you got the latest version from the Linux Tools Project update site, then you likely have 0.9.0 which means you don't require compiling opxml. You can try just following the regular installation instructions : http://wiki.eclipse.org/Linux_Tools_Project/OProfile/User_Guide#Installation_and_Set-Up .

Hope this helps.
Re: Problem with OPofiler in Ubuntu [message #776427 is a reply to message #774759] Sun, 08 January 2012 11:05 Go to previous messageGo to next message
El ni is currently offline El ni
Messages: 8
Registered: February 2010
Junior Member
Hi,
i saw the post at:
www.eclipse.org/forums/index.php/m/569986/


i'm using ubunti 10.10 32bit.
i install the OProfile and it seems to run manually.
i try to run it on the example project:
wiki.eclipse.org/Linux_Tools_Project/OProfile/User_Guide#Example_Project

but i still get "No profiling data is on the system."

can you please help me with this???

thanks in advance,
Re: Problem with OPofiler in Ubuntu [message #778375 is a reply to message #776427] Thu, 12 January 2012 16:24 Go to previous messageGo to next message
Roland Grunberg is currently offline Roland Grunberg
Messages: 26
Registered: December 2009
Junior Member
El ni wrote on Sun, 08 January 2012 06:05
Hi,
i saw the post at:
www.eclipse.org/forums/index.php/m/569986/


i'm using ubunti 10.10 32bit.
i install the OProfile and it seems to run manually.
i try to run it on the example project:
wiki.eclipse.org/Linux_Tools_Project/OProfile/User_Guide#Example_Project

but i still get "No profiling data is on the system."

can you please help me with this???

thanks in advance,


Are you using the latest Eclipse Oprofile from http://download.eclipse.org/technology/linuxtools/update/ ? You mention that it seems to run manually. Do you mean that you can go through all the steps of setting up the daemon, starting it, running your binary, stopping, and viewing samples through the opreport command ?

If this is the case then try profiling your project with OProfile in Eclipse. When it displays the message about no profiling data, go to the command-line and try running "opcontrol --status" as root. This should display some information. See if the absolute path for "Image Filter" is the correct path to your binary.
Re: Problem with OPofiler in Ubuntu [message #780754 is a reply to message #778375] Thu, 19 January 2012 10:06 Go to previous messageGo to next message
El ni is currently offline El ni
Messages: 8
Registered: February 2010
Junior Member
Hi,
thanks for the response.
i have the latest oprofile.

i have a simple code of a for-loop with a sleep inside. that's all.

i still see the error "no profilling data is on the system".

this is the code:
unsigned long long factorial1(unsigned long long);
unsigned long long factorial2(unsigned long long);
#include <unistd.h>

int main() {
	for (int i = 0; i < 1000000; i++) {
		factorial1(20);
		factorial2(20);
	}
}

unsigned long long factorial1(unsigned long long n) {
	if (n <= 1)
		return 1;
	else
	{
		sleep(1);
		return n * factorial1(n-1);
	}
}

unsigned long long factorial2(unsigned long long n) {
	unsigned long long ret = 1;
	for (unsigned int i = 1; i <= n; i++)
		ret *= i;
	return ret;
}



and this is what i get when i run oprofile from eclipse in the terminal i "sudo opcontrol --status":
Daemon running: pid 1562
Event 0: CPU_CLK_UNHALTED:100000:0:1:1
Separate options: none
vmlinux file: none
Image filter: /home/blabla/workspace/factorial/Debug/factorial
Call-graph depth: 0

still nothing happens.

do you have any more suggestions???

thank in advance Smile
Re: Problem with OPofiler in Ubuntu [message #783360 is a reply to message #780754] Wed, 25 January 2012 15:27 Go to previous message
Roland Grunberg is currently offline Roland Grunberg
Messages: 26
Registered: December 2009
Junior Member
Quote:
i still see the error "no profilling data is on the system".


Often when this happens it could be an issue with the sampling rate. Oprofile checks hardware counters at intervals. By lowering the "Count" you can increase this interval and hopefully collect some samples. This setting can be changed by right clicking your project, going to profile configurations, selecting the oprofile configuration for the project, and selecting the events tab, where you will see the setting. (http://wiki.eclipse.org/Linux_Tools_Project/OProfile/User_Guide#Regular_Mode)


Quote:
and this is what i get when i run oprofile from eclipse in the terminal i "sudo opcontrol --status":
Daemon running: pid 1562
Event 0: CPU_CLK_UNHALTED:100000:0:1:1
Separate options: none
vmlinux file: none
Image filter: /home/blabla/workspace/factorial/Debug/factorial
Call-graph depth: 0

still nothing happens.

do you have any more suggestions???


The daemon seems to be running and the settings look fine. After running the binary, what does running 'opreport' show you? If it mentions that no sample file was found then it would confirm that you need to reduce the sampling frequency (mentioned above). Otherwise this would seem to be a bug requiring some investigation.
Previous Topic:Problem with Linuxtool installation
Next Topic:Eclipse, CDT, Cygwin: GCov panel shows zero values
Goto Forum:
  


Current Time: Thu Oct 23 20:42:32 GMT 2014

Powered by FUDForum. Page generated in 0.02711 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software