Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Test and Performance Tools Platform (TPTP) » Trouble Installing TPTP
Trouble Installing TPTP [message #87626] Thu, 16 November 2006 14:47
Eclipse User
Originally posted by: mlevison.gmail.com

Yesterday I had a painful battle trying to install tptp 4.2.1, I looking
for some suggestions on where I went wrong (following the instructions at
http://www.eclipse.org/tptp/home/downloads/installguide/Inst allGuide42.html)
literally.

My story follows:
1. Find the Eclipse Test and Performance Tools Platform website
(http://www.eclipse.org/tptp/)
2. TPTP website hides the installation instructions – however Google
found them here
( http://www.eclipse.org/tptp/home/downloads/installguide/Inst allGuide42.html)
3. Using the update site (http://eclipse.org/tptp/updates/site.xml)
recommend in the installation instructions, try to find the features. It’s
slow, insanely slow.
4. From 4.2.1 select the Tracing and Profiling package – get warned of
errors because I don’t have all required plugins
5. Use the Select required – get errors because it can’t find the
required EMF dependency (among others)
6. Now try the manual steps
( http://www.eclipse.org/tptp/home/downloads/installguide/Inst allGuide42.html#install_manual)
of getting the All TPTP file
( http://www.eclipse.org/downloads/download.php?file=/tptp/4.2 .0/TPTP-4.2.0-200606190100A/tptp.runtime-TPTP-4.2.0.zip)
from an Eclipse download site. Hint don’t choose the main site its slow
try anything else (I used Indiana).
7. Unzip the download files in your eclipse directory.
8. Restart Eclipse
9. Now I get the option to Analyze my code (a static analysis tool –
like PMD. BTW why the duplication of effort?), but no “Profile As…” item
in my toolbar/context menus
( http://www.eclipse.org/articles/Article-TPTP-Profiling-Tool/ tptpProfilingArticle.html)
– what gives? Now I suspect that the right components were always on my
disk I just didn't know how to activate them.
10. Now I've got a copy of TPTP 4.2.x installed maybe I can retry the
update site and find a missing feature. But no joy just more wasted time.

Did I have everything I need installed? I think so. If so what do I need
to activate/make it appear in the UI the profiler.

Once we figure out my mistake is there anyway to update the installation
instructions to reflect the solution? Also could someone update the
installation to reflect the emf and other dependancies that will be a
problem if installed via the update route? Any of this would save the next
person my frustrating waste of a morning.
Previous Topic:Remote Import of log file
Next Topic:Using Java class callouts with the Generic Log Adapter / Using substitution extension class
Goto Forum:
  


Current Time: Mon Sep 22 22:27:31 GMT 2014

Powered by FUDForum. Page generated in 0.02460 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software