Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » General connection error with response code=-1(connection error)
General connection error with response code=-1 [message #769571] Thu, 22 December 2011 05:58 Go to next message
Carmelo  is currently offline Carmelo
Messages: 4
Registered: December 2011
Junior Member
Hello everybody,
i'm new in eclipse and for this forum too.
Shortly, i can't access software updates or install new software, because of an exception during connection.
I'm under a proxy so i think is for this reason, i tried to do something but didn't work.
I'm working on a virtual machine with windows7 under a proxy with Indigo and java 6.
This is my eclipse.ini
-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.100.v20110502
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-Dhttp.proxyPort=myport
-Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient
-Dhttp.proxyHost=myproxy
-Dhttp.proxyUser=myuser
-Dhttp.proxyPassword=mypassword
-Dhttp.nonProxyHosts=localhost|127.0.0.1


In attachment my log

Thanks everybody!
  • Attachment: log.txt
    (Size: 19.22KB, Downloaded 111 times)
Re: General connection error with response code=-1 [message #769659 is a reply to message #769571] Thu, 22 December 2011 08:43 Go to previous messageGo to next message
Russell Bateman is currently offline Russell Bateman
Messages: 3148
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2011.12.22 3:58, Carmelo wrote:
> Hello everybody,
> i'm new in eclipse and for this forum too.
> Shortly, i can't access software updates or install new software, because of an exception during connection.
> I'm under a proxy so i think is for this reason, i tried to do something but didn't work.
> I'm working on a virtual machine with windows7 under a proxy with Indigo and java 6.
> This is my eclipse.ini
> -startup
> plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
> --launcher.library
> plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.100.v20110502
> -product
> org.eclipse.epp.package.jee.product
> --launcher.defaultAction
> openFile
> --launcher.XXMaxPermSize
> 256M
> -showsplash
> org.eclipse.platform
> --launcher.XXMaxPermSize
> 256m
> --launcher.defaultAction
> openFile
> -vmargs
> -Dosgi.requiredJavaVersion=1.5
> -Xms40m
> -Xmx512m
> -Dhttp.proxyPort=myport
> -Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient
> -Dhttp.proxyHost=myproxy
> -Dhttp.proxyUser=myuser
> -Dhttp.proxyPassword=mypassword
> -Dhttp.nonProxyHosts=localhost|127.0.0.1
>
> In attachment my log
>
> Thanks everybody!

Carmelo,

It might have nothing to do with your problem, but it's customary for an
Eclipse user to signal the exact path to a Sun JDK via the -vm option in
eclipse.ini just before the -vmargs option. (Note that the -vm option
consists of two lines.) Taking care of this will eliminate one variable
in any problem when you come back to this forum.

http://wiki.eclipse.org/Eclipse.ini#Windows_Example
Re: General connection error with response code=-1 [message #770078 is a reply to message #769659] Fri, 23 December 2011 04:22 Go to previous messageGo to next message
Carmelo  is currently offline Carmelo
Messages: 4
Registered: December 2011
Junior Member
Done, but it still doesn't work.
This is my eclipse.ini:
-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.100.v20110502
-product
org.eclipse.epp.package.jee.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile

-vm
C:\Program Files\Java\jdk1.7.0_02\bin\javaw.exe
-vmargs

-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m

-Dhttp.proxyPort=****
-Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient
-Dhttp.proxyHost=************
-Dhttp.proxyUser=************
-Dhttp.proxyPassword=*******
-Dhttp.nonProxyHosts=localhost|127.0.0.1



Re: General connection error with response code=-1 [message #770153 is a reply to message #770078] Fri, 23 December 2011 08:35 Go to previous messageGo to next message
Carmelo  is currently offline Carmelo
Messages: 4
Registered: December 2011
Junior Member
up
Re: General connection error with response code=-1 [message #771552 is a reply to message #770153] Tue, 27 December 2011 10:42 Go to previous messageGo to next message
Carmelo  is currently offline Carmelo
Messages: 4
Registered: December 2011
Junior Member
I'm sorry,
i'm really stuck with this issue.
If someone has any idea please help me.
Re: General connection error with response code=-1 [message #772790 is a reply to message #771552] Fri, 30 December 2011 10:46 Go to previous messageGo to next message
Carmelo Missing name is currently offline Carmelo Missing name
Messages: 2
Registered: December 2011
Junior Member
I'm tryng to use differente version of eclipse(Helios) but nothing changes!
Re: General connection error with response code=-1 [message #772793 is a reply to message #771552] Fri, 30 December 2011 10:53 Go to previous messageGo to next message
Carmelo Missing name is currently offline Carmelo Missing name
Messages: 2
Registered: December 2011
Junior Member
I'm tring with different versions(helios)but nothing changes...what can i do?
Re: General connection error with response code=-1 [message #772810 is a reply to message #772793] Fri, 30 December 2011 11:42 Go to previous message
Russell Bateman is currently offline Russell Bateman
Messages: 3148
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 2011.12.30 8:53, Carmelo Mising name wrote:
> I'm tring with different versions(helios)but nothing changes...what can
> i do?

You might try from scratch. I have a summary that may be useful. Perhaps
you'll stumble upon what you did wrong as you follow it?

http://www.javahotchocolate.com/tutorials/eclipse-summary.html

(I can only hope this is helpful. Sorry you're having such a bad time of
it.)
Previous Topic:vbScript plugin
Next Topic:p2 in ~
Goto Forum:
  


Current Time: Sat Aug 23 01:43:03 EDT 2014

Powered by FUDForum. Page generated in 0.04842 seconds