Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Remote Application Platform (RAP) » 1.5M4 -SyntaxError: JSON.parse
1.5M4 -SyntaxError: JSON.parse [message #768543] Tue, 20 December 2011 10:30 Go to next message
Avrajit Chatterjee is currently offline Avrajit Chatterjee
Messages: 64
Registered: September 2011
Member
Hi,

I am trying to migrate my application into RAP 1.5M4. I know that now the communication protocol for RAP is JSON.

I see the following error in Firebug often after 1.5 M4 migration-
"Could not execute javascript: [ ]
[Break On This Error] (no source for SyntaxError: JSON.parse)"
It doesnt have any impact in the application. But just curious to know why does it come?
Re: 1.5M4 -SyntaxError: JSON.parse [message #768544 is a reply to message #768543] Tue, 20 December 2011 10:35 Go to previous messageGo to next message
Ivan Furnadjiev is currently offline Ivan Furnadjiev
Messages: 1839
Registered: July 2009
Senior Member
Hi,
we just fixed this issue in CVS HEAD. You could try the next nightly
build. Here are the related bugzillas:
367053: [UICallBackManager] Writes a space for check isConnectionAlive -
leads to exception in UICallBack.js _handleFinished
https://bugs.eclipse.org/bugs/show_bug.cgi?id=367053
367155: [UICallBack] Sometimes the UICallBack response is empty string
(with spaces only)
https://bugs.eclipse.org/bugs/show_bug.cgi?id=367155
Best,
Ivan

On 12/20/2011 12:30 PM, Avrajit wrote:
> Hi,
>
> I am trying to migrate my application into RAP 1.5M4. I know that now
> the communication protocol for RAP is JSON.
>
> I see the following error in Firebug often after 1.5 M4 migration-
> "Could not execute javascript: [ ]
> [Break On This Error] (no source for SyntaxError: JSON.parse)"
> It doesnt have any impact in the application. But just curious to know
> why does it come?
Re: 1.5M4 -SyntaxError: JSON.parse [message #771147 is a reply to message #768544] Mon, 26 December 2011 13:10 Go to previous messageGo to next message
Avrajit Chatterjee is currently offline Avrajit Chatterjee
Messages: 64
Registered: September 2011
Member
Hi,
I have started to use rap-runtime-1.5.0-N-20111222-0213 nightly build which shows the fix for JSON.parse.
But now I am facing a new issue. I am getting this error on the screen sometimes "Cannot begin a new event while another event is in progress by thread, UIThread"
This never used to come earlier when I was using 1.5M2. Please suggest.
Re: 1.5M4 -SyntaxError: JSON.parse [message #771467 is a reply to message #771147] Tue, 27 December 2011 10:39 Go to previous message
Avrajit Chatterjee is currently offline Avrajit Chatterjee
Messages: 64
Registered: September 2011
Member
I got the issue. It is coming from the glazedlist. Its not the RAP framework issue.
Previous Topic:Table themes
Next Topic:Using RWP for portlets
Goto Forum:
  


Current Time: Sat Oct 25 08:53:59 GMT 2014

Powered by FUDForum. Page generated in 0.08339 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software