Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » [Acceleo] disable java starter generation.
[Acceleo] disable java starter generation. [message #768446] Tue, 20 December 2011 06:57 Go to next message
urs zeidler is currently offline urs zeidler
Messages: 91
Registered: July 2009
Member
Is there a way of disabling the generation of the java starter class ?
I habe included the acceleo generator in ATLFlow and don't need a
seperated starter, as i start the generation in the transformation flow.

greetings, urs.
Re: [Acceleo] disable java starter generation. [message #769600 is a reply to message #768446] Thu, 22 December 2011 11:56 Go to previous messageGo to next message
Stephane Begaudeau is currently offline Stephane Begaudeau
Messages: 413
Registered: April 2010
Location: Nantes (France)
Senior Member

Hi,

[comment @main/] = refresh of the java launcher.
You can remove the comment of the template if you don't want Acceleo to refresh the Java class (but if you change the name of the main template or if you add a new metamodel, the Java class may not work anymore since it wouldn't have been regenerated).

Regards,

Stephane Begaudeau, Obeo

--
Twitter: @sbegaudeau & @acceleo
Google+: stephane.begaudeau & acceleo
Blog: http://stephanebegaudeau.tumblr.com
Acceleo Documentation: http://docs.obeonetwork.com/acceleo



Re: [Acceleo] disable java starter generation. [message #770784 is a reply to message #769600] Sun, 25 December 2011 10:11 Go to previous message
urs zeidler is currently offline urs zeidler
Messages: 16
Registered: July 2009
Junior Member
Am 22.12.2011 12:56, schrieb Stephane Begaudeau:
> Hi,
>
> [comment @main/] = refresh of the java launcher.
> You can remove the comment of the template if you don't want Acceleo to refresh the Java class (but if you change the name of the main template or if
> you add a new metamodel, the Java class may not work anymore since it wouldn't have been regenerated).
>
> Regards,
>
> Stephane Begaudeau, Obeo
>
> --
> Twitter: http://twitter.com/#!/sbegaudeau & http://twitter.com/#!/acceleo
> Google+: https://plus.google.com/u/0/105625286543794908607/ & https://plus.google.com/u/0/114651471803085159652/
> Blog: http://stephanebegaudeau.tumblr.com
> Acceleo Documentation: http://docs.obeonetwork.com/acceleo
Nice, worked as told.
Thanks and greetinigs, Urs.
Previous Topic:[Xpand] import issue
Next Topic:[workflow] run workflow error
Goto Forum:
  


Current Time: Fri Oct 24 15:36:57 GMT 2014

Powered by FUDForum. Page generated in 0.02221 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software