Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » OCL » Ecore2OCLInEcore problem referencing Classes in subpackages
Ecore2OCLInEcore problem referencing Classes in subpackages [message #768038] Mon, 19 December 2011 13:19 Go to next message
Wolfgang Kling is currently offline Wolfgang Kling
Messages: 4
Registered: December 2011
Junior Member
Hello everybody, I have a problem while passing from an Ecore file to the OCLInEcore textual version. The reference to elements in nested packages are not correctly resolved.

I have the following metamodel in Ecore

module _'Test.ecore'
package pkg : pkg = '/pkg/1.0'
{
	class Class extends pkg::subPkg::subsubPkg::SubSubpkgClass;
	package subPkg : subPkg = '/pkg/subPkg/1.0'
	{
		class SubpkgClass;
		package subsubPkg : subsubPkg = '/pkg/subPkg/subPkg/1.0'
		{
			class SubSubpkgClass;
		}
	}
}


When I open it with OCLInEcore it generates the following

module _'Test.ecore'
package pkg : pkg = '/pkg/1.0'
{
	class Class extends subsubPkg::SubSubpkgClass;
	package subPkg : subPkg = '/pkg/subPkg/1.0'
	{
		class SubpkgClass;
		package subsubPkg : subsubPkg = '/pkg/subPkg/subPkg/1.0'
		{
			class SubSubpkgClass;
		}
	}
}

Note the difference

Before
class Class extends pkg::subPkg::subsubPkg::SubSubpkgClass;

After
class Class extends subsubPkg::SubSubpkgClass;

From OCLInEcore to Ecore works correctly but not the other way.

Thank you for any help,
Re: Ecore2OCLInEcore problem referencing Classes in subpackages [message #768173 is a reply to message #768038] Mon, 19 December 2011 17:30 Go to previous messageGo to next message
Ed Willink is currently offline Ed Willink
Messages: 4046
Registered: July 2009
Senior Member
Hi Wolfgang

This looks like https://bugs.eclipse.org/bugs/show_bug.cgi?id=362620,
which is fixed in Juno M3, and for which a patch awaits review for
Indigo SR2.

Regards

Ed Willink



On 19/12/2011 13:20, Wolfgang Kling wrote:
> Hello everybody, I have a problem while passing from an Ecore file to
> the OCLInEcore textual version. The reference to elements in nested
> packages are not correctly resolved.
>
> I have the following metamodel in Ecore
>
>
> module _'Test.ecore'
> package pkg : pkg = '/pkg/1.0'
> {
> class Class extends pkg::subPkg::subsubPkg::SubSubpkgClass;
> package subPkg : subPkg = '/pkg/subPkg/1.0'
> {
> class SubpkgClass;
> package subsubPkg : subsubPkg = '/pkg/subPkg/subPkg/1.0'
> {
> class SubSubpkgClass;
> }
> }
> }
>
>
> When I open it with OCLInEcore it generates the following
>
>
> module _'Test.ecore'
> package pkg : pkg = '/pkg/1.0'
> {
> class Class extends subsubPkg::SubSubpkgClass;
> package subPkg : subPkg = '/pkg/subPkg/1.0'
> {
> class SubpkgClass;
> package subsubPkg : subsubPkg = '/pkg/subPkg/subPkg/1.0'
> {
> class SubSubpkgClass;
> }
> }
> }
>
> Note the difference
>
> Before
> class Class extends pkg::subPkg::subsubPkg::SubSubpkgClass;
>
> After
> class Class extends subsubPkg::SubSubpkgClass;
>
> From OCLInEcore to Ecore works correctly but not the other way.
> Thank you for any help,
Re: Ecore2OCLInEcore problem referencing Classes in subpackages [message #768695 is a reply to message #768173] Tue, 20 December 2011 16:13 Go to previous message
Wolfgang Kling is currently offline Wolfgang Kling
Messages: 4
Registered: December 2011
Junior Member
Ok, thanks for your quick answer.
Previous Topic:[Announce] Eclipse OCL CORE 4.0.0 (Juno) M4 is now available
Next Topic:OCL rules
Goto Forum:
  


Current Time: Fri Sep 19 01:51:28 GMT 2014

Powered by FUDForum. Page generated in 0.01995 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software