Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Platform » Is os.version>=10.7 legal in osgi platform filter?
Is os.version>=10.7 legal in osgi platform filter? [message #767291] Sat, 17 December 2011 15:17 Go to next message
h1055071 is currently offline h1055071
Messages: 335
Registered: July 2009
Senior Member
I have a plug-in fragment that should only run on Mac OS X Lion version 10.7 or greater.

I have set the platform filter in the manifest as follows:

Eclipse-PlatformFilter: (&(osgi.ws=cocoa)(os.version>=10.7))

This certainly seems to work when launching on different platforms and OS versions. However, in the Launch configuration setup dialog when I click "Validate Plug-ins" on the "Plug-ins" tab there is a reported error:

The following problems were detected:
Platform filter did not match: (&(osgi.ws=cocoa)(os.version>=10.7))

I am running it on a Mac with the correct version. The offending part seems to be "os.version>=10.7". And yet in practice this works.

Is this the correct way to specify a minimum OS version for a filter?

Thanks in advance.
Re: Is os.version>=10.7 legal in osgi platform filter? [message #772673 is a reply to message #767291] Fri, 30 December 2011 10:34 Go to previous message
h1055071 is currently offline h1055071
Messages: 335
Registered: July 2009
Senior Member
See http://www.eclipse.org/forums/index.php/m/772670/#msg_772670
Previous Topic:JVM crash on linux with Eclipse 3.7.1
Next Topic:Eclipse does not save changes to run configurations. Any clue?
Goto Forum:
  


Current Time: Sun Oct 26 06:09:38 GMT 2014

Powered by FUDForum. Page generated in 0.01526 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software