Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » AM3 » Error while installing AM3(Hi I get the following error while installing AM3 on Ec)
Error while installing AM3 [message #766779] Fri, 16 December 2011 07:22 Go to next message
Sangeeta Tripathy is currently offline Sangeeta Tripathy
Messages: 16
Registered: December 2011
Junior Member
Hi, Please help me urgently on this issue as I am in last stage of development and am stuck Shocked

I have to use an XML injector/extractor and am trying to install AM3 plugins / features on an Eclipse Helios version 3.6.0. But the following 4 errors are generated. (See below for errors). The AM3 perspective is loading and injection/extraction is working, but I am not able to compile any ATL files due to a CompilerNotFoundException.

My environment is:
Eclipse Helios version 3.6.0., with ATL plugins installed successfully.
I am working on a machine with firewall settings and uses proxy authentication/configuration script to connect to the Internet.

I have copied the AM3 plugin files/folders into dropins/folder/plugins and AM3 features into dropins/folder/features.

Do let me know a solution as soon as possible, thank you.

ERRORS:

ERROR 1--- eclipse.buildId=I20100527-1700
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.modeling.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.modeling.product -clean


Warning
Fri Dec 16 17:33:42 IST 2011
Http error retrieving service message: Proxy Authentication Required



ERROR 2---eclipse.buildId=I20100527-1700
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.modeling.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.modeling.product -clean


Error
Fri Dec 16 17:33:02 IST 2011
The artifact file for osgi.bundle,org.atl.eclipse.adt.builder,2.0.0 was not found.

ERROR 3----eclipse.buildId=I20100527-1700
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.modeling.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.modeling.product -clean


Error
Fri Dec 16 17:33:02 IST 2011
session context was:(profile=epp.package.modeling, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.atl.eclipse.adt.builder 2.0.0, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).

ERROR 4---eclipse.buildId=I20100527-1700
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.modeling.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.modeling.product -clean


OK
Fri Dec 16 17:32:53 IST 2011
The -clean (osgi.clean) option was not successful. Unable to clean the storage area: D:\Eclipse\eclipse-modeling-helios-RC3-incubation-win32\eclipse\configuration\org.eclipse.osgi
Re: Error while installing AM3 [message #766798 is a reply to message #766779] Fri, 16 December 2011 07:53 Go to previous messageGo to next message
Guillaume Doux is currently offline Guillaume Doux
Messages: 56
Registered: July 2009
Member
Hello,

Which version of AM3 are you trying to use and for which purpose ?

It seems that you are using the old AM3 which is now deprecated and which have dependencies to ATL 2.0

* Error
Fri Dec 16 17:33:02 IST 2011
The artifact file for osgi.bundle,org.atl.eclipse.adt.builder,2.0.0 was not found.


The problem is that the version of ATL on Eclipse 3.6 is 3.x and so you do not have the right dependencies.

Instead of using this plugin, you should use this one https://dev.eclipse.org/svnroot/modeling/org.eclipse.mdt.modisco/incubation/trunk/am3/plugins/trunk/org.eclipse.m2m.atl.projectors.xml/

Which is compliant with ATL 3.0 and with the new ANT tasks. You will need to get the plugin jar from the sources.

Best regards,

Guillaume
Re: Error while installing AM3 [message #766826 is a reply to message #766798] Fri, 16 December 2011 08:52 Go to previous message
Sangeeta Tripathy is currently offline Sangeeta Tripathy
Messages: 16
Registered: December 2011
Junior Member
Hi, Guillaume, thanks for the prompt reply. I am using AM3_2.0RC2 but the Eclipse Helios is RC3, so you are right. But please tell me how to create/get the jar file from the link you mentioned. Do I have to download all the files and create the jar? sorry, I am new to eclipse/atl/am3.
Previous Topic:installing KM3
Next Topic:How to create binaries of new AM3 source files
Goto Forum:
  


Current Time: Thu Apr 24 01:50:51 EDT 2014

Powered by FUDForum. Page generated in 0.03023 seconds