Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Jubula » AUTs Agent code(Is there a location for AUTs Agent code I can get)
AUTs Agent code [message #766469] Thu, 15 December 2011 21:05 Go to next message
Carl Bader is currently offline Carl Bader
Messages: 15
Registered: November 2011
Junior Member
I am looking for a package that will allow me to install the remote AUT agent code so I can test on multiple platforms with installing the Jubula package on that platform.

I have only seen the AUT agent in the standalone installation package.

Can someone point at a download site or tell how to pull the AUT agent out of the standalone installation to install on a remote platform so I can test against it.

I am trying to test on the following platforms.

OracleLinux 64bit
RHEL5 64bit
RHEL6 64bit

There isn't a Standalone Jubula version for 64bit Linux so far.

This would be testing rcp plug-in application.

[Updated on: Thu, 15 December 2011 22:19]

Report message to a moderator

Re: AUTs Agent code [message #766759 is a reply to message #766469] Fri, 16 December 2011 11:21 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra Schladebeck
Messages: 1155
Registered: July 2009
Senior Member
Hi,

The standalone package is currently the only way to install the remote AUT Agent. You can select just to install the Agent component.

The standalone 32 bit should also run on a 64 bit machine, as long as 32-bit libraries are also installed.

HTH,
Alex

Re: AUTs Agent code [message #766863 is a reply to message #766759] Fri, 16 December 2011 15:13 Go to previous messageGo to next message
Carl Bader is currently offline Carl Bader
Messages: 15
Registered: November 2011
Junior Member
Thank you for the reply I really appreciate the help, can you tell me which 32bit libraries are required to run the AUT Agent on a 64bit linux environment please?

I am not a linux person and this is new to me.

Is there a place that talks about that you can just install the AUT Agent separately in the docs?

[Updated on: Fri, 16 December 2011 15:17]

Report message to a moderator

Re: AUTs Agent code [message #769735 is a reply to message #766863] Thu, 22 December 2011 16:00 Go to previous messageGo to next message
Carl Bader is currently offline Carl Bader
Messages: 15
Registered: November 2011
Junior Member
So interesting that no one has commented on which 32 bit drivers are needed for running the AUT agent on a 64 bit Linux system. Does that mean there is no one running any Jubula tests on a 64 bit linux system? I would not like to install more libraries than are necessary so some help please.

Sad
Re: AUTs Agent code [message #769772 is a reply to message #769735] Thu, 22 December 2011 16:49 Go to previous messageGo to next message
Achim Loerke is currently offline Achim Loerke
Messages: 338
Registered: July 2009
Location: Braunschweig, Germany
Senior Member

The only way to do this is by just trying. There are dozens of dependencies just for the GTK libs alone. In our experience most 64bit systems will support 32bit applications if not told otherwise during installation.

If you excluded 32bit support during OS setup you're on your own.

Achim

Re: AUTs Agent code [message #775371 is a reply to message #769772] Thu, 05 January 2012 21:18 Go to previous message
Carl Bader is currently offline Carl Bader
Messages: 15
Registered: November 2011
Junior Member

I didn't notice during my installation of the RedHat that is was a possibility, again I am not a Linux person. I will rerun the installation and see if it is an option.

With all the developers and testers using Jubula, I can't believe that a 64 bit standalone AUTAGENT version is not provided to test those Operating Systems. It seems like that would open up a very large pool of opertunities. IMHO
Previous Topic:Object recognition across platforms
Next Topic:conditionial testing
Goto Forum:
  


Current Time: Tue Sep 30 18:09:10 GMT 2014

Powered by FUDForum. Page generated in 0.02004 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software