Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Orbit » org.w3c.dom.svg broken in Eclipse 3.7?
org.w3c.dom.svg broken in Eclipse 3.7? [message #766391] Thu, 15 December 2011 17:39 Go to next message
Thorsten Meinl is currently offline Thorsten Meinl
Messages: 85
Registered: July 2009
Member
Hi all,

We are using the org.w3c.dom.svg plug-in from Orbit in our project. This
requires org.w3c.dom.smil in version 1.0.0. This works perfectly fine in
Eclipse 3.6. Now, if I use the very same plug-ins in Eclipse 3.7 it
complains (either during validation in the "Plug-ins" tab of a run
configuration or during startup) that it cannot resolve org.w3c.dom.svg
because the dependecy org.w3c.dom.smil_0.0.0 is missin. But it is
actually there. What I find a bit suspicious is that the complaint does
not contain the version range defined in the MANIFEST.MF but simply
0.0.0. Since all that changed is the Eclipse version, it seem that
Eclipse 3.7 has broken something. Does anyone have an idea?

It is very easy to reproduce: just create a new launch configuration and
select only the org.w3c.dom.svg and org.w3c.dom.smil Plug-ins. Even if
you all all required plug-ins validation still fails. On the source code
level, i.e. when using them in projects everything is fine.

Cheers,

Thorsten
Re: org.w3c.dom.svg broken in Eclipse 3.7? [message #766466 is a reply to message #766391] Thu, 15 December 2011 20:54 Go to previous messageGo to next message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
On 12/15/2011 12:39 PM, Thorsten Meinl wrote:
> Since all that changed is the Eclipse version, it seem that
> Eclipse 3.7 has broken something. Does anyone have an idea?
>

Or ... maybe Eclipse fixed something? :) (That then exposed a bug in
some Orbit bundles.)

I bet you are are still using "the old" versions of the orbit bundles?

See
https://bugs.eclipse.org/bugs/show_bug.cgi?id=358542

but in short, be sure to use one of the "new" versions, from
http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/
which then should "match" the fixed functionality in 3.7.
Re: org.w3c.dom.svg broken in Eclipse 3.7? [message #766485 is a reply to message #766466] Thu, 15 December 2011 21:39 Go to previous messageGo to next message
Thorsten Meinl is currently offline Thorsten Meinl
Messages: 85
Registered: July 2009
Member
Yes, this seems to fix it. I'm not sure where the old version came from
in the first place, but explicitly requiring while creating the target
platform the new version fixes everything. Thanks for the hint!

Am 15.12.2011 21:54, schrieb David Williams:
> On 12/15/2011 12:39 PM, Thorsten Meinl wrote:
>> Since all that changed is the Eclipse version, it seem that
>> Eclipse 3.7 has broken something. Does anyone have an idea?
>>
>
> Or ... maybe Eclipse fixed something? :) (That then exposed a bug in
> some Orbit bundles.)
>
> I bet you are are still using "the old" versions of the orbit bundles?
>
> See
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=358542
>
> but in short, be sure to use one of the "new" versions, from
> http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/
> which then should "match" the fixed functionality in 3.7.
>
>
>
Re: org.w3c.dom.svg broken in Eclipse 3.7? [message #766653 is a reply to message #766485] Fri, 16 December 2011 07:46 Go to previous messageGo to next message
Thorsten Meinl is currently offline Thorsten Meinl
Messages: 85
Registered: July 2009
Member
Am 15.12.2011 22:39, schrieb Thorsten Meinl:
> Yes, this seems to fix it. I'm not sure where the old version came from
> in the first place, but explicitly requiring while creating the target
> platform the new version fixes everything. Thanks for the hint!
Ah, now I know. Birt 2.6.2 brings the old version with it. Bummer...
Re: org.w3c.dom.svg broken in Eclipse 3.7? [message #767036 is a reply to message #766653] Fri, 16 December 2011 22:30 Go to previous message
David Williams is currently offline David Williams
Messages: 176
Registered: July 2009
Senior Member
On 12/16/2011 02:46 AM, Thorsten Meinl wrote:
> Am 15.12.2011 22:39, schrieb Thorsten Meinl:
>> Yes, this seems to fix it. I'm not sure where the old version came from
>> in the first place, but explicitly requiring while creating the target
>> platform the new version fixes everything. Thanks for the hint!
> Ah, now I know. Birt 2.6.2 brings the old version with it. Bummer...
They should have an update for "Indigo" (3.7 platform). If you can
upgrade to that level. You should have

http://download.eclipse.org/releases/indigo/

built-in to your 3.7 environment. Of course, then you might run into other
issues or incompatibilities (updating directly from 3.6 stuff to 3.7
stuff from the repo should work in theory, but its usually discouraged,
since no one tests it.

Or, you could try fresh all-in-one install for
Eclipse IDE for Java and Report Developers
at
www.eclipse.org/downloads


Good luck,
Previous Topic:org.slf4j.log4j
Next Topic:GWT missing requirement
Goto Forum:
  


Current Time: Sun Oct 26 03:53:18 GMT 2014

Powered by FUDForum. Page generated in 0.02304 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software