Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Equinox » Issue with Jetty 7 upgrade because Equinox SDK 3.7.1 includes old Jetty libs - version 6.1.23 (The last released Equinox SDK 3.7.1 contains references to the not latest Jetty version)
Issue with Jetty 7 upgrade because Equinox SDK 3.7.1 includes old Jetty libs - version 6.1.23 [message #765637] Wed, 14 December 2011 12:32 Go to next message
Dmitry Ogievich is currently offline Dmitry OgievichFriend
Messages: 2
Registered: December 2011
Junior Member
Hi,

On the current project we are using Equinox 3.6 and Jetty 6.1.23. So we decided to upgrade Equinox up to version 3.7.1 (latest release) and Jetty up to version 7.5.1 (latest release).

During the Equinox upgrade we noticed that bundle 'org.eclipse.equinox.http.jetty' contains references to the old Jetty libs of version 6.1.23 (org.mortbay.*) which were removed in Jetty 7.5.1.
Such restriction prevents us to upgrade Jetty.

Does anyone faced with such situation? Probably there is updated 'org.eclipse.equinox.http.jetty' lib for Equinox 3.7.1 compatible with Jetty 7.5.1 somewhere? I will highly appreciate if someone could provide the link to download such lib version if it exists?

Thanks in advance.
Re: Issue with Jetty 7 upgrade because Equinox SDK 3.7.1 includes old Jetty libs - version 6.1.23 [message #765679 is a reply to message #765637] Wed, 14 December 2011 14:16 Go to previous messageGo to next message
Thomas Watson is currently offline Thomas WatsonFriend
Messages: 437
Registered: July 2009
Senior Member
Unfortunately Equinox did not upgrade to support jetty 7. I think the eclipse jetty project does have some support for the http service with jetty 7 so you may have some luck finding support there. For the Juno release Equinox is upgrading to jetty 8 and servlet 3.0.

Tom.
Re: Issue with Jetty 7 upgrade because Equinox SDK 3.7.1 includes old Jetty libs - version 6.1.23 [message #765771 is a reply to message #765679] Wed, 14 December 2011 16:52 Go to previous messageGo to next message
Dmitry Ogievich is currently offline Dmitry OgievichFriend
Messages: 2
Registered: December 2011
Junior Member
Thank you for the quick reply, Thomas!
Will try to ask the same question within 'jetty-dev' mailing list.
Re: Issue with Jetty 7 upgrade because Equinox SDK 3.7.1 includes old Jetty libs - version 6.1.23 [message #766729 is a reply to message #765637] Fri, 16 December 2011 10:29 Go to previous message
Ivan Larionov is currently offline Ivan LarionovFriend
Messages: 37
Registered: July 2009
Member
Hi

It is not apparent to me what you need: whether a target platform or an
IDE. I have been using eclipse 3.7 and jetty 7 together to host web
applications as well as to use HttpService. So, if you were talking
about the target platform I could give some details. You might want to
look at the target platform I use, in this case you should see the
attachment.


On 14.12.2011 14:32, Dmitry Ogievich wrote:
> Hi,
>
> On the current project we are using Equinox 3.6 and Jetty 6.1.23. So we
> decided to upgrade Equinox up to version 3.7.1 (latest release) and
> Jetty up to version 7.5.1 (latest release).
>
> During the Equinox upgrade we noticed that bundle
> 'org.eclipse.equinox.http.jetty' contains references to the old Jetty
> libs of version 6.1.23 (org.mortbay.*) which were removed in Jetty 7.5.1.
> Such restriction prevents us to upgrade Jetty.
>
> Does anyone faced with such situation? Probably there is updated
> 'org.eclipse.equinox.http.jetty' lib for Equinox 3.7.1 compatible with
> Jetty 7.5.1 somewhere? I will highly appreciate if someone could provide
> the link to download such lib version if it exists?
>
> Thanks in advance.
  • Attachment: jetty7.png
    (Size: 25.65KB, Downloaded 128 times)
Previous Topic:How to install framework extension?
Next Topic:Using @annotations to define Declarative Services components
Goto Forum:
  


Current Time: Wed Nov 26 16:42:24 GMT 2014

Powered by FUDForum. Page generated in 0.02151 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software