Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Missing Constraint:... org.apache.lucene; bundle-version=[1.9.0;2.0.0)
Missing Constraint:... org.apache.lucene; bundle-version=[1.9.0;2.0.0) [message #761669] Tue, 06 December 2011 15:54 Go to next message
js Missing name is currently offline js Missing name
Messages: 73
Registered: July 2009
Member
I am trying to upgrade my rcp application to use the indigo 3.7 libraries.
I have a prouduct based on features but when I try to export the product I
get:

org.eclipse.datatols.sqltools.result
-> Missing Constraint: Require-Bundle: org.apache.lucene;
bundle-version=[1.9.0;2.0.0)

In my product feature I include:

org.eclipse.datatools.sqldevtools.feature, version
1.9.1.v201108301820-7N847CFDsn0VdrPUJvPUshDWIPJ0

which include:

org.eclipse.datatools.sqldevtools.results.feature, version
1.9.1.v201108301820-57B4AkF7AJ7NCBBMBL

One of the bundles this feature delivers is:

org.apache.lucene, version: 1.9.1.v201101211617


On my target platform I have both:

org.apache.lucene, version: 1.9.1.v201101211617
org.apache.lucene, version: 2.9.1.v201101211721

I have tried to uncheck:

org.apache.lucene, version: 2.9.1.v201101211721

but it has no effect. Any ideas?
Re: Missing Constraint:... org.apache.lucene; bundle-version=[1.9.0;2.0.0) [message #762159 is a reply to message #761669] Wed, 07 December 2011 11:23 Go to previous message
Paul Webster is currently offline Paul Webster
Messages: 6859
Registered: July 2009
Location: Ottawa
Senior Member

Are you using any of the 3.7 org.eclipse.help bundles? Or consuming eclipse using the org.eclipse.rcp feature? Or do you specify the RCP workbench using your own base feature?

PW


Previous Topic:Get Plugin-Version String from within eclipse
Next Topic:Menu accelerators not always active
Goto Forum:
  


Current Time: Fri Aug 01 18:30:13 EDT 2014

Powered by FUDForum. Page generated in 0.05267 seconds