Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BIRT » Problem when starting birt platform (migrating to birt 3.7)
Problem when starting birt platform (migrating to birt 3.7) [message #761061] Mon, 05 December 2011 20:44 Go to next message
Anton is currently offline AntonFriend
Messages: 23
Registered: July 2009
Junior Member
I am trying to migrate my birt application to 3.7. I have read this guide

http://www.eclipse.org/birt/phoenix/project/notable3.7.php

added the runtime (approx 11 MB) lib to my project (everything compiles
fine) and changed my engine code to:

try {
designConfig = new DesignConfig();
// designConfig.setProperty("BIRT_HOME", path);
Platform.startup(designConfig);
// Platform.startup();

IDesignEngineFactory designFactory = (IDesignEngineFactory)
Platform.createFactoryObject(IDesignEngineFactory.EXTENSION_DESIGN_ENGINE_FACTORY);
IDesignEngine designEngine = designFactory.createDesignEngine(designConfig);
session = designEngine.newSessionHandle(ULocale.ENGLISH);
} catch (Exception e) {
logEngineError(e);
}


Doing this:

Platform.startup(designConfig);

gives:

java.lang.NoClassDefFoundError: org/eclipse/core/runtime/CoreException
at
org.eclipse.birt.core.framework.Platform.createPlatformLauncher(Platform.java:115)

Not starting the Platform results in the below designFactory being null:

IDesignEngineFactory designFactory = (IDesignEngineFactory)
Platform.createFactoryObject(IDesignEngineFactory.EXTENSION_DESIGN_ENGINE_FACTORY);

Any ideas on how the new pattern should be implemented - its seems that its
not enough to simply change:

designConfig = new DesignConfig();
designConfig.setProperty("BIRT_HOME", path);

to :

designConfig = new DesignConfig();

?
Re: Problem when starting birt platform (migrating to birt 3.7) [message #761072 is a reply to message #761061] Mon, 05 December 2011 21:03 Go to previous messageGo to next message
Jason Weathersby is currently offline Jason WeathersbyFriend
Messages: 9167
Registered: July 2009
Senior Member

Do you have all the jars from the runtime/ReportEngine/lib directory or
just the BIRT one?

Jason

On 12/5/2011 3:44 PM, Anton wrote:
> I am trying to migrate my birt application to 3.7. I have read this guide
>
> http://www.eclipse.org/birt/phoenix/project/notable3.7.php
>
> added the runtime (approx 11 MB) lib to my project (everything compiles
> fine) and changed my engine code to:
>
> try {
> designConfig = new DesignConfig();
> // designConfig.setProperty("BIRT_HOME", path);
> Platform.startup(designConfig);
> // Platform.startup();
>
> IDesignEngineFactory designFactory = (IDesignEngineFactory)
> Platform.createFactoryObject(IDesignEngineFactory.EXTENSION_DESIGN_ENGINE_FACTORY);
>
> IDesignEngine designEngine =
> designFactory.createDesignEngine(designConfig);
> session = designEngine.newSessionHandle(ULocale.ENGLISH);
> } catch (Exception e) {
> logEngineError(e);
> }
>
>
> Doing this:
>
> Platform.startup(designConfig);
>
> gives:
>
> java.lang.NoClassDefFoundError: org/eclipse/core/runtime/CoreException
> at
> org.eclipse.birt.core.framework.Platform.createPlatformLauncher(Platform.java:115)
>
>
> Not starting the Platform results in the below designFactory being null:
>
> IDesignEngineFactory designFactory = (IDesignEngineFactory)
> Platform.createFactoryObject(IDesignEngineFactory.EXTENSION_DESIGN_ENGINE_FACTORY);
>
>
> Any ideas on how the new pattern should be implemented - its seems that
> its not enough to simply change:
>
> designConfig = new DesignConfig();
> designConfig.setProperty("BIRT_HOME", path);
>
> to :
>
> designConfig = new DesignConfig();
>
> ?
>
>
Re: Problem when starting birt platform (migrating to birt 3.7) [message #761087 is a reply to message #761072] Mon, 05 December 2011 21:42 Go to previous messageGo to next message
Anton is currently offline AntonFriend
Messages: 23
Registered: July 2009
Junior Member
I am currently working on adding them one by one to minimize the size of my
application. The wierd thing is that the :

org.eclipse.birt.runtime_3.7.1.v20110913-1734.jar

included in the lib folder in the runtime does NOT contain the
CoreException:

org/eclipse/core/runtime/CoreException

Instead I have tried to add:

<dependency>
<groupId>org.eclipse.core</groupId>
<artifactId>org.eclipse.core.runtime</artifactId>
<version>3.6.0.v20100505</version>
<type>jar</type>
<scope>compile</scope>
</dependency>

That fixes that error even though the class is not located in that jar
either. Any ideas on which jar actually contains the CoreException from the
3.7.1 libs?







"Jason Weathersby" wrote in message news:jbjbj5$t2v$2@news.eclipse.org...

Do you have all the jars from the runtime/ReportEngine/lib directory or
just the BIRT one?

Jason

On 12/5/2011 3:44 PM, Anton wrote:
> I am trying to migrate my birt application to 3.7. I have read this guide
>
> http://www.eclipse.org/birt/phoenix/project/notable3.7.php
>
> added the runtime (approx 11 MB) lib to my project (everything compiles
> fine) and changed my engine code to:
>
> try {
> designConfig = new DesignConfig();
> // designConfig.setProperty("BIRT_HOME", path);
> Platform.startup(designConfig);
> // Platform.startup();
>
> IDesignEngineFactory designFactory = (IDesignEngineFactory)
> Platform.createFactoryObject(IDesignEngineFactory.EXTENSION_DESIGN_ENGINE_FACTORY);
>
> IDesignEngine designEngine =
> designFactory.createDesignEngine(designConfig);
> session = designEngine.newSessionHandle(ULocale.ENGLISH);
> } catch (Exception e) {
> logEngineError(e);
> }
>
>
> Doing this:
>
> Platform.startup(designConfig);
>
> gives:
>
> java.lang.NoClassDefFoundError: org/eclipse/core/runtime/CoreException
> at
> org.eclipse.birt.core.framework.Platform.createPlatformLauncher(Platform.java:115)
>
>
> Not starting the Platform results in the below designFactory being null:
>
> IDesignEngineFactory designFactory = (IDesignEngineFactory)
> Platform.createFactoryObject(IDesignEngineFactory.EXTENSION_DESIGN_ENGINE_FACTORY);
>
>
> Any ideas on how the new pattern should be implemented - its seems that
> its not enough to simply change:
>
> designConfig = new DesignConfig();
> designConfig.setProperty("BIRT_HOME", path);
>
> to :
>
> designConfig = new DesignConfig();
>
> ?
>
>
Re: Problem when starting birt platform (migrating to birt 3.7) [message #761089 is a reply to message #761087] Mon, 05 December 2011 21:46 Go to previous message
Anton is currently offline AntonFriend
Messages: 23
Registered: July 2009
Junior Member
Found it in :

org.eclipse.equinox.common_3.6.0.v20110523.jar

which is included when including the 3.6.0 version of the o.e.c.runtime.



"Anton" wrote in message news:jbjdst$1v8$1@news.eclipse.org...

I am currently working on adding them one by one to minimize the size of my
application. The wierd thing is that the :

org.eclipse.birt.runtime_3.7.1.v20110913-1734.jar

included in the lib folder in the runtime does NOT contain the
CoreException:

org/eclipse/core/runtime/CoreException

Instead I have tried to add:

<dependency>
<groupId>org.eclipse.core</groupId>
<artifactId>org.eclipse.core.runtime</artifactId>
<version>3.6.0.v20100505</version>
<type>jar</type>
<scope>compile</scope>
</dependency>

That fixes that error even though the class is not located in that jar
either. Any ideas on which jar actually contains the CoreException from the
3.7.1 libs?







"Jason Weathersby" wrote in message news:jbjbj5$t2v$2@news.eclipse.org...

Do you have all the jars from the runtime/ReportEngine/lib directory or
just the BIRT one?

Jason

On 12/5/2011 3:44 PM, Anton wrote:
> I am trying to migrate my birt application to 3.7. I have read this guide
>
> http://www.eclipse.org/birt/phoenix/project/notable3.7.php
>
> added the runtime (approx 11 MB) lib to my project (everything compiles
> fine) and changed my engine code to:
>
> try {
> designConfig = new DesignConfig();
> // designConfig.setProperty("BIRT_HOME", path);
> Platform.startup(designConfig);
> // Platform.startup();
>
> IDesignEngineFactory designFactory = (IDesignEngineFactory)
> Platform.createFactoryObject(IDesignEngineFactory.EXTENSION_DESIGN_ENGINE_FACTORY);
>
> IDesignEngine designEngine =
> designFactory.createDesignEngine(designConfig);
> session = designEngine.newSessionHandle(ULocale.ENGLISH);
> } catch (Exception e) {
> logEngineError(e);
> }
>
>
> Doing this:
>
> Platform.startup(designConfig);
>
> gives:
>
> java.lang.NoClassDefFoundError: org/eclipse/core/runtime/CoreException
> at
> org.eclipse.birt.core.framework.Platform.createPlatformLauncher(Platform.java:115)
>
>
> Not starting the Platform results in the below designFactory being null:
>
> IDesignEngineFactory designFactory = (IDesignEngineFactory)
> Platform.createFactoryObject(IDesignEngineFactory.EXTENSION_DESIGN_ENGINE_FACTORY);
>
>
> Any ideas on how the new pattern should be implemented - its seems that
> its not enough to simply change:
>
> designConfig = new DesignConfig();
> designConfig.setProperty("BIRT_HOME", path);
>
> to :
>
> designConfig = new DesignConfig();
>
> ?
>
>
Previous Topic:what is the system id of the report design?
Next Topic:Can Java and BIRT use same Oracle database session connection
Goto Forum:
  


Current Time: Wed Nov 26 04:30:29 GMT 2014

Powered by FUDForum. Page generated in 0.01652 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software