Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » Android dev: NoClassDefFoundError on one machine but not another(Can't find external classes after multiple reinstalls of environment)
Android dev: NoClassDefFoundError on one machine but not another [message #759645] Tue, 29 November 2011 13:11
IZ  is currently offline IZ
Messages: 3
Registered: November 2011
Junior Member
I've run into a bizarre problem. I am doing Android development in Eclipse. I created a toy Android project and then added an external JAR to the project. The idea was to test using classes from that external JAR in the Android app. No errors are reported at build time. However, when I run the app either in emulator or on an actual device, I get a java.lang.NoClassDefFoundError exception for all classes from the external JAR. I reinstalled the whole environment more than once, including Eclipse, Android plugin, Android SDK and Java but I still get this error. When I installed what appears to be the identical environment on a different computer, it worked fine there. However, I want to do my development on the 1st machine, so I've been trying to figure what's wrong. Something on my main machine seems to be out of whack but I can't figure out what. Going insane here!!! Smile Can you help? Thanks much!
Previous Topic:Template for try/catch block
Next Topic:HELPPPP :(
Goto Forum:
  


Current Time: Thu Oct 23 05:26:47 GMT 2014

Powered by FUDForum. Page generated in 0.02034 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software