Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Subversive » 0.7.9.I20111119-1700 is broken
0.7.9.I20111119-1700 is broken [message #758272] Tue, 22 November 2011 14:20 Go to next message
Lars Sonchocky-Helldorf is currently offline Lars Sonchocky-HelldorfFriend
Messages: 13
Registered: July 2009
Junior Member
Hi,

after updating to 0.7.9.I20111119-1700 today I get Exceptions everywhere which all boil down to:

Caused by: java.lang.NoSuchFieldError: INSTANCE
at org.eclipse.team.svn.core.SVNTeamPlugin.getPreferences(SVNTeamPlugin.java:141)
at org.eclipse.team.svn.core.svnstorage.AbstractSVNStorage.initialize(AbstractSVNStorage.java:500)
at org.eclipse.team.svn.core.operation.file.SVNFileStorage.initialize(SVNFileStorage.java:63)
at org.eclipse.team.svn.core.SVNTeamPlugin.start(SVNTeamPlugin.java:161)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)
... 74 more

I opened a bug report for this:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=364464

hopefully somebody sees this and fixes it!
Re: 0.7.9.I20111119-1700 is broken [message #758456 is a reply to message #758272] Wed, 23 November 2011 10:56 Go to previous messageGo to next message
Tom Chiverton is currently offline Tom ChivertonFriend
Messages: 26
Registered: August 2010
Junior Member
Snap, all SVN operations are broken since this mornings update.

Is there anyway to roll back the update ?

[update: yes, being worked on, I will post here when it's ready]

[Updated on: Wed, 23 November 2011 12:43]

Report message to a moderator

Re: 0.7.9.I20111119-1700 is broken [message #758500 is a reply to message #758456] Wed, 23 November 2011 13:24 Go to previous message
Tom Chiverton is currently offline Tom ChivertonFriend
Messages: 26
Registered: August 2010
Junior Member
Fix: add http://download.eclipse.org/technology/subversive/0.7/update-site/ as a new update site, check for and apply updates. Remove the site after you are done unless you already had it.
Previous Topic:JavaHL connector for SVN 1.7
Next Topic:Team -> Share Project is not working for some projects
Goto Forum:
  


Current Time: Sat Dec 20 16:38:07 GMT 2014

Powered by FUDForum. Page generated in 0.01992 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software