Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » Java Development Tools (JDT) » How to Resolve JDT Conflicting Dependencies?
How to Resolve JDT Conflicting Dependencies? [message #757647] Mon, 21 November 2011 03:52 Go to next message
Ari  is currently offline Ari
Messages: 1
Registered: November 2011
Junior Member
Does anyone know how to resolve the following dependency conflict?

Quote:
Cannot complete the install because of a conflicting dependency.
Software being installed: SpringSource Tool Suite Grails Support 2.8.0.201110171000-RELEASE (com.springsource.sts.grails.feature.group 2.8.0.201110171000-RELEASE)
Software currently installed: Shared profile 1.0.0.1316139734506 (SharedProfile_epp.package.jee 1.0.0.1316139734506)
Only one of the following can be installed at once:
Java Development Tools Core 3.7.1.xx-20110929-1800-e37 (org.eclipse.jdt.core 3.7.1.xx-20110929-1800-e37)
Java Development Tools Core 3.7.0.v_B61 (org.eclipse.jdt.core 3.7.0.v_B61)
Java Development Tools Core 3.7.1.v_B76_R37x (org.eclipse.jdt.core 3.7.1.v_B76_R37x)
Object Teams Development Tooling Core 3.7.0.v_OTDT_r200_201106070730 (org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730)
Object Teams Development Tooling Core 3.7.1.v_OTDT_r201_201109101025 (org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025)
Cannot satisfy dependency:
From: Shared profile 1.0.0.1316139734506 (SharedProfile_epp.package.jee 1.0.0.1316139734506)
To: org.eclipse.jdt.core [3.7.1.v_B76_R37x]
Cannot satisfy dependency:
From: Shared profile 1.0.0.1316139734506 (SharedProfile_epp.package.jee 1.0.0.1316139734506)
To: org.eclipse.jdt.feature.group [3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK]
Cannot satisfy dependency:
From: SpringSource Tool Suite Grails Support 2.8.0.201110171000-RELEASE (com.springsource.sts.grails.feature.group 2.8.0.201110171000-RELEASE)
To: org.codehaus.groovy.eclipse.feature.feature.group 2.0.0
Cannot satisfy dependency:
From: Groovy-Eclipse Feature 2.5.2.xx-20110929-1800-e37 (org.codehaus.groovy.eclipse.feature.feature.group 2.5.2.xx-20110929-1800-e37)
To: org.codehaus.groovy.jdt.patch.feature.group [2.5.2.xx-20110929-1800-e37]
Cannot satisfy dependency:
From Patch: org.codehaus.groovy.jdt.patch.feature.group 2.5.2.xx-20110929-1800-e37 Eclipse Java Development Tools 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK (org.eclipse.jdt.feature.group 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK)
To: org.eclipse.jdt.core [3.7.1.xx-20110929-1800-e37]
Re: How to Resolve JDT Conflicting Dependencies? [message #759242 is a reply to message #757647] Mon, 28 November 2011 02:09 Go to previous message
Andrew Eisenberg is currently offline Andrew Eisenberg
Messages: 368
Registered: July 2009
Senior Member
You are trying to install groovy-eclipse into a read-only directory (this includes c:\program files on windows). You must move your eclipse installation to a writable location or give the current user write access.
Previous Topic:Remote Debugging
Next Topic:-----------------------
Goto Forum:
  


Current Time: Thu Oct 23 06:41:16 GMT 2014

Powered by FUDForum. Page generated in 0.02109 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software