Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Eclipse Process Manager (Stardust) » NullPointerException during first login in on Weblogic(Exception initSessionInfo in Weblogic SessionHelper)
NullPointerException during first login in on Weblogic [message #757518] Fri, 18 November 2011 18:02 Go to next message
Jan Hendrik Scheufen is currently offline Jan Hendrik Scheufen
Messages: 61
Registered: October 2011
Member

Hi,

I'm deploying Stardust in EJB mode and packaged as EAR on Weblogic 10.3. When trying to access the web application in a browser, the log shows the following exception:

java.lang.NullPointerException
                at weblogic.servlet.internal.ServletRequestImpl$SessionHelper.initSessionInfo(ServletRequestImpl.java:2611)
                at weblogic.servlet.internal.ServletRequestImpl$SessionHelper.getSessionInternal(ServletRequestImpl.java:2379)
                at weblogic.servlet.internal.ServletRequestImpl$SessionHelper.getSession(ServletRequestImpl.java:2369)
                at weblogic.servlet.internal.ServletRequestImpl.getSession(ServletRequestImpl.java:1285)
                at javax.servlet.http.HttpServletRequestWrapper.getSession(HttpServletRequestWrapper.java:227)
                at org.apache.myfaces.context.servlet.SessionMap.getSession(SessionMap.java:75)
                at org.apache.myfaces.context.servlet.SessionMap.getAttribute(SessionMap.java:46)
                at org.apache.myfaces.context.servlet.AbstractAttributeMap.get(AbstractAttributeMap.java:91)
                at com.icesoft.faces.context.effects.JavascriptContext.getIncludedLibs(JavascriptContext.java:129)
                at com.infinity.bpm.portal.common.filter.LoginFilter.includeCustomJS(LoginFilter.java:339)
                at com.infinity.bpm.portal.common.filter.LoginFilter.doFilter(LoginFilter.java:244)


It looks like deactivating KeepAlive in WLS for the Oracle database resources solves the issue (it is activated by default for 10g and 11g).

Re: NullPointerException during first login in on Weblogic [message #757519 is a reply to message #757518] Fri, 18 November 2011 18:04 Go to previous messageGo to next message
Jan Hendrik Scheufen is currently offline Jan Hendrik Scheufen
Messages: 61
Registered: October 2011
Member

We've seen similar issues on Weblogic before and deactivating the "KeepAlive" usually solved it.
Re: NullPointerException during first login in on Weblogic [message #985574 is a reply to message #757518] Thu, 15 November 2012 14:03 Go to previous message
Y Wang is currently offline Y Wang
Messages: 1
Registered: November 2012
Junior Member
We have run into similiar problem recently, changing the keep-alive value solved the problem.
Previous Topic:Build Process
Next Topic:Send activemq message to CarnotApplicationQuque
Goto Forum:
  


Current Time: Sat Sep 20 01:59:41 GMT 2014

Powered by FUDForum. Page generated in 0.01605 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software