Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Maven Integration (M2E) » m2e + Spring DM Server Tools error(Error Updating Project Configuration in faceted OSGi Bundle Project)
m2e + Spring DM Server Tools error [message #756192] Fri, 11 November 2011 07:55
Castor Rodriguez is currently offline Castor Rodriguez
Messages: 4
Registered: August 2011
Junior Member
Hi!

In Spring STS forums we're discussing about an error produced when using plugins m2e and Spring DM Server Tools [1]

I don't know if we're actually doing something wrong or if it's really a bug from any of the two plugins.

Does anybody know what's going on? I mean... I know what the log is saying, but still don't know who's fault is...

STS Version: 2.7.2 Build Id: 201109131000-RELEASE
m2e Version: 1.0.100 Build Id: 20110804-1717
Spring DM Server Tools Version: 2.6.0 Build Id: 201103161000-RELEASE

Error:
Unable to update maven configuration for the following projects:
my-project      Problems encountered while setting project description


Log:
!ENTRY org.maven.ide.eclipse 2 4 2011-11-11 14:37:34.433
!MESSAGE Unable to update Maven configuration
!SUBENTRY 1 org.eclipse.core.resources 2 568 2011-11-11 14:37:34.433
!MESSAGE Problems encountered while setting project description.
!SUBENTRY 2 org.eclipse.core.resources 2 35 2011-11-11 14:37:34.433
!MESSAGE Cannot remove nature org.springframework.ide.eclipse.core.springnature because it is a prerequisite of nature org.eclipse.virgo.ide.facet.core.bundlenature.


Thanks!

(I can't post links yet)
[1] forum.springsource.org/showthread.php?113801-EclipseRT-OSGi-Bundle-facet-Maven-plugin-problems

[Updated on: Fri, 11 November 2011 07:56]

Report message to a moderator

Previous Topic:M2E Plugin does not has Enable Maven Feature on Dynamic Web Project
Next Topic:Maven WTP Project not respecting [provided] scope
Goto Forum:
  


Current Time: Mon Apr 21 05:46:54 EDT 2014

Powered by FUDForum. Page generated in 0.01551 seconds